ANN: PyQt v5.11 and SIP v4.19.9 Released

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

ANN: PyQt v5.11 and SIP v4.19.9 Released

Phil Thompson-5
PyQt v5.11 and SIP v4.19.9 have been released. There are corresponding releases of PyQt3D, PyQtChart, PyQtDataVisualization and PyQtPurchasing.

More detail can be found here...

https://www.riverbankcomputing.com/news/pyqt-5110
https://www.riverbankcomputing.com/news/sip-4199

Phil
_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: ANN: PyQt v5.11 and SIP v4.19.9 Released

Rex Dieter
Phil Thompson wrote:

> PyQt v5.11 and SIP v4.19.9 have been released. There are corresponding
> releases of PyQt3D, PyQtChart, PyQtDataVisualization and PyQtPurchasing.

sip-4.19.9 fails to build when using out-of-tree builds.  For example, this
used to work, but no longer does:

mkdir build
cd build
python ../configure.py
This is SIP 4.19.9 for Python 2.7.15 on linux2.
The SIP code generator will be installed in /usr/bin.
The sip module will be installed in /usr/lib64/python2.7/site-packages.
The sip.pyi stub file will be installed in /usr/lib64/python2.7/site-
packages.
The sip.h header file will be installed in /usr/include/python2.7.
The default directory to install .sip files in is /usr/share/sip.
Creating sipconfig.py...
Creating top level Makefile...
Creating sip code generator Makefile...
Creating sip module Makefile...
Error: Unable to open
"/var/tmp/kdecache-rdieter/BUILDROOT/sip-4.19.9/build/siplib/siplib.sbf"


-- Rex

_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: ANN: PyQt v5.11 and SIP v4.19.9 Released

Phil Thompson-5
On 24 Jun 2018, at 4:07 am, Rex Dieter <[hidden email]> wrote:

>
> Phil Thompson wrote:
>
>> PyQt v5.11 and SIP v4.19.9 have been released. There are corresponding
>> releases of PyQt3D, PyQtChart, PyQtDataVisualization and PyQtPurchasing.
>
> sip-4.19.9 fails to build when using out-of-tree builds.  For example, this
> used to work, but no longer does:
>
> mkdir build
> cd build
> python ../configure.py
> This is SIP 4.19.9 for Python 2.7.15 on linux2.
> The SIP code generator will be installed in /usr/bin.
> The sip module will be installed in /usr/lib64/python2.7/site-packages.
> The sip.pyi stub file will be installed in /usr/lib64/python2.7/site-
> packages.
> The sip.h header file will be installed in /usr/include/python2.7.
> The default directory to install .sip files in is /usr/share/sip.
> Creating sipconfig.py...
> Creating top level Makefile...
> Creating sip code generator Makefile...
> Creating sip module Makefile...
> Error: Unable to open
> "/var/tmp/kdecache-rdieter/BUILDROOT/sip-4.19.9/build/siplib/siplib.sbf"

Should be fixed in v4.19.11.

Thanks,
Phil
_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: ANN: PyQt v5.11 and SIP v4.19.9 Released

Rex Dieter
In reply to this post by Phil Thompson-5
Phil Thompson wrote:

> PyQt v5.11 and SIP v4.19.9 have been released. There are corresponding
> releases of PyQt3D, PyQtChart, PyQtDataVisualization and PyQtPurchasing.

Found another build failure, fails when not using --no-dist-info along with
'make install DESTDIR=...'

/usr/bin/python2 mk_distinfo.py /usr/lib64/python2.7/site-
packages/sip-4.19.9.dist-info installed.txt
unable to create /usr/lib64/python2.7/site-packages/sip-4.19.9.dist-info

This step seems to not take DESTDIR into account.

-- rex

_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: dist-info fails when using DESTDIR

Rex Dieter
Rex Dieter wrote:

> Phil Thompson wrote:
>
>> PyQt v5.11 and SIP v4.19.9 have been released. There are corresponding
>> releases of PyQt3D, PyQtChart, PyQtDataVisualization and PyQtPurchasing.
>
> Found another build failure, fails when not using --no-dist-info along
> with 'make install DESTDIR=...'
>
> /usr/bin/python2 mk_distinfo.py /usr/lib64/python2.7/site-
> packages/sip-4.19.9.dist-info installed.txt
> unable to create /usr/lib64/python2.7/site-packages/sip-4.19.9.dist-info
>
> This step seems to not take DESTDIR into account.

This problem persists with latest sip-4.19.11

-- Rex

_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: dist-info fails when using DESTDIR

Phil Thompson-5
On 1 Jul 2018, at 3:07 pm, Rex Dieter <[hidden email]> wrote:

>
> Rex Dieter wrote:
>
>> Phil Thompson wrote:
>>
>>> PyQt v5.11 and SIP v4.19.9 have been released. There are corresponding
>>> releases of PyQt3D, PyQtChart, PyQtDataVisualization and PyQtPurchasing.
>>
>> Found another build failure, fails when not using --no-dist-info along
>> with 'make install DESTDIR=...'
>>
>> /usr/bin/python2 mk_distinfo.py /usr/lib64/python2.7/site-
>> packages/sip-4.19.9.dist-info installed.txt
>> unable to create /usr/lib64/python2.7/site-packages/sip-4.19.9.dist-info
>>
>> This step seems to not take DESTDIR into account.
>
> This problem persists with latest sip-4.19.11

Works fine for me.

However there may be an issue with the contents of the RECORD file in the .dist-info directory as I assume it should reflect where the package will eventually be installed.

Phil
_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt