ARGPARSE ERROR

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Ank
Reply | Threaded
Open this post in threaded view
|

ARGPARSE ERROR

Ank
Hi all,

Iḿ trying to setup Catmaid - http://catmaid.readthedocs.io/en/stable/. Iḿ receiving this error when installing requirements.

Progressbar2 3.6.2 requires argparse, which is not installed.
twisted 17.9.0 requires zope.interface>=3.6.0, which is not installed.
matplotlib 2.1.0 requires backports.functools-lru-cache, which is not installed.
django-rest-swagger 2.1.2 has requirement djangorestframework>=3.5.4, but you'll have djangorestframework 3.5.3 which is incompatible



 How it can be resolved ?

Best
Ank

--
You received this message because you are subscribed to the Google Groups "Django users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/django-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/django-users/1fb16f72-1837-48f1-a8f6-c7bd64ca212f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: ARGPARSE ERROR

Babatunde Akinyanmi
This is not a django problem. Simply install and upgrade the apps specified in the error message 

On Thu, 12 Apr 2018, 16:03 Ank, <[hidden email]> wrote:
Hi all,

Iḿ trying to setup Catmaid - http://catmaid.readthedocs.io/en/stable/. Iḿ receiving this error when installing requirements.

Progressbar2 3.6.2 requires argparse, which is not installed.
twisted 17.9.0 requires zope.interface>=3.6.0, which is not installed.
matplotlib 2.1.0 requires backports.functools-lru-cache, which is not installed.
django-rest-swagger 2.1.2 has requirement djangorestframework>=3.5.4, but you'll have djangorestframework 3.5.3 which is incompatible



 How it can be resolved ?

Best
Ank

--
You received this message because you are subscribed to the Google Groups "Django users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/django-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/django-users/1fb16f72-1837-48f1-a8f6-c7bd64ca212f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Django users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/django-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/django-users/CA%2BWjgXMHx_zdBtc_NG%2Bn1JMfi4oxTPHy_1y2Pw75VpxfX%2BxuqA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Ank
Reply | Threaded
Open this post in threaded view
|

Re: ARGPARSE ERROR

Ank
Hi Babatunde , 
I installed other listed tools ! Here the main concern im talking about is Argsparse - 
the Progressbar2 3.6.2 requires argparse, which is not installed.
Thanks in advance 
Ank





On Thu, 12 Apr 2018 at 20:53, Babatunde Akinyanmi <[hidden email]> wrote:
This is not a django problem. Simply install and upgrade the apps specified in the error message 

On Thu, 12 Apr 2018, 16:03 Ank, <[hidden email]> wrote:
Hi all,

Iḿ trying to setup Catmaid - http://catmaid.readthedocs.io/en/stable/. Iḿ receiving this error when installing requirements.

Progressbar2 3.6.2 requires argparse, which is not installed.
twisted 17.9.0 requires zope.interface>=3.6.0, which is not installed.
matplotlib 2.1.0 requires backports.functools-lru-cache, which is not installed.
django-rest-swagger 2.1.2 has requirement djangorestframework>=3.5.4, but you'll have djangorestframework 3.5.3 which is incompatible



 How it can be resolved ?

Best
Ank

--
You received this message because you are subscribed to the Google Groups "Django users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/django-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/django-users/1fb16f72-1837-48f1-a8f6-c7bd64ca212f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Django users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/django-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/django-users/CA%2BWjgXMHx_zdBtc_NG%2Bn1JMfi4oxTPHy_1y2Pw75VpxfX%2BxuqA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Django users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/django-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/django-users/CAALWEk2D4B%3D%3Dw%2BD1BK3TpZQ8fEwCE8-s8nDWMZztO3ZPu4tBXw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: ARGPARSE ERROR

Michal Petrucha-3
On Thu, Apr 12, 2018 at 07:58:08PM +0000, Ankush Sharma wrote:
> Hi Babatunde ,
> I installed other listed tools ! Here the main concern im talking about is
> Argsparse -
> the Progressbar2 3.6.2 requires argparse, which is not installed.
> Thanks in advance
> Ank

What version of Python are you running this on? Either it's a very old
one (2.6, 3.1), which would be unsupported by pretty much any
reasonably recent Python package, or your Python environment is messed
up somehow, and it lacks a part of the standard library. If the former
is the case, you need to migrate to a newer Python; if the latter,
then you need to fix your Python installation, and make sure that it
includes the entire standard library.

Good luck,

Michal

--
You received this message because you are subscribed to the Google Groups "Django users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/django-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/django-users/20180413090646.GN1181%40koniiiik.org.
For more options, visit https://groups.google.com/d/optout.

signature.asc (836 bytes) Download Attachment
Ank
Reply | Threaded
Open this post in threaded view
|

Re: ARGPARSE ERROR

Ank
HI all ,

Installed Python 3.5 and still getting an error

django-rest-swagger 2.1.2 has requirement djangorestframework>=3.5.4, but you'll have djangorestframework 3.5.3 which is incompatible.


Any pointers to solve this

Thanks in advance

best
Ankush

On Friday, April 13, 2018 at 11:07:58 AM UTC+2, Michal Petrucha wrote:
On Thu, Apr 12, 2018 at 07:58:08PM +0000, Ankush Sharma wrote:
> Hi Babatunde ,
> I installed other listed tools ! Here the main concern im talking about is
> Argsparse -
> the Progressbar2 3.6.2 requires argparse, which is not installed.
> Thanks in advance
> Ank

What version of Python are you running this on? Either it's a very old
one (2.6, 3.1), which would be unsupported by pretty much any
reasonably recent Python package, or your Python environment is messed
up somehow, and it lacks a part of the standard library. If the former
is the case, you need to migrate to a newer Python; if the latter,
then you need to fix your Python installation, and make sure that it
includes the entire standard library.

Good luck,

Michal

--
You received this message because you are subscribed to the Google Groups "Django users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/django-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/django-users/65019800-10a1-40bb-98e0-a22a74cc6ac5%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: ARGPARSE ERROR

Aditya Singh
You need to download the latest version of django rest framework same as the version specified. If you need help on the commands let me know mate. Give it a shot it should help.
Kind Regards,
Aditya


On Mon, Apr 16, 2018, 3:57 PM Ank <[hidden email]> wrote:
HI all ,

Installed Python 3.5 and still getting an error

django-rest-swagger 2.1.2 has requirement djangorestframework>=3.5.4, but you'll have djangorestframework 3.5.3 which is incompatible.


Any pointers to solve this

Thanks in advance

best
Ankush

On Friday, April 13, 2018 at 11:07:58 AM UTC+2, Michal Petrucha wrote:
On Thu, Apr 12, 2018 at 07:58:08PM +0000, Ankush Sharma wrote:
> Hi Babatunde ,
> I installed other listed tools ! Here the main concern im talking about is
> Argsparse -
> the Progressbar2 3.6.2 requires argparse, which is not installed.
> Thanks in advance
> Ank

What version of Python are you running this on? Either it's a very old
one (2.6, 3.1), which would be unsupported by pretty much any
reasonably recent Python package, or your Python environment is messed
up somehow, and it lacks a part of the standard library. If the former
is the case, you need to migrate to a newer Python; if the latter,
then you need to fix your Python installation, and make sure that it
includes the entire standard library.

Good luck,

Michal

--
You received this message because you are subscribed to the Google Groups "Django users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/django-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/django-users/65019800-10a1-40bb-98e0-a22a74cc6ac5%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Django users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/django-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/django-users/CAEPfumhWmqc4RMxeODHJX2DSacMox61sqhtnxdik5%2Bv7fCqh2w%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: ARGPARSE ERROR

Anthony Flury
In reply to this post by Ank
Are you using virtual environments ?

I found an issues where it seemed like part of the standard library was
missing - and it was due to my virtual environment having an old version
of the Python 2 binary. Some time in the Python 2.7 lifecycle, there was
a change as to how the standard library C code modules were included in
the binary.

If you are using the 'pip' command you are likely to be using the Python
2 pip - even if you have Python 3.5 installed.

I would :

 1. Check if you are using a virtual environment
 2. Check the version of Python 2.7 you are using; the latest available
    is 2.7.14
 3. If you are using a virtual env and it is out of date (but your
    system wide Python2.7 is ok), you can simply copy the python binary
    over.
 4. If both virtual env and System Python are ok - double check your pip
    version, and Django version (although I doubt they are the issue).
 5. If your system is out of date - update the system version.

I am not sure the same issue exists with old Python 3 versions - but it
might be worth ensuring that you up to date versions of Python3.x and
also 'pip3' which is the Python3 version of pip on systems with both
Python 2 & Python 3 installed.

Good luck.

--
Anthony Flury
email : *[hidden email]*
Twitter : *@TonyFlury <https://twitter.com/TonyFlury/>*

On 12/04/18 20:58, Ankush Sharma wrote:

> Hi Babatunde ,
> I installed other listed tools ! Here the main concern im talking
> about is Argsparse -
> the Progressbar2 3.6.2 requires argparse, which is not installed.
> Thanks in advance
> Ank
>
>
>
>
>
> On Thu, 12 Apr 2018 at 20:53, Babatunde Akinyanmi
> <[hidden email] <mailto:[hidden email]>> wrote:
>
>     This is not a django problem. Simply install and upgrade the apps
>     specified in the error message
>
>     On Thu, 12 Apr 2018, 16:03 Ank, <[hidden email]
>     <mailto:[hidden email]>> wrote:
>
>         Hi all,
>
>         Iḿ trying to setup Catmaid -
>         http://catmaid.readthedocs.io/en/stable/. Iḿ receiving this
>         error when installing requirements.
>
>         Progressbar2 3.6.2 requires argparse, which is not installed.
>         twisted 17.9.0 requires zope.interface>=3.6.0, which is not
>         installed.
>         matplotlib 2.1.0 requires backports.functools-lru-cache, which
>         is not installed.
>         django-rest-swagger 2.1.2 has requirement
>         djangorestframework>=3.5.4, but you'll have
>         djangorestframework 3.5.3 which is incompatible
>
>
>
>          How it can be resolved ?
>
>         Best
>         Ank
>         --
>         You received this message because you are subscribed to the
>         Google Groups "Django users" group.
>         To unsubscribe from this group and stop receiving emails from
>         it, send an email to [hidden email]
>         <mailto:[hidden email]>.
>         To post to this group, send email to
>         [hidden email]
>         <mailto:[hidden email]>.
>         Visit this group at https://groups.google.com/group/django-users.
>         To view this discussion on the web visit
>         https://groups.google.com/d/msgid/django-users/1fb16f72-1837-48f1-a8f6-c7bd64ca212f%40googlegroups.com
>         <https://groups.google.com/d/msgid/django-users/1fb16f72-1837-48f1-a8f6-c7bd64ca212f%40googlegroups.com?utm_medium=email&utm_source=footer>.
>         For more options, visit https://groups.google.com/d/optout.
>
>     --
>     You received this message because you are subscribed to the Google
>     Groups "Django users" group.
>     To unsubscribe from this group and stop receiving emails from it,
>     send an email to [hidden email]
>     <mailto:[hidden email]>.
>     To post to this group, send email to [hidden email]
>     <mailto:[hidden email]>.
>     Visit this group at https://groups.google.com/group/django-users.
>     To view this discussion on the web visit
>     https://groups.google.com/d/msgid/django-users/CA%2BWjgXMHx_zdBtc_NG%2Bn1JMfi4oxTPHy_1y2Pw75VpxfX%2BxuqA%40mail.gmail.com
>     <https://groups.google.com/d/msgid/django-users/CA%2BWjgXMHx_zdBtc_NG%2Bn1JMfi4oxTPHy_1y2Pw75VpxfX%2BxuqA%40mail.gmail.com?utm_medium=email&utm_source=footer>.
>     For more options, visit https://groups.google.com/d/optout.
>
> --
> You received this message because you are subscribed to the Google
> Groups "Django users" group.
> To unsubscribe from this group and stop receiving emails from it, send
> an email to [hidden email]
> <mailto:[hidden email]>.
> To post to this group, send email to [hidden email]
> <mailto:[hidden email]>.
> Visit this group at https://groups.google.com/group/django-users.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/django-users/CAALWEk2D4B%3D%3Dw%2BD1BK3TpZQ8fEwCE8-s8nDWMZztO3ZPu4tBXw%40mail.gmail.com 
> <https://groups.google.com/d/msgid/django-users/CAALWEk2D4B%3D%3Dw%2BD1BK3TpZQ8fEwCE8-s8nDWMZztO3ZPu4tBXw%40mail.gmail.com?utm_medium=email&utm_source=footer>.
> For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Django users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/django-users.
To view this discussion on the web visit https://groups.google.com/d/msgid/django-users/52f2cbd4-28cd-2f6b-70d7-24a37e97068a%40btinternet.com.
For more options, visit https://groups.google.com/d/optout.