Abnormal behaviour on "replace" form.

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Abnormal behaviour on "replace" form.

Kachanovsky R.S.
Hello.

When I try to replace some text in the text, which ends with a backslash "\" - IDLE is closed.
For example: http://clip2net.com/clip/m58534/1316678588-clip-6kb.png
I know about the escape-sequence \\, but it is very unexpected behavior.

Sorry for my bad English. I use IDLE v3.2.1

--
Best regards.
 Kachanovsky R.S.                         mailto:[hidden email]

_______________________________________________
IDLE-dev mailing list
[hidden email]
http://mail.python.org/mailman/listinfo/idle-dev
Reply | Threaded
Open this post in threaded view
|

Re: Abnormal behaviour on "replace" form.

Ned Deily
In article <[hidden email]>,
 Kachanovsky R.S. <[hidden email]> wrote:
> When I try to replace some text in the text, which ends with a backslash "\"
> - IDLE is closed.
> For example: http://clip2net.com/clip/m58534/1316678588-clip-6kb.png
> I know about the escape-sequence \\, but it is very unexpected behavior.
>
> Sorry for my bad English. I use IDLE v3.2.1

That appears to be a bug in IDLE.  It would be nice if you could open an
issue about it on the Python bug tracker:

http://bugs.python.org/

--
 Ned Deily,
 [hidden email]

_______________________________________________
IDLE-dev mailing list
[hidden email]
http://mail.python.org/mailman/listinfo/idle-dev
Reply | Threaded
Open this post in threaded view
|

Re: Abnormal behaviour on "replace" form.

Terry Reedy
On 9/24/2011 3:57 AM, Ned Deily wrote:
> In article<[hidden email]>,
>   Kachanovsky R.S.<[hidden email]>  wrote:
>> When I try to replace some text in the text, which ends with a backslash "\"
>> - IDLE is closed.

Verified with 3.2.2 on Win7, with a couple of seconds delay.

>> For example: http://clip2net.com/clip/m58534/1316678588-clip-6kb.png
>> I know about the escape-sequence \\, but it is very unexpected behavior.
>>
>> Sorry for my bad English. I use IDLE v3.2.1

You English is fine. Thank you for reporting this.
>
> That appears to be a bug in IDLE.

Or if in tkinter, one to avoid by checking replace strings.

>  It would be nice if you could open an
> issue about it on the Python bug tracker:
>
> http://bugs.python.org/

If you do, attach the .png and add terry.reedy as nosy.
What you already wrote above is enough.
If you do not wish too, please say so, and I will.

--
Terry Jan Reedy

_______________________________________________
IDLE-dev mailing list
[hidden email]
http://mail.python.org/mailman/listinfo/idle-dev
Reply | Threaded
Open this post in threaded view
|

Re: Abnormal behaviour on "replace" form.

Terry Reedy
On 9/24/2011 8:51 PM, Terry Reedy wrote:
> If you do, attach the .png and add terry.reedy as nosy.
> What you already wrote above is enough.
> If you do not wish too, please say so, and I will.

No reply, so I opened http://bugs.python.org/issue1305

--
Terry Jan Reedy

_______________________________________________
IDLE-dev mailing list
[hidden email]
http://mail.python.org/mailman/listinfo/idle-dev
Reply | Threaded
Open this post in threaded view
|

Re: Abnormal behaviour on "replace" form.

Weeble
On Wed, Sep 28, 2011 at 3:44 AM, Terry Reedy <[hidden email]> wrote:
> No reply, so I opened http://bugs.python.org/issue1305

Looks like that got truncated. I think the link should be:

http://bugs.python.org/issue13052
_______________________________________________
IDLE-dev mailing list
[hidden email]
http://mail.python.org/mailman/listinfo/idle-dev