Building SIP/PyQt5 for Python 2.7 on Windows

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Building SIP/PyQt5 for Python 2.7 on Windows

Arve Knudsen-2
Hi

I need to build SIP and PyQt5 for Python 2.7 on Windows, using Visual Studio. How does one get hold of the right version of Visual Studio (2008) these days?

Thanks,
Arve

_______________________________________________
PyQt mailing list    [hidden email]
http://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: Building SIP/PyQt5 for Python 2.7 on Windows

Andreas Pakulat
Hi,

On Mon, Apr 7, 2014 at 12:24 PM, Arve Knudsen <[hidden email]> wrote:
Hi

I need to build SIP and PyQt5 for Python 2.7 on Windows, using Visual Studio. How does one get hold of the right version of Visual Studio (2008) these days?

Talk to the vendor of the tool you need, aka Microsoft or check if you can get it from a retailer somewhere 

Andreas

_______________________________________________
PyQt mailing list    [hidden email]
http://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: Building SIP/PyQt5 for Python 2.7 on Windows

V. Armando Solé
On 07/04/2014 13:32, Andreas Pakulat wrote:
Hi,

On Mon, Apr 7, 2014 at 12:24 PM, Arve Knudsen <[hidden email]> wrote:
Hi

I need to build SIP and PyQt5 for Python 2.7 on Windows, using Visual Studio. How does one get hold of the right version of Visual Studio (2008) these days?

Talk to the vendor of the tool you need, aka Microsoft or check if you can get it from a retailer somewhere 

Andreas

To say that better say nothing.

The Visual Studio 2008 Express edition complemented with the Windows SDK used to be fine simply the link is a bit "hard to find these days" because now one gets directed to the 2102 version.

You can give a try to:

http://go.microsoft.com/fwlink/?LinkId=104679

Although I have not tested it with PyQt5, it should provide at least the appropriate compiler.

Armando



_______________________________________________
PyQt mailing list    [hidden email]
http://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: Building SIP/PyQt5 for Python 2.7 on Windows

Arve Knudsen-2
Thank you!

Arve


On Mon, Apr 7, 2014 at 3:57 PM, "V. Armando Solé" <[hidden email]> wrote:
On 07/04/2014 13:32, Andreas Pakulat wrote:
Hi,

On Mon, Apr 7, 2014 at 12:24 PM, Arve Knudsen <[hidden email]> wrote:
Hi

I need to build SIP and PyQt5 for Python 2.7 on Windows, using Visual Studio. How does one get hold of the right version of Visual Studio (2008) these days?

Talk to the vendor of the tool you need, aka Microsoft or check if you can get it from a retailer somewhere 

Andreas

To say that better say nothing.

The Visual Studio 2008 Express edition complemented with the Windows SDK used to be fine simply the link is a bit "hard to find these days" because now one gets directed to the 2102 version.

You can give a try to:

http://go.microsoft.com/fwlink/?LinkId=104679

Although I have not tested it with PyQt5, it should provide at least the appropriate compiler.

Armando



_______________________________________________
PyQt mailing list    [hidden email]
http://www.riverbankcomputing.com/mailman/listinfo/pyqt


_______________________________________________
PyQt mailing list    [hidden email]
http://www.riverbankcomputing.com/mailman/listinfo/pyqt