Quantcast

Can pylauncher run pip or easy_install for different versions of Python?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Can pylauncher run pip or easy_install for different versions of Python?

Mark Lawrence
Hi all,

I've tried reading PEP397 and this
https://bitbucket.org/vinay.sajip/pylauncher/src/tip/Doc/launcher.rst 
but couldn't get my head around it, so the question is as the subject.

As an aside, are people aware that there is already a pylauncher see
http://pylauncher.garage.maemo.org/ ?

--
Cheers.

Mark Lawrence.

_______________________________________________
python-win32 mailing list
[hidden email]
http://mail.python.org/mailman/listinfo/python-win32
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Can pylauncher run pip or easy_install for different versions of Python?

Randy Syring-2
Looks like it could, but you would have to give it the version you wanted and then pass in the path to the pip or easy_install script. 

But, maybe its not needed.  On my system, the .exe files are installed with and without the version numbers.  So, I have:

Directory of c:\Python26\Scripts

02/11/2011  04:07 PM    <DIR>          .
02/11/2011  04:07 PM    <DIR>          ..
<snip>
10/20/2009  06:08 AM               286 easy_install-2.6-script.py
11/22/2010  03:04 PM               355 easy_install-2.6-script.pyc
11/22/2010  03:04 PM               355 easy_install-2.6-script.pyo
10/20/2009  06:08 AM             7,168 easy_install-2.6.exe
10/20/2009  06:08 AM               515 easy_install-2.6.exe.manifest
10/20/2009  06:08 AM               278 easy_install-script.py
11/22/2010  03:04 PM               347 easy_install-script.pyc
11/22/2010  03:04 PM               347 easy_install-script.pyo
10/20/2009  06:08 AM             7,168 easy_install.exe
10/20/2009  06:08 AM               511 easy_install.exe.manifest
<snip>
12/06/2010  03:54 PM               265 pip-2.6-script.py
12/06/2010  03:54 PM             7,168 pip-2.6.exe
12/06/2010  03:54 PM               522 pip-2.6.exe.manifest
12/06/2010  03:54 PM               257 pip-script.py
12/06/2010  03:54 PM             7,168 pip.exe
12/06/2010  03:54 PM               518 pip.exe.manifest
And similar for my 2.7 install.  So, the following commands should work for installing for specific versions of python if the Scripts directories are all on your PATH:

easy_install-2.6
easy_install-2.7
pip-2.6
pip-2.7

If that isn't sufficient, maybe you can tell us more about what you are trying to do.  The pylauncher docs seemed pretty thorough, is there something specific you don't understand?
---------------------------------------------
Randy Syring
Development & Executive Director
Level 12 Technologies
Direct: 502-276-0459
Office: 502-212-9913

Principled People, Technology that Works

On 04/12/2012 11:58 PM, Mark Lawrence wrote:
Hi all,

I've tried reading PEP397 and this https://bitbucket.org/vinay.sajip/pylauncher/src/tip/Doc/launcher.rst but couldn't get my head around it, so the question is as the subject.

As an aside, are people aware that there is already a pylauncher see http://pylauncher.garage.maemo.org/ ?


_______________________________________________
python-win32 mailing list
[hidden email]
http://mail.python.org/mailman/listinfo/python-win32
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Can pylauncher run pip or easy_install for different versions of Python?

Brian Curtin
In reply to this post by Mark Lawrence
On Thu, Apr 12, 2012 at 22:58, Mark Lawrence <[hidden email]> wrote:
> Hi all,
>
> I've tried reading PEP397 and this
> https://bitbucket.org/vinay.sajip/pylauncher/src/tip/Doc/launcher.rst but
> couldn't get my head around it, so the question is as the subject.
>
> As an aside, are people aware that there is already a pylauncher see
> http://pylauncher.garage.maemo.org/ ?

I don't think the name matters all that much. It'll be included
directly in the CPython installers, and the launcher itself is called
py.exe anyway, so "pylauncher" is just some folder name under Vinay's
account.
_______________________________________________
python-win32 mailing list
[hidden email]
http://mail.python.org/mailman/listinfo/python-win32
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Can pylauncher run pip or easy_install for different versions of Python?

Mark Lawrence
In reply to this post by Randy Syring-2
On 13/04/2012 05:12, Randy Syring wrote:

> Looks like it could, but you would have to give it the version you
> wanted and then pass in the path to the pip or easy_install script.
>
> But, maybe its not needed. On my system, the .exe files are installed
> with and without the version numbers. So, I have:
>
> Directory of c:\Python26\Scripts
>
> 02/11/2011 04:07 PM <DIR> .
> 02/11/2011 04:07 PM <DIR> ..
> <snip>
> 10/20/2009 06:08 AM 286 easy_install-2.6-script.py
> 11/22/2010 03:04 PM 355 easy_install-2.6-script.pyc
> 11/22/2010 03:04 PM 355 easy_install-2.6-script.pyo
> 10/20/2009 06:08 AM 7,168 easy_install-2.6.exe
> 10/20/2009 06:08 AM 515 easy_install-2.6.exe.manifest
> 10/20/2009 06:08 AM 278 easy_install-script.py
> 11/22/2010 03:04 PM 347 easy_install-script.pyc
> 11/22/2010 03:04 PM 347 easy_install-script.pyo
> 10/20/2009 06:08 AM 7,168 easy_install.exe
> 10/20/2009 06:08 AM 511 easy_install.exe.manifest
> <snip>
> 12/06/2010 03:54 PM 265 pip-2.6-script.py
> 12/06/2010 03:54 PM 7,168 pip-2.6.exe
> 12/06/2010 03:54 PM 522 pip-2.6.exe.manifest
> 12/06/2010 03:54 PM 257 pip-script.py
> 12/06/2010 03:54 PM 7,168 pip.exe
> 12/06/2010 03:54 PM 518 pip.exe.manifest
>
> And similar for my 2.7 install. So, the following commands should work
> for installing for specific versions of python if the Scripts
> directories are all on your PATH:
>
> easy_install-2.6
> easy_install-2.7
> pip-2.6
> pip-2.7
>
> If that isn't sufficient, maybe you can tell us more about what you are
> trying to do. The pylauncher docs seemed pretty thorough, is there
> something specific you don't understand?
>
> ---------------------------------------------
> Randy Syring
> Development& Executive Director
> Level 12 Technologies <https://www.lev12.com/>
> Direct: 502-276-0459
> Office: 502-212-9913
>
> Principled People, Technology that Works
>
>
> On 04/12/2012 11:58 PM, Mark Lawrence wrote:
>> Hi all,
>>
>> I've tried reading PEP397 and this
>> https://bitbucket.org/vinay.sajip/pylauncher/src/tip/Doc/launcher.rst
>> but couldn't get my head around it, so the question is as the subject.
>>
>> As an aside, are people aware that there is already a pylauncher see
>> http://pylauncher.garage.maemo.org/ ?
>>
> _______________________________________________
> python-win32 mailing list
> [hidden email]
> http://mail.python.org/mailman/listinfo/python-win32

Thanks for the fast response, it had never occurred to me that there
were version numbers available for these programs, so that's my question
answered.

--
Cheers.

Mark Lawrence.

_______________________________________________
python-win32 mailing list
[hidden email]
http://mail.python.org/mailman/listinfo/python-win32
Loading...