Can't install eric 19 in debian 9.6

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Can't install eric 19 in debian 9.6

starglider.dev
I get this error:
Shall 'QScintilla' be installed using pip? (Y/n) Y
Requirement already satisfied: QScintilla in /usr/local/lib/python3.5/dist-packages
Requirement already satisfied: PyQt5>=5.10.1 in /usr/local/lib/python3.5/dist-packages (from QScintilla)
Requirement already satisfied: sip<4.20,>=4.19.4 in /usr/local/lib/python3.5/dist-packages (from PyQt5>=5.10.1->QScintilla)
Sorry, please install QScintilla2 and
its PyQt5/PyQt4 wrapper.
Error: /usr/local/lib/python3.5/dist-packages/PyQt5/Qt/lib/libQt5Core.so.5: version `Qt_5.11' not found (required by /usr/local/lib/python3.5/dist-packages/PyQt5/Qsci.so)


_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: Can't install eric 19 in debian 9.6

Detlev Offenbach
Hi,

it seems that QSci and Qt are not compatible. QScintilla wants Qt version 5.11
but your Qt seems to be different. Maybe you have two different variants/
versions of Qt installed (one via the package management and one via the PyQt5
wheels).

Detlev

Am Donnerstag, 10. Januar 2019, 23:24:59 CET schrieb Starglider Developer:

> I get this error:
> Shall 'QScintilla' be installed using pip? (Y/n) Y
> Requirement already satisfied: QScintilla in
> /usr/local/lib/python3.5/dist-packages
> Requirement already satisfied: PyQt5>=5.10.1 in
> /usr/local/lib/python3.5/dist-packages (from QScintilla)
> Requirement already satisfied: sip<4.20,>=4.19.4 in
> /usr/local/lib/python3.5/dist-packages (from PyQt5>=5.10.1->QScintilla)
> Sorry, please install QScintilla2 and
> its PyQt5/PyQt4 wrapper.
> Error: /usr/local/lib/python3.5/dist-packages/PyQt5/Qt/lib/libQt5Core.so.5:
> version `Qt_5.11' not found (required by
> /usr/local/lib/python3.5/dist-packages/PyQt5/Qsci.so)

--
Detlev Offenbach
[hidden email]


_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: Can't install eric 19 in debian 9.6

Guðjón Guðjónsson
Hi

On Fri, Jan 11, 2019 at 10:57 AM Detlev Offenbach
<[hidden email]> wrote:

> it seems that QSci and Qt are not compatible. QScintilla wants Qt version 5.11
> but your Qt seems to be different. Maybe you have two different variants/
> versions of Qt installed (one via the package management and one via the PyQt5
> wheels).
> Am Donnerstag, 10. Januar 2019, 23:24:59 CET schrieb Starglider Developer:
> > I get this error:
> > Shall 'QScintilla' be installed using pip? (Y/n) Y
> > Requirement already satisfied: QScintilla in
> > /usr/local/lib/python3.5/dist-packages
> > Requirement already satisfied: PyQt5>=5.10.1 in
> > /usr/local/lib/python3.5/dist-packages (from QScintilla)
> > Requirement already satisfied: sip<4.20,>=4.19.4 in
> > /usr/local/lib/python3.5/dist-packages (from PyQt5>=5.10.1->QScintilla)
> > Sorry, please install QScintilla2 and
> > its PyQt5/PyQt4 wrapper.
> > Error: /usr/local/lib/python3.5/dist-packages/PyQt5/Qt/lib/libQt5Core.so.5:
> > version `Qt_5.11' not found (required by
> > /usr/local/lib/python3.5/dist-packages/PyQt5/Qsci.so)
I agree with Detlev.

The QScintilla version in Debian is 2.9.3. I don't know if that
version is compatible with eric 19 but I suggest that you
stick to the Debian packages as much as possible.
If you want to go outside of the package system you need to remove the
conflicting Debian packages.

You can also upgrade to Debian Unstable (I run that myself) or we
could backport eric to stable.

Hope that helps.

Gudjon
_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: Can't install eric 19 in debian 9.6

Detlev Offenbach

Am Samstag, 12. Januar 2019, 08:19:50 CET schrieb Guðjón Guðjónsson:

> Hi
>
> On Fri, Jan 11, 2019 at 10:57 AM Detlev Offenbach
>
> <[hidden email]> wrote:
> > it seems that QSci and Qt are not compatible. QScintilla wants Qt version
> > 5.11 but your Qt seems to be different. Maybe you have two different
> > variants/ versions of Qt installed (one via the package management and
> > one via the PyQt5 wheels).
> >
> > Am Donnerstag, 10. Januar 2019, 23:24:59 CET schrieb Starglider Developer:
> > > I get this error:
> > > Shall 'QScintilla' be installed using pip? (Y/n) Y
> > > Requirement already satisfied: QScintilla in
> > > /usr/local/lib/python3.5/dist-packages
> > > Requirement already satisfied: PyQt5>=5.10.1 in
> > > /usr/local/lib/python3.5/dist-packages (from QScintilla)
> > > Requirement already satisfied: sip<4.20,>=4.19.4 in
> > > /usr/local/lib/python3.5/dist-packages (from PyQt5>=5.10.1->QScintilla)
> > > Sorry, please install QScintilla2 and
> > > its PyQt5/PyQt4 wrapper.
> > > Error:
> > > /usr/local/lib/python3.5/dist-packages/PyQt5/Qt/lib/libQt5Core.so.5:
> > > version `Qt_5.11' not found (required by
> > > /usr/local/lib/python3.5/dist-packages/PyQt5/Qsci.so)
>
> I agree with Detlev.
>
> The QScintilla version in Debian is 2.9.3. I don't know if that
> version is compatible with eric 19 but I suggest that you
> stick to the Debian packages as much as possible.
> If you want to go outside of the package system you need to remove the
> conflicting Debian packages.
>
> You can also upgrade to Debian Unstable (I run that myself) or we
> could backport eric to stable.
>

Another possibility would be to create a Python Virtual environment (python3 -
m venv), install the latest PyQt5 and QScintilla wheels in there and use this
environment to install and run eric6. I am doing this myself to be able to
test eric6 with various PyQt and Python variants (PyQt4/Py2, PyQt4/Py3 and
PyQt5/Py3).

Hope this helps also.

Detlev
--
Detlev Offenbach
[hidden email]


_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: Can't install eric 19 in debian 9.6

Detlev Offenbach
Maybe be doing

python3 -m pip install --upgrade PyQt5 QScintilla

will help. Do you have some older Qt libraries lying around? Maybe
uninstalling sip, PyQt5 and QScintilla and doing it from scratch will help.

Detlev

Am Samstag, 12. Januar 2019, 20:47:20 CET schrieb Starglider Developer:

> Update everything and get:
> python3 install.py
> Checking dependencies
> Python Version: 3.5.3
> Found PyQt5
> Found pyuic5
> QScintilla could not be detected.
> Error: /usr/local/lib/python3.5/dist-packages/PyQt5/Qt/lib/libQt5Core.so.5:
> version `Qt_5.11' not found (required by
> /usr/local/lib/python3.5/dist-packages/PyQt5/Qsci.so)
>
> Shall 'QScintilla' be installed using pip? (Y/n) y
> Requirement already satisfied: QScintilla in
> /usr/local/lib/python3.5/dist-packages
> Requirement already satisfied: PyQt5>=5.10.1 in
> /usr/local/lib/python3.5/dist-packages (from QScintilla)
> Requirement already satisfied: sip<4.20,>=4.19.4 in
> /usr/local/lib/python3.5/dist-packages (from PyQt5>=5.10.1->QScintilla)
> Sorry, please install QScintilla2 and
> its PyQt5/PyQt4 wrapper.
> Error: /usr/local/lib/python3.5/dist-packages/PyQt5/Qt/lib/libQt5Core.so.5:
> version `Qt_5.11' not found (required by
> /usr/local/lib/python3.5/dist-packages/PyQt5/Qsci.so)
>
> the python envirment check:
> 3.5.3 (default, Sep 27 2018, 17:25:39)
> [GCC 6.3.0 20170516]
> Qt version: 5.11.2
> SIP version: 4.19.13
> PyQt version: 5.11.3
>
>
>
> On Sat, 12 Jan 2019 at 09:51, Detlev Offenbach <[hidden email]>
>
> wrote:
> > Am Samstag, 12. Januar 2019, 08:19:50 CET schrieb Guðjón Guðjónsson:
> > > Hi
> > >
> > > On Fri, Jan 11, 2019 at 10:57 AM Detlev Offenbach
> > >
> > > <[hidden email]> wrote:
> > > > it seems that QSci and Qt are not compatible. QScintilla wants Qt
> >
> > version
> >
> > > > 5.11 but your Qt seems to be different. Maybe you have two different
> > > > variants/ versions of Qt installed (one via the package management and
> > > > one via the PyQt5 wheels).
> > > >
> > > > Am Donnerstag, 10. Januar 2019, 23:24:59 CET schrieb Starglider
> >
> > Developer:
> > > > > I get this error:
> > > > > Shall 'QScintilla' be installed using pip? (Y/n) Y
> > > > > Requirement already satisfied: QScintilla in
> > > > > /usr/local/lib/python3.5/dist-packages
> > > > > Requirement already satisfied: PyQt5>=5.10.1 in
> > > > > /usr/local/lib/python3.5/dist-packages (from QScintilla)
> > > > > Requirement already satisfied: sip<4.20,>=4.19.4 in
> > > > > /usr/local/lib/python3.5/dist-packages (from
> >
> > PyQt5>=5.10.1->QScintilla)
> >
> > > > > Sorry, please install QScintilla2 and
> > > > > its PyQt5/PyQt4 wrapper.
> > > > > Error:
> > > > > /usr/local/lib/python3.5/dist-packages/PyQt5/Qt/lib/libQt5Core.so.5:
> > > > > version `Qt_5.11' not found (required by
> > > > > /usr/local/lib/python3.5/dist-packages/PyQt5/Qsci.so)
> > >
> > > I agree with Detlev.
> > >
> > > The QScintilla version in Debian is 2.9.3. I don't know if that
> > > version is compatible with eric 19 but I suggest that you
> > > stick to the Debian packages as much as possible.
> > > If you want to go outside of the package system you need to remove the
> > > conflicting Debian packages.
> > >
> > > You can also upgrade to Debian Unstable (I run that myself) or we
> > > could backport eric to stable.
> >
> > Another possibility would be to create a Python Virtual environment
> > (python3 -
> > m venv), install the latest PyQt5 and QScintilla wheels in there and use
> > this
> > environment to install and run eric6. I am doing this myself to be able to
> > test eric6 with various PyQt and Python variants (PyQt4/Py2, PyQt4/Py3 and
> > PyQt5/Py3).
> >
> > Hope this helps also.
> >
> > Detlev
> > --
> > Detlev Offenbach
> > [hidden email]
> >
> >
> > _______________________________________________
> > PyQt mailing list    [hidden email]
> > https://www.riverbankcomputing.com/mailman/listinfo/pyqt

--
Detlev Offenbach
[hidden email]


_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt