Cannot 'configure' PyQt4.9 before build on Linuxmint

classic Classic list List threaded Threaded
17 messages Options
Reply | Threaded
Open this post in threaded view
|

Cannot 'configure' PyQt4.9 before build on Linuxmint

Nico Dufort
Hello,

I need to build PyQt4 for use with an existing software (The Foundry's Nuke6.3v4).  That software uses Python 2.6 which requires me to build a separate version of Python for my system (LinuxMint 12, w/ Python 2.7).

I have built python-2.6.7 fine.
I have built sip-4.13.1 fine.
I have built qt-everywhere-opensource-4.8.0 fine.
I fail on configuring PyQt-4.9 before evening building it (using /opt/python-2.6.7/bin/python2.6 ./configure.py -q /usr/local/Trolltech/Qt-4.8.0/bin/qmake -w):

Generating the C++ source for the QtDeclarative module...
"/opt/python-2.6.7/bin/sip" -w -o -P -x VendorID -t WS_X11 -x PyQt_OpenSSL -x PyQt_NoPrintRangeBug -t Qt_4_8_0 -x Py_v3 -g -a QtDeclarative.api -c /home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/QtDeclarative -b QtDeclarative/QtDeclarative.sbf -I /home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/sip /home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/sip/QtDeclarative/QtDeclarativemod.sip
sip: __or__() unsupported function return type - provide %MethodCode and a C++ signature
Error: Unable to create the C++ code.

Earlier this year, I managed to build PyQt4 on Ubuntu, but it was a version for Python 2.5.  I do not recall having any problem at all when I did.  I'm about to install VirtualBox to run a few test cases, but if anyone can point me towards what I may be doing wrong, that would be great.  Not sure if that -x Py_v3 is a hint.  Or perhaps there is a mismatch elsewhere in my packages?

Thanks. nico

--
"Attention, attention. Here and now, boys," the mynah repeated. "Here and now, boys."

_______________________________________________
PyQt mailing list    [hidden email]
http://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: Cannot 'configure' PyQt4.9 before build on Linuxmint

Phil Thompson-5
On Tue, 27 Dec 2011 10:32:36 +0100, Nico Dufort <[hidden email]> wrote:

> Hello,
>
> I need to build PyQt4 for use with an existing software (The Foundry's
> Nuke6.3v4).  That software uses Python 2.6 which requires me to build a
> separate version of Python for my system (LinuxMint 12, w/ Python 2.7).
>
> I have built python-2.6.7 fine.
> I have built sip-4.13.1 fine.
> I have built qt-everywhere-opensource-4.8.0 fine.
> I fail on configuring PyQt-4.9 before evening building it (using
> /opt/python-2.6.7/bin/python2.6
> ./configure.py -q /usr/local/Trolltech/Qt-4.8.0/bin/qmake -w):
>
> Generating the C++ source for the QtDeclarative module...
> "/opt/python-2.6.7/bin/sip" -w -o -P -x VendorID -t WS_X11 -x
PyQt_OpenSSL
> -x PyQt_NoPrintRangeBug -t Qt_4_8_0 -x Py_v3 -g -a QtDeclarative.api -c
> /home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/QtDeclarative -b
> QtDeclarative/QtDeclarative.sbf -I
> /home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/sip
>
/home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/sip/QtDeclarative/QtDeclarativemod.sip
> sip: __or__() unsupported function return type - provide %MethodCode and
a
> C++ signature
> Error: Unable to create the C++ code.
>
> Earlier this year, I managed to build PyQt4 on Ubuntu, but it was a
version
> for Python 2.5.  I do not recall having any problem at all when I did.
I'm
> about to install VirtualBox to run a few test cases, but if anyone can
> point me towards what I may be doing wrong, that would be great.  Not
sure
> if that -x Py_v3 is a hint.  Or perhaps there is a mismatch elsewhere in
my
> packages?
>
> Thanks. nico

Run...

/opt/python-2.6.7/bin/sip -V

...to make sure you are actually using the right version of sip.

Phil
_______________________________________________
PyQt mailing list    [hidden email]
http://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: Cannot 'configure' PyQt4.9 before build on Linuxmint

Nico Dufort
Hi Phil,

Thanks for the quick answer.  It does return the correct sip (4.13.1), and the output of the configure reported the correct version as well.

I just noticed a few errors from the output, but I do not think that would be related to my problem (sorry for the long output).  Anything I should worry about, or that I may be missing?
I am installing Ubuntu on virtualbox to see if it's my environment.

Thanks. nico.

nico@slimline:~/Downloads/py4nk/PyQt-x11-gpl-4.9$ /opt/python-2.6.7/bin/python2.6 ./configure.py -q /usr/local/Trolltech/Qt-4.8.0/bin/qmake -w
Determining the layout of your Qt installation...
/usr/local/Trolltech/Qt-4.8.0/bin/qmake -o qtdirs.mk qtdirs.pro
make -f qtdirs.mk
g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -DQT_NO_DEBUG -DQT_CORE_LIB -DQT_SHARED -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/linux-g++-64 -I. -I/usr/local/Trolltech/Qt-4.8.0/include/QtCore -I/usr/local/Trolltech/Qt-4.8.0/include -I. -o qtdirs.o qtdirs.cpp
g++ -m64 -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -o qtdirs qtdirs.o    -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtCore -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread 
./qtdirs
This is the GPL version of PyQt 4.9 (licensed under the GNU General Public
License) for Python 2.6.7 on linux3.

Type '2' to view the GPL v2 license.
Type '3' to view the GPL v3 license.
Type 'yes' to accept the terms of the license.
Type 'no' to decline the terms of the license.

Do you accept the terms of the license? yes
Found the license file pyqt-gpl.sip.
Checking to see if the QtGui module should be built...
g++ -DQT_NO_DEBUG -DQT_GUI_LIB -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default -I/usr/local/Trolltech/Qt-4.8.0/include/QtGui -I/usr/local/Trolltech/Qt-4.8.0/include -I/usr/X11R6/include -m64 -pipe -O2 -w -D_REENTRANT cfgtest_QtGui.cpp -o cfgtest_QtGui -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtGui -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64 -lQtCore -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lXext -lX11 -lm -lpthread
Checking to see if the QtHelp module should be built...
g++ -DQT_NO_DEBUG -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default -I/usr/local/Trolltech/Qt-4.8.0/include/QtHelp -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT cfgtest_QtHelp.cpp -o cfgtest_QtHelp -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtHelp -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtSql -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtGui -L/usr/X11R6/lib64 -lQtNetwork -lQtCore -lpthread -lpthread
Checking to see if the QtMultimedia module should be built...
g++ -DQT_NO_DEBUG -DQT_MULTIMEDIA_LIB -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default -I/usr/local/Trolltech/Qt-4.8.0/include/QtMultimedia -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT cfgtest_QtMultimedia.cpp -o cfgtest_QtMultimedia -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtMultimedia -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtGui -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64 -lQtCore -lpthread -lpthread
Checking to see if the QtNetwork module should be built...
g++ -DQT_NO_DEBUG -DQT_NETWORK_LIB -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default -I/usr/local/Trolltech/Qt-4.8.0/include/QtNetwork -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT cfgtest_QtNetwork.cpp -o cfgtest_QtNetwork -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtNetwork -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtCore -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lpthread
Checking to see if the QtDBus module should be built...
g++ -DQT_NO_DEBUG -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default -I/usr/local/Trolltech/Qt-4.8.0/include/QtDBus -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT cfgtest_QtDBus.cpp -o cfgtest_QtDBus -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtDBus -lpthread
cfgtest_QtDBus.cpp:1:29: fatal error: qdbusconnection.h: No such file or directory
compilation terminated.
Checking to see if the QtDeclarative module should be built...
g++ -DQT_NO_DEBUG -DQT_DECLARATIVE_LIB -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default -I/usr/local/Trolltech/Qt-4.8.0/include/QtDeclarative -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT cfgtest_QtDeclarative.cpp -o cfgtest_QtDeclarative -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtDeclarative -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtScript -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtSvg -L/usr/X11R6/lib64 -lQtSql -lQtXmlPatterns -lQtGui -lQtNetwork -lQtCore -lpthread -lpthread
Checking to see if the QtOpenGL module should be built...
g++ -DQT_NO_DEBUG -DQT_OPENGL_LIB -DQT_CORE_LIB -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default -I/usr/local/Trolltech/Qt-4.8.0/include/QtOpenGL -I/usr/local/Trolltech/Qt-4.8.0/include/QtCore -I/usr/local/Trolltech/Qt-4.8.0/include -I/usr/X11R6/include -m64 -pipe -O2 -w -D_REENTRANT cfgtest_QtOpenGL.cpp -o cfgtest_QtOpenGL -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtOpenGL -lQtCore -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lGL -lXext -lX11 -lm -lpthread
cfgtest_QtOpenGL.cpp:1:17: fatal error: qgl.h: No such file or directory
compilation terminated.
Checking to see if the QtScript module should be built...
g++ -DQT_NO_DEBUG -DQT_SCRIPT_LIB -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default -I/usr/local/Trolltech/Qt-4.8.0/include/QtScript -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT cfgtest_QtScript.cpp -o cfgtest_QtScript -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtScript -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtCore -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lpthread
Checking to see if the QtScriptTools module should be built...
g++ -DQT_NO_DEBUG -DQT_SCRIPTTOOLS_LIB -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default -I/usr/local/Trolltech/Qt-4.8.0/include/QtScriptTools -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT cfgtest_QtScriptTools.cpp -o cfgtest_QtScriptTools -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtScriptTools -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtScript -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtGui -L/usr/X11R6/lib64 -lQtCore -lpthread -lpthread
Checking to see if the QtSql module should be built...
g++ -DQT_NO_DEBUG -DQT_SQL_LIB -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default -I/usr/local/Trolltech/Qt-4.8.0/include/QtSql -I/usr/local/Trolltech/Qt-4.8.0/include/QtGui -I/usr/local/Trolltech/Qt-4.8.0/include -I/usr/X11R6/include -m64 -pipe -O2 -w -D_REENTRANT cfgtest_QtSql.cpp -o cfgtest_QtSql -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtSql -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtCore -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lQtGui -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64 -lQtCore -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lXext -lX11 -lm -lpthread
Checking to see if the QtSvg module should be built...
g++ -DQT_NO_DEBUG -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default -I/usr/local/Trolltech/Qt-4.8.0/include/QtSvg -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT cfgtest_QtSvg.cpp -o cfgtest_QtSvg -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtSvg -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtGui -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64 -lQtCore -lpthread -lpthread
Checking to see if the QtTest module should be built...
g++ -DQT_NO_DEBUG -DQT_TEST_LIB -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default -I/usr/local/Trolltech/Qt-4.8.0/include/QtTest -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT cfgtest_QtTest.cpp -o cfgtest_QtTest -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtTest -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtCore -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lpthread
Checking to see if the QtWebKit module should be built...
g++ -DQT_NO_DEBUG -DQT_WEBKIT_LIB -DQT_CORE_LIB -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default -I/usr/local/Trolltech/Qt-4.8.0/include/QtWebKit -I/usr/local/Trolltech/Qt-4.8.0/include/QtCore -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT cfgtest_QtWebKit.cpp -o cfgtest_QtWebKit -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtWebKit -lQtCore -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lpthread
Checking to see if the QtXml module should be built...
g++ -DQT_NO_DEBUG -DQT_XML_LIB -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default -I/usr/local/Trolltech/Qt-4.8.0/include/QtXml -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT cfgtest_QtXml.cpp -o cfgtest_QtXml -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtXml -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtCore -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lpthread
Checking to see if the QtXmlPatterns module should be built...
g++ -DQT_NO_DEBUG -DQT_XMLPATTERNS_LIB -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default -I/usr/local/Trolltech/Qt-4.8.0/include/QtXmlPatterns -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT cfgtest_QtXmlPatterns.cpp -o cfgtest_QtXmlPatterns -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtXmlPatterns -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtNetwork -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtCore -lpthread -lpthread
Checking to see if the phonon module should be built...
g++ -DQT_NO_DEBUG -DQT_PHONON_LIB -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default -I/usr/local/Trolltech/Qt-4.8.0/include/phonon -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT cfgtest_phonon.cpp -o cfgtest_phonon -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lphonon -lpthread
cfgtest_phonon.cpp:1:32: fatal error: phonon/videowidget.h: No such file or directory
compilation terminated.
Checking to see if the QtAssistant module should be built...
g++ -DQT_NO_DEBUG -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default -I/usr/local/Trolltech/Qt-4.8.0/include/QtAssistant -I/usr/local/Trolltech/Qt-4.8.0/include/QtGui -I/usr/local/Trolltech/Qt-4.8.0/include/QtNetwork -I/usr/local/Trolltech/Qt-4.8.0/include -I/usr/X11R6/include -m64 -pipe -O2 -w -D_REENTRANT cfgtest_QtAssistant.cpp -o cfgtest_QtAssistant -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtAssistantClient -lQtGui -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64 -lQtCore -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lQtNetwork -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtCore -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lXext -lX11 -lm -lpthread
cfgtest_QtAssistant.cpp:1:30: fatal error: qassistantclient.h: No such file or directory
compilation terminated.
Checking to see if the QtDesigner module should be built...
g++ -DQT_NO_DEBUG -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default -I/usr/local/Trolltech/Qt-4.8.0/include/QtDesigner -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT cfgtest_QtDesigner.cpp -o cfgtest_QtDesigner -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtDesigner -lpthread
Checking to see if the dbus support module should be built...
DBus v1 does not seem to be installed.
Qt v4.8.0 free edition is being used.
SIP 4.13.1 is being used.
The Qt header files are in /usr/local/Trolltech/Qt-4.8.0/include.
The shared Qt libraries are in /usr/local/Trolltech/Qt-4.8.0/lib.
The Qt binaries are in /usr/local/Trolltech/Qt-4.8.0/bin.
The Qt mkspecs directory is in /usr/local/Trolltech/Qt-4.8.0.
These PyQt modules will be built: QtCore, QtGui, QtHelp, QtMultimedia,
QtNetwork, QtDeclarative, QtScript, QtScriptTools, QtSql, QtSvg, QtTest,
QtWebKit, QtXml, QtXmlPatterns, QtDesigner.
The PyQt Python package will be installed in
/opt/python-2.6.7/lib/python2.6/site-packages.
PyQt is being built with generated docstrings.
PyQt is being built with 'protected' redefined as 'public'.
The Designer plugin will be installed in
/usr/local/Trolltech/Qt-4.8.0/plugins/designer.
The PyQt .sip files will be installed in /opt/python-2.6.7/share/sip/PyQt4.
pyuic4, pyrcc4 and pylupdate4 will be installed in /opt/python-2.6.7/bin.
Generating the C++ source for the QtCore module...
"/opt/python-2.6.7/bin/sip" -w -o -P -x VendorID -t WS_X11 -x PyQt_OpenSSL -x PyQt_NoPrintRangeBug -t Qt_4_8_0 -x Py_v3 -g -a QtCore.api -c /home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/QtCore -b QtCore/QtCore.sbf -I /home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/sip /home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/sip/QtCore/QtCoremod.sip
Creating the Makefile for the QtCore module...
Generating the C++ source for the QtDeclarative module...
"/opt/python-2.6.7/bin/sip" -w -o -P -x VendorID -t WS_X11 -x PyQt_OpenSSL -x PyQt_NoPrintRangeBug -t Qt_4_8_0 -x Py_v3 -g -a QtDeclarative.api -c /home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/QtDeclarative -b QtDeclarative/QtDeclarative.sbf -I /home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/sip /home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/sip/QtDeclarative/QtDeclarativemod.sip
sip: __or__() unsupported function return type - provide %MethodCode and a C++ signature
Error: Unable to create the C++ code.


On Tue, Dec 27, 2011 at 10:54 AM, Phil Thompson <[hidden email]> wrote:
On Tue, 27 Dec 2011 10:32:36 +0100, Nico Dufort <[hidden email]> wrote:
> Hello,
>
> I need to build PyQt4 for use with an existing software (The Foundry's
> Nuke6.3v4).  That software uses Python 2.6 which requires me to build a
> separate version of Python for my system (LinuxMint 12, w/ Python 2.7).
>
> I have built python-2.6.7 fine.
> I have built sip-4.13.1 fine.
> I have built qt-everywhere-opensource-4.8.0 fine.
> I fail on configuring PyQt-4.9 before evening building it (using
> /opt/python-2.6.7/bin/python2.6
> ./configure.py -q /usr/local/Trolltech/Qt-4.8.0/bin/qmake -w):
>
> Generating the C++ source for the QtDeclarative module...
> "/opt/python-2.6.7/bin/sip" -w -o -P -x VendorID -t WS_X11 -x
PyQt_OpenSSL
> -x PyQt_NoPrintRangeBug -t Qt_4_8_0 -x Py_v3 -g -a QtDeclarative.api -c
> /home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/QtDeclarative -b
> QtDeclarative/QtDeclarative.sbf -I
> /home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/sip
>
/home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/sip/QtDeclarative/QtDeclarativemod.sip
> sip: __or__() unsupported function return type - provide %MethodCode and
a
> C++ signature
> Error: Unable to create the C++ code.
>
> Earlier this year, I managed to build PyQt4 on Ubuntu, but it was a
version
> for Python 2.5.  I do not recall having any problem at all when I did.
I'm
> about to install VirtualBox to run a few test cases, but if anyone can
> point me towards what I may be doing wrong, that would be great.  Not
sure
> if that -x Py_v3 is a hint.  Or perhaps there is a mismatch elsewhere in
my
> packages?
>
> Thanks. nico

Run...

/opt/python-2.6.7/bin/sip -V

...to make sure you are actually using the right version of sip.

Phil



--
"Attention, attention. Here and now, boys," the mynah repeated. "Here and now, boys."

_______________________________________________
PyQt mailing list    [hidden email]
http://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: Cannot 'configure' PyQt4.9 before build on Linuxmint

Phil Thompson-5
On Tue, 27 Dec 2011 11:55:57 +0100, Nico Dufort <[hidden email]> wrote:
> Hi Phil,
>
> Thanks for the quick answer.  It does return the correct sip (4.13.1),
and
> the output of the configure reported the correct version as well.
>
> I just noticed a few errors from the output, but I do not think that
would

> be related to my problem (sorry for the long output).  Anything I should
> worry about, or that I may be missing?
> I am installing Ubuntu on virtualbox to see if it's my environment.
>
> Thanks. nico.
>
> nico@slimline:~/Downloads/py4nk/PyQt-x11-gpl-4.9$
> /opt/python-2.6.7/bin/python2.6 ./configure.py -q
> /usr/local/Trolltech/Qt-4.8.0/bin/qmake -w
> Determining the layout of your Qt installation...
> /usr/local/Trolltech/Qt-4.8.0/bin/qmake -o qtdirs.mk qtdirs.pro
> make -f qtdirs.mk
> g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -DQT_NO_DEBUG -DQT_CORE_LIB
> -DQT_SHARED -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/linux-g++-64 -I.
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtCore
> -I/usr/local/Trolltech/Qt-4.8.0/include -I. -o qtdirs.o qtdirs.cpp
> g++ -m64 -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -o qtdirs
> qtdirs.o    -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtCore
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread
> ./qtdirs
> This is the GPL version of PyQt 4.9 (licensed under the GNU General
Public

> License) for Python 2.6.7 on linux3.
>
> Type '2' to view the GPL v2 license.
> Type '3' to view the GPL v3 license.
> Type 'yes' to accept the terms of the license.
> Type 'no' to decline the terms of the license.
>
> Do you accept the terms of the license? yes
> Found the license file pyqt-gpl.sip.
> Checking to see if the QtGui module should be built...
> g++ -DQT_NO_DEBUG -DQT_GUI_LIB -I.
> -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtGui
> -I/usr/local/Trolltech/Qt-4.8.0/include -I/usr/X11R6/include -m64 -pipe
-O2

> -w -D_REENTRANT cfgtest_QtGui.cpp -o cfgtest_QtGui
> -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64  -Wl,-O1
> -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtGui
> -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64 -lQtCore
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lXext -lX11 -lm -lpthread
> Checking to see if the QtHelp module should be built...
> g++ -DQT_NO_DEBUG -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtHelp
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_QtHelp.cpp -o cfgtest_QtHelp -L/usr/local/Trolltech/Qt-4.8.0/lib
>  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtHelp
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtSql
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtGui -L/usr/X11R6/lib64
-lQtNetwork

> -lQtCore -lpthread -lpthread
> Checking to see if the QtMultimedia module should be built...
> g++ -DQT_NO_DEBUG -DQT_MULTIMEDIA_LIB -I.
> -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtMultimedia
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_QtMultimedia.cpp -o cfgtest_QtMultimedia
> -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1
> -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtMultimedia
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtGui
> -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64 -lQtCore
-lpthread

> -lpthread
> Checking to see if the QtNetwork module should be built...
> g++ -DQT_NO_DEBUG -DQT_NETWORK_LIB -I.
> -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtNetwork
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_QtNetwork.cpp -o cfgtest_QtNetwork
> -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1
> -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtNetwork
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtCore
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lpthread
> Checking to see if the QtDBus module should be built...
> g++ -DQT_NO_DEBUG -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtDBus
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_QtDBus.cpp -o cfgtest_QtDBus -L/usr/local/Trolltech/Qt-4.8.0/lib
>  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtDBus -lpthread
> cfgtest_QtDBus.cpp:1:29: fatal error: qdbusconnection.h: No such file or
> directory
> compilation terminated.
> Checking to see if the QtDeclarative module should be built...
> g++ -DQT_NO_DEBUG -DQT_DECLARATIVE_LIB -I.
> -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtDeclarative
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_QtDeclarative.cpp -o cfgtest_QtDeclarative
> -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1
> -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtDeclarative
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtScript
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtSvg -L/usr/X11R6/lib64 -lQtSql
> -lQtXmlPatterns -lQtGui -lQtNetwork -lQtCore -lpthread -lpthread
> Checking to see if the QtOpenGL module should be built...
> g++ -DQT_NO_DEBUG -DQT_OPENGL_LIB -DQT_CORE_LIB -I.
> -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtOpenGL
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtCore
> -I/usr/local/Trolltech/Qt-4.8.0/include -I/usr/X11R6/include -m64 -pipe
-O2

> -w -D_REENTRANT cfgtest_QtOpenGL.cpp -o cfgtest_QtOpenGL
> -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64  -Wl,-O1
> -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtOpenGL -lQtCore
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lGL -lXext -lX11 -lm
> -lpthread
> cfgtest_QtOpenGL.cpp:1:17: fatal error: qgl.h: No such file or directory
> compilation terminated.
> Checking to see if the QtScript module should be built...
> g++ -DQT_NO_DEBUG -DQT_SCRIPT_LIB -I.
> -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtScript
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_QtScript.cpp -o cfgtest_QtScript
> -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1
> -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtScript
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtCore
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lpthread
> Checking to see if the QtScriptTools module should be built...
> g++ -DQT_NO_DEBUG -DQT_SCRIPTTOOLS_LIB -I.
> -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtScriptTools
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_QtScriptTools.cpp -o cfgtest_QtScriptTools
> -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1
> -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtScriptTools
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtScript
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtGui -L/usr/X11R6/lib64 -lQtCore
> -lpthread -lpthread
> Checking to see if the QtSql module should be built...
> g++ -DQT_NO_DEBUG -DQT_SQL_LIB -I.
> -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtSql
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtGui
> -I/usr/local/Trolltech/Qt-4.8.0/include -I/usr/X11R6/include -m64 -pipe
-O2

> -w -D_REENTRANT cfgtest_QtSql.cpp -o cfgtest_QtSql
> -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64  -Wl,-O1
> -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtSql
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtCore
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lQtGui
> -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64 -lQtCore
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lXext -lX11 -lm -lpthread
> Checking to see if the QtSvg module should be built...
> g++ -DQT_NO_DEBUG -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtSvg
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_QtSvg.cpp -o cfgtest_QtSvg -L/usr/local/Trolltech/Qt-4.8.0/lib
>  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtSvg
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtGui
> -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64 -lQtCore
-lpthread

> -lpthread
> Checking to see if the QtTest module should be built...
> g++ -DQT_NO_DEBUG -DQT_TEST_LIB -I.
> -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtTest
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_QtTest.cpp -o cfgtest_QtTest -L/usr/local/Trolltech/Qt-4.8.0/lib
>  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtTest
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtCore
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lpthread
> Checking to see if the QtWebKit module should be built...
> g++ -DQT_NO_DEBUG -DQT_WEBKIT_LIB -DQT_CORE_LIB -I.
> -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtWebKit
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtCore
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_QtWebKit.cpp -o cfgtest_QtWebKit
> -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1
> -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtWebKit -lQtCore
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lpthread
> Checking to see if the QtXml module should be built...
> g++ -DQT_NO_DEBUG -DQT_XML_LIB -I.
> -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtXml
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_QtXml.cpp -o cfgtest_QtXml -L/usr/local/Trolltech/Qt-4.8.0/lib
>  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtXml
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtCore
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lpthread
> Checking to see if the QtXmlPatterns module should be built...
> g++ -DQT_NO_DEBUG -DQT_XMLPATTERNS_LIB -I.
> -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtXmlPatterns
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_QtXmlPatterns.cpp -o cfgtest_QtXmlPatterns
> -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1
> -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtXmlPatterns
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtNetwork
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtCore -lpthread -lpthread
> Checking to see if the phonon module should be built...
> g++ -DQT_NO_DEBUG -DQT_PHONON_LIB -I.
> -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/phonon
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_phonon.cpp -o cfgtest_phonon -L/usr/local/Trolltech/Qt-4.8.0/lib
>  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lphonon -lpthread
> cfgtest_phonon.cpp:1:32: fatal error: phonon/videowidget.h: No such file
or
> directory
> compilation terminated.
> Checking to see if the QtAssistant module should be built...
> g++ -DQT_NO_DEBUG -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtAssistant
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtGui
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtNetwork
> -I/usr/local/Trolltech/Qt-4.8.0/include -I/usr/X11R6/include -m64 -pipe
-O2
> -w -D_REENTRANT cfgtest_QtAssistant.cpp -o cfgtest_QtAssistant
> -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64  -Wl,-O1
> -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtAssistantClient -lQtGui
> -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64 -lQtCore
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lQtNetwork
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtCore
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lXext -lX11 -lm -lpthread
> cfgtest_QtAssistant.cpp:1:30: fatal error: qassistantclient.h: No such
file

> or directory
> compilation terminated.
> Checking to see if the QtDesigner module should be built...
> g++ -DQT_NO_DEBUG -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtDesigner
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_QtDesigner.cpp -o cfgtest_QtDesigner
> -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1
> -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtDesigner -lpthread
> Checking to see if the dbus support module should be built...
> DBus v1 does not seem to be installed.
> Qt v4.8.0 free edition is being used.
> SIP 4.13.1 is being used.
> The Qt header files are in /usr/local/Trolltech/Qt-4.8.0/include.
> The shared Qt libraries are in /usr/local/Trolltech/Qt-4.8.0/lib.
> The Qt binaries are in /usr/local/Trolltech/Qt-4.8.0/bin.
> The Qt mkspecs directory is in /usr/local/Trolltech/Qt-4.8.0.
> These PyQt modules will be built: QtCore, QtGui, QtHelp, QtMultimedia,
> QtNetwork, QtDeclarative, QtScript, QtScriptTools, QtSql, QtSvg, QtTest,
> QtWebKit, QtXml, QtXmlPatterns, QtDesigner.
> The PyQt Python package will be installed in
> /opt/python-2.6.7/lib/python2.6/site-packages.
> PyQt is being built with generated docstrings.
> PyQt is being built with 'protected' redefined as 'public'.
> The Designer plugin will be installed in
> /usr/local/Trolltech/Qt-4.8.0/plugins/designer.
> The PyQt .sip files will be installed in
/opt/python-2.6.7/share/sip/PyQt4.
> pyuic4, pyrcc4 and pylupdate4 will be installed in
/opt/python-2.6.7/bin.
> Generating the C++ source for the QtCore module...
> "/opt/python-2.6.7/bin/sip" -w -o -P -x VendorID -t WS_X11 -x
PyQt_OpenSSL
> -x PyQt_NoPrintRangeBug -t Qt_4_8_0 -x Py_v3 -g -a QtCore.api -c
> /home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/QtCore -b QtCore/QtCore.sbf
-I
> /home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/sip
> /home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/sip/QtCore/QtCoremod.sip
> Creating the Makefile for the QtCore module...
> Generating the C++ source for the QtDeclarative module...
> "/opt/python-2.6.7/bin/sip" -w -o -P -x VendorID -t WS_X11 -x
PyQt_OpenSSL
> -x PyQt_NoPrintRangeBug -t Qt_4_8_0 -x Py_v3 -g -a QtDeclarative.api -c
> /home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/QtDeclarative -b
> QtDeclarative/QtDeclarative.sbf -I
> /home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/sip
>
/home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/sip/QtDeclarative/QtDeclarativemod.sip
> sip: __or__() unsupported function return type - provide %MethodCode and
a
> C++ signature
> Error: Unable to create the C++ code.

QtDeclarativemod.sip doesn't contain any C++ declarations. Is it
corrupted?

Phil
_______________________________________________
PyQt mailing list    [hidden email]
http://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: Cannot 'configure' PyQt4.9 before build on Linuxmint

Nico Dufort
Hello Phil,

I did a test with xubuntu on a virtual machine, and I ran into the exact same error.  I can try on a non-ubuntu/non-debian based environment when I have more time, but I would want to believe that someone else got this version to build.


All my files were downloaded from their respective websites:


Just for the sake of trying, I re-downloaded everything for both test environments, but that made no difference.  I do not think corruption is an issue.  Any suggestion as to what might be worth trying next?
I got a hold of an older build of PyQt that meets my needs and works with Nuke, but I really would like to be able to build this one properly on my own, for the sake of getting it to work. =)

Thanks in advance.
nico

On Tue, Dec 27, 2011 at 12:04 PM, Phil Thompson <[hidden email]> wrote:
On Tue, 27 Dec 2011 11:55:57 +0100, Nico Dufort <[hidden email]> wrote:
> Hi Phil,
>
> Thanks for the quick answer.  It does return the correct sip (4.13.1),
and
> the output of the configure reported the correct version as well.
>
> I just noticed a few errors from the output, but I do not think that
would
> be related to my problem (sorry for the long output).  Anything I should
> worry about, or that I may be missing?
> I am installing Ubuntu on virtualbox to see if it's my environment.
>
> Thanks. nico.
>
> nico@slimline:~/Downloads/py4nk/PyQt-x11-gpl-4.9$
> /opt/python-2.6.7/bin/python2.6 ./configure.py -q
> /usr/local/Trolltech/Qt-4.8.0/bin/qmake -w
> Determining the layout of your Qt installation...
> /usr/local/Trolltech/Qt-4.8.0/bin/qmake -o qtdirs.mk qtdirs.pro
> make -f qtdirs.mk
> g++ -c -m64 -pipe -O2 -Wall -W -D_REENTRANT -DQT_NO_DEBUG -DQT_CORE_LIB
> -DQT_SHARED -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/linux-g++-64 -I.
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtCore
> -I/usr/local/Trolltech/Qt-4.8.0/include -I. -o qtdirs.o qtdirs.cpp
> g++ -m64 -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -o qtdirs
> qtdirs.o    -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtCore
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread
> ./qtdirs
> This is the GPL version of PyQt 4.9 (licensed under the GNU General
Public
> License) for Python 2.6.7 on linux3.
>
> Type '2' to view the GPL v2 license.
> Type '3' to view the GPL v3 license.
> Type 'yes' to accept the terms of the license.
> Type 'no' to decline the terms of the license.
>
> Do you accept the terms of the license? yes
> Found the license file pyqt-gpl.sip.
> Checking to see if the QtGui module should be built...
> g++ -DQT_NO_DEBUG -DQT_GUI_LIB -I.
> -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtGui
> -I/usr/local/Trolltech/Qt-4.8.0/include -I/usr/X11R6/include -m64 -pipe
-O2
> -w -D_REENTRANT cfgtest_QtGui.cpp -o cfgtest_QtGui
> -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64  -Wl,-O1
> -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtGui
> -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64 -lQtCore
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lXext -lX11 -lm -lpthread
> Checking to see if the QtHelp module should be built...
> g++ -DQT_NO_DEBUG -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtHelp
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_QtHelp.cpp -o cfgtest_QtHelp -L/usr/local/Trolltech/Qt-4.8.0/lib
>  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtHelp
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtSql
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtGui -L/usr/X11R6/lib64
-lQtNetwork
> -lQtCore -lpthread -lpthread
> Checking to see if the QtMultimedia module should be built...
> g++ -DQT_NO_DEBUG -DQT_MULTIMEDIA_LIB -I.
> -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtMultimedia
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_QtMultimedia.cpp -o cfgtest_QtMultimedia
> -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1
> -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtMultimedia
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtGui
> -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64 -lQtCore
-lpthread
> -lpthread
> Checking to see if the QtNetwork module should be built...
> g++ -DQT_NO_DEBUG -DQT_NETWORK_LIB -I.
> -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtNetwork
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_QtNetwork.cpp -o cfgtest_QtNetwork
> -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1
> -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtNetwork
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtCore
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lpthread
> Checking to see if the QtDBus module should be built...
> g++ -DQT_NO_DEBUG -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtDBus
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_QtDBus.cpp -o cfgtest_QtDBus -L/usr/local/Trolltech/Qt-4.8.0/lib
>  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtDBus -lpthread
> cfgtest_QtDBus.cpp:1:29: fatal error: qdbusconnection.h: No such file or
> directory
> compilation terminated.
> Checking to see if the QtDeclarative module should be built...
> g++ -DQT_NO_DEBUG -DQT_DECLARATIVE_LIB -I.
> -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtDeclarative
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_QtDeclarative.cpp -o cfgtest_QtDeclarative
> -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1
> -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtDeclarative
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtScript
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtSvg -L/usr/X11R6/lib64 -lQtSql
> -lQtXmlPatterns -lQtGui -lQtNetwork -lQtCore -lpthread -lpthread
> Checking to see if the QtOpenGL module should be built...
> g++ -DQT_NO_DEBUG -DQT_OPENGL_LIB -DQT_CORE_LIB -I.
> -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtOpenGL
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtCore
> -I/usr/local/Trolltech/Qt-4.8.0/include -I/usr/X11R6/include -m64 -pipe
-O2
> -w -D_REENTRANT cfgtest_QtOpenGL.cpp -o cfgtest_QtOpenGL
> -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64  -Wl,-O1
> -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtOpenGL -lQtCore
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lGL -lXext -lX11 -lm
> -lpthread
> cfgtest_QtOpenGL.cpp:1:17: fatal error: qgl.h: No such file or directory
> compilation terminated.
> Checking to see if the QtScript module should be built...
> g++ -DQT_NO_DEBUG -DQT_SCRIPT_LIB -I.
> -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtScript
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_QtScript.cpp -o cfgtest_QtScript
> -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1
> -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtScript
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtCore
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lpthread
> Checking to see if the QtScriptTools module should be built...
> g++ -DQT_NO_DEBUG -DQT_SCRIPTTOOLS_LIB -I.
> -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtScriptTools
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_QtScriptTools.cpp -o cfgtest_QtScriptTools
> -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1
> -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtScriptTools
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtScript
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtGui -L/usr/X11R6/lib64 -lQtCore
> -lpthread -lpthread
> Checking to see if the QtSql module should be built...
> g++ -DQT_NO_DEBUG -DQT_SQL_LIB -I.
> -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtSql
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtGui
> -I/usr/local/Trolltech/Qt-4.8.0/include -I/usr/X11R6/include -m64 -pipe
-O2
> -w -D_REENTRANT cfgtest_QtSql.cpp -o cfgtest_QtSql
> -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64  -Wl,-O1
> -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtSql
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtCore
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lQtGui
> -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64 -lQtCore
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lXext -lX11 -lm -lpthread
> Checking to see if the QtSvg module should be built...
> g++ -DQT_NO_DEBUG -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtSvg
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_QtSvg.cpp -o cfgtest_QtSvg -L/usr/local/Trolltech/Qt-4.8.0/lib
>  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtSvg
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtGui
> -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64 -lQtCore
-lpthread
> -lpthread
> Checking to see if the QtTest module should be built...
> g++ -DQT_NO_DEBUG -DQT_TEST_LIB -I.
> -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtTest
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_QtTest.cpp -o cfgtest_QtTest -L/usr/local/Trolltech/Qt-4.8.0/lib
>  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtTest
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtCore
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lpthread
> Checking to see if the QtWebKit module should be built...
> g++ -DQT_NO_DEBUG -DQT_WEBKIT_LIB -DQT_CORE_LIB -I.
> -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtWebKit
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtCore
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_QtWebKit.cpp -o cfgtest_QtWebKit
> -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1
> -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtWebKit -lQtCore
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lpthread
> Checking to see if the QtXml module should be built...
> g++ -DQT_NO_DEBUG -DQT_XML_LIB -I.
> -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtXml
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_QtXml.cpp -o cfgtest_QtXml -L/usr/local/Trolltech/Qt-4.8.0/lib
>  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtXml
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtCore
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lpthread
> Checking to see if the QtXmlPatterns module should be built...
> g++ -DQT_NO_DEBUG -DQT_XMLPATTERNS_LIB -I.
> -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtXmlPatterns
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_QtXmlPatterns.cpp -o cfgtest_QtXmlPatterns
> -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1
> -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtXmlPatterns
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtNetwork
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtCore -lpthread -lpthread
> Checking to see if the phonon module should be built...
> g++ -DQT_NO_DEBUG -DQT_PHONON_LIB -I.
> -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/phonon
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_phonon.cpp -o cfgtest_phonon -L/usr/local/Trolltech/Qt-4.8.0/lib
>  -Wl,-O1 -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lphonon -lpthread
> cfgtest_phonon.cpp:1:32: fatal error: phonon/videowidget.h: No such file
or
> directory
> compilation terminated.
> Checking to see if the QtAssistant module should be built...
> g++ -DQT_NO_DEBUG -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtAssistant
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtGui
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtNetwork
> -I/usr/local/Trolltech/Qt-4.8.0/include -I/usr/X11R6/include -m64 -pipe
-O2
> -w -D_REENTRANT cfgtest_QtAssistant.cpp -o cfgtest_QtAssistant
> -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64  -Wl,-O1
> -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtAssistantClient -lQtGui
> -L/usr/local/Trolltech/Qt-4.8.0/lib -L/usr/X11R6/lib64 -lQtCore
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lQtNetwork
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lQtCore
> -L/usr/local/Trolltech/Qt-4.8.0/lib -lpthread -lXext -lX11 -lm -lpthread
> cfgtest_QtAssistant.cpp:1:30: fatal error: qassistantclient.h: No such
file
> or directory
> compilation terminated.
> Checking to see if the QtDesigner module should be built...
> g++ -DQT_NO_DEBUG -I. -I/usr/local/Trolltech/Qt-4.8.0/mkspecs/default
> -I/usr/local/Trolltech/Qt-4.8.0/include/QtDesigner
> -I/usr/local/Trolltech/Qt-4.8.0/include -m64 -pipe -O2 -w -D_REENTRANT
> cfgtest_QtDesigner.cpp -o cfgtest_QtDesigner
> -L/usr/local/Trolltech/Qt-4.8.0/lib  -Wl,-O1
> -Wl,-rpath,/usr/local/Trolltech/Qt-4.8.0/lib -lQtDesigner -lpthread
> Checking to see if the dbus support module should be built...
> DBus v1 does not seem to be installed.
> Qt v4.8.0 free edition is being used.
> SIP 4.13.1 is being used.
> The Qt header files are in /usr/local/Trolltech/Qt-4.8.0/include.
> The shared Qt libraries are in /usr/local/Trolltech/Qt-4.8.0/lib.
> The Qt binaries are in /usr/local/Trolltech/Qt-4.8.0/bin.
> The Qt mkspecs directory is in /usr/local/Trolltech/Qt-4.8.0.
> These PyQt modules will be built: QtCore, QtGui, QtHelp, QtMultimedia,
> QtNetwork, QtDeclarative, QtScript, QtScriptTools, QtSql, QtSvg, QtTest,
> QtWebKit, QtXml, QtXmlPatterns, QtDesigner.
> The PyQt Python package will be installed in
> /opt/python-2.6.7/lib/python2.6/site-packages.
> PyQt is being built with generated docstrings.
> PyQt is being built with 'protected' redefined as 'public'.
> The Designer plugin will be installed in
> /usr/local/Trolltech/Qt-4.8.0/plugins/designer.
> The PyQt .sip files will be installed in
/opt/python-2.6.7/share/sip/PyQt4.
> pyuic4, pyrcc4 and pylupdate4 will be installed in
/opt/python-2.6.7/bin.
> Generating the C++ source for the QtCore module...
> "/opt/python-2.6.7/bin/sip" -w -o -P -x VendorID -t WS_X11 -x
PyQt_OpenSSL
> -x PyQt_NoPrintRangeBug -t Qt_4_8_0 -x Py_v3 -g -a QtCore.api -c
> /home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/QtCore -b QtCore/QtCore.sbf
-I
> /home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/sip
> /home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/sip/QtCore/QtCoremod.sip
> Creating the Makefile for the QtCore module...
> Generating the C++ source for the QtDeclarative module...
> "/opt/python-2.6.7/bin/sip" -w -o -P -x VendorID -t WS_X11 -x
PyQt_OpenSSL
> -x PyQt_NoPrintRangeBug -t Qt_4_8_0 -x Py_v3 -g -a QtDeclarative.api -c
> /home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/QtDeclarative -b
> QtDeclarative/QtDeclarative.sbf -I
> /home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/sip
>
/home/nico/Downloads/py4nk/PyQt-x11-gpl-4.9/sip/QtDeclarative/QtDeclarativemod.sip
> sip: __or__() unsupported function return type - provide %MethodCode and
a
> C++ signature
> Error: Unable to create the C++ code.

QtDeclarativemod.sip doesn't contain any C++ declarations. Is it
corrupted?

Phil



--
"Attention, attention. Here and now, boys," the mynah repeated. "Here and now, boys."

_______________________________________________
PyQt mailing list    [hidden email]
http://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: Cannot 'configure' PyQt4.9 before build on Linuxmint

Phil Thompson-5
On Wed, 28 Dec 2011 15:18:05 +0100, Nico Dufort <[hidden email]> wrote:
> Hello Phil,
>
> I did a test with xubuntu on a virtual machine, and I ran into the exact
> same error.  I can try on a non-ubuntu/non-debian based environment when
I
> have more time, but I would want to believe that someone else got this
> version to build.
>
>
> All my files were downloaded from their respective websites:
>
> Python 2.6.7: http://www.python.org/ftp/python/2.6.7/Python-2.6.7.tgz
> Sip 4.13.1:
>
http://www.riverbankcomputing.com/static/Downloads/sip4/sip-4.13.1.tar.gz
> Qt 4.8.0:
>
ftp://ftp.qt.nokia.com/qt/source/qt-everywhere-opensource-src-4.8.0.tar.gz
> PyQt 4.9:
>
http://www.riverbankcomputing.com/static/Downloads/PyQt4/PyQt-x11-gpl-4.9.tar.gz
>
> Just for the sake of trying, I re-downloaded everything for both test
> environments, but that made no difference.  I do not think corruption is
an
> issue.  Any suggestion as to what might be worth trying next?
> I got a hold of an older build of PyQt that meets my needs and works
with
> Nuke, but I really would like to be able to build this one properly on
my
> own, for the sake of getting it to work. =)

Works fine for me under kubuntu. If this was a general problem I'd expect
somebody else to have mentioned it by now.

Phil
_______________________________________________
PyQt mailing list    [hidden email]
http://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: Cannot 'configure' PyQt4.9 before build on Linuxmint

Nico Dufort
Hmm, I'm puzzled then.  I have installed another virtual machine with Fedora 16, and it gives the exact same error as I had under LinuxMint 12 and Xubuntu 11.10.  Each package was downloaded fresh and rebuilt for each machine, with no special flag/option, just plain vanilla config/make.  I had no problem earlier this year with older versions.

I'll check other forums if anyone has an idea of what the problem might be.
Thanks for your time.  Cheers.

On Wed, Dec 28, 2011 at 8:02 PM, Phil Thompson <[hidden email]> wrote:
On Wed, 28 Dec 2011 15:18:05 +0100, Nico Dufort <[hidden email]> wrote:
> Hello Phil,
>
> I did a test with xubuntu on a virtual machine, and I ran into the exact
> same error.  I can try on a non-ubuntu/non-debian based environment when
I
> have more time, but I would want to believe that someone else got this
> version to build.
>
>
> All my files were downloaded from their respective websites:
>
> Python 2.6.7: http://www.python.org/ftp/python/2.6.7/Python-2.6.7.tgz
> Sip 4.13.1:
>
http://www.riverbankcomputing.com/static/Downloads/sip4/sip-4.13.1.tar.gz
> Qt 4.8.0:
>
ftp://ftp.qt.nokia.com/qt/source/qt-everywhere-opensource-src-4.8.0.tar.gz
> PyQt 4.9:
>
http://www.riverbankcomputing.com/static/Downloads/PyQt4/PyQt-x11-gpl-4.9.tar.gz
>
> Just for the sake of trying, I re-downloaded everything for both test
> environments, but that made no difference.  I do not think corruption is
an
> issue.  Any suggestion as to what might be worth trying next?
> I got a hold of an older build of PyQt that meets my needs and works
with
> Nuke, but I really would like to be able to build this one properly on
my
> own, for the sake of getting it to work. =)

Works fine for me under kubuntu. If this was a general problem I'd expect
somebody else to have mentioned it by now.

Phil



--
"Attention, attention. Here and now, boys," the mynah repeated. "Here and now, boys."

_______________________________________________
PyQt mailing list    [hidden email]
http://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: Cannot 'configure' PyQt4.9 before build on Linuxmint

Hans-Peter Jansen-2
On Thursday 29 December 2011, 10:48:21 Nico Dufort wrote:
> Hmm, I'm puzzled then.  I have installed another virtual machine with
> Fedora 16, and it gives the exact same error as I had under LinuxMint
> 12 and Xubuntu 11.10.  Each package was downloaded fresh and rebuilt
> for each machine, with no special flag/option, just plain vanilla
> config/make.  I had no problem earlier this year with older versions.
>
> I'll check other forums if anyone has an idea of what the problem
> might be. Thanks for your time.  Cheers.

Start with deinstalling all packages of your distribution, that you're
going to replace.

Pete


_______________________________________________
PyQt mailing list    [hidden email]
http://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: Cannot 'configure' PyQt4.9 before build on Linuxmint

Ivan
This post has NOT been accepted by the mailing list yet.
I just want nico to know s/he is not alone.

One of my Kubuntu Lucid 10.04 machines stops with:

Generating the C++ source for the QtDeclarative module...
sip: __or__() unsupported function return type - provide %MethodCode and a C++ signature
Error: Unable to create the C++ code.

while configuring PyQt4.9.

Many other Kubuntu Lucid (x86_64) machines have completed the PyQt4.9 build (python2.6) with no problem. The one
that stops in config has been upgraded from years-old kubuntu. May be it is not the same as a freshly installed Kubuntu
Lucid (according to PyQt4.9). I have no time to find out.

Ivan
Reply | Threaded
Open this post in threaded view
|

Re: Cannot 'configure' PyQt4.9 before build on Linuxmint

murison
I, too, am stopped cold by this very same problem. Sip 4.13.2, Python 2.7.3, Qt 4.8.1, PyQt 4.9.1 on Ubuntu 11.10.
Reply | Threaded
Open this post in threaded view
|

Re: Cannot 'configure' PyQt4.9 before build on Linuxmint

Brian Kelley-3
I got hit by this as well.  Apparently having the correct sip in your path
may not be enough.  I have attached a script that properly builds sip+qt
assuming you have downloaded the current tarballs.  It also has the
command that fails (SLED10-64/Ubuntu10-64) so Phil can take a look at it.

Essentially:

I had to specifically tell PyQt's configure where the sip include file
(include/sip.h) was.

> sip -V
4.13.2
> which sip
.../sip-4.13.2/bin/sip

> python configure.py \
  -q .../Trolltech/Qt-4.8.0/bin/qmake \
   -e .../sip-4.13.2/include \
   -v .../sip-4.13.2/share/sip


Note that "-e" and "-v" are the same flags as how you configured sip which
is how I figured this out in the first place (purely by serendipity, I
copied the wrong configure flags in a shell by accident)

I kind of think this might be a bug in the PyQt configure, but then I know
all about configuration hell so I have some sympathy ( I had to patch Qt
4.8 to properly build WebKit on SLED10-64 as well ).  I don't have
sympathy for the amount of time it took me to figure this out though, so
hopefully this will help future coders. :)

Brian



On 4/19/12 2:09 PM, "murison" <[hidden email]> wrote:

>I, too, am stopped cold by this very same problem. Sip 4.13.2, Python
>2.7.3,
>Qt 4.8.1, PyQt 4.9.1 on Ubuntu 11.10.
>
>--
>View this message in context:
>http://python.6.n6.nabble.com/Cannot-configure-PyQt4-9-before-build-on-Lin
>uxmint-tp2309321p4899103.html
>Sent from the PyQt mailing list archive at Nabble.com.
>_______________________________________________
>PyQt mailing list    [hidden email]
>http://www.riverbankcomputing.com/mailman/listinfo/pyqt

_______________________________________________
PyQt mailing list    [hidden email]
http://www.riverbankcomputing.com/mailman/listinfo/pyqt

buildpyqt.sh (1K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Cannot 'configure' PyQt4.9 before build on Linuxmint

Hans-Peter Jansen-2
Dear Brian,

Am Tuesday 24 April 2012 19:44:17 schrieb Brian Kelley:

> I got hit by this as well.  Apparently having the correct sip in your path
> may not be enough.  I have attached a script that properly builds sip+qt
> assuming you have downloaded the current tarballs.  It also has the
> command that fails (SLED10-64/Ubuntu10-64) so Phil can take a look at it.
>
> Essentially:
>
> I had to specifically tell PyQt's configure where the sip include file
> (include/sip.h) was.
>
> > sip -V
>
> 4.13.2
>
> > which sip
>
> .../sip-4.13.2/bin/sip
>
> > python configure.py \
>
>   -q .../Trolltech/Qt-4.8.0/bin/qmake \
>    -e .../sip-4.13.2/include \
>    -v .../sip-4.13.2/share/sip
>
>
> Note that "-e" and "-v" are the same flags as how you configured sip which
> is how I figured this out in the first place (purely by serendipity, I
> copied the wrong configure flags in a shell by accident)
>
> I kind of think this might be a bug in the PyQt configure, but then I know
> all about configuration hell so I have some sympathy ( I had to patch Qt
> 4.8 to properly build WebKit on SLED10-64 as well ).  I don't have
> sympathy for the amount of time it took me to figure this out though, so
> hopefully this will help future coders. :)

You could have spared a significant amount of your time by simply building sip
and friends in openSUSEs build service. That typically results in properly
installable packages, and a new target (distribution) is mostly a matter of a
few clicks. There are plenty of packages/examples in BS, that could serve as
the rpm spec template (including mine found here:
        https://build.opensuse.org/project/show?project=home%3Afrispete
  http://download.opensuse.org/repositories/home:/frispete:/
).

Pete

> Brian
>
> On 4/19/12 2:09 PM, "murison" <[hidden email]> wrote:
> >I, too, am stopped cold by this very same problem. Sip 4.13.2, Python
> >2.7.3,
> >Qt 4.8.1, PyQt 4.9.1 on Ubuntu 11.10.
> >
> >--
> >View this message in context:
> >http://python.6.n6.nabble.com/Cannot-configure-PyQt4-9-before-build-on-Lin
> >uxmint-tp2309321p4899103.html
> >Sent from the PyQt mailing list archive at Nabble.com.
> >_______________________________________________
> >PyQt mailing list    [hidden email]
> >http://www.riverbankcomputing.com/mailman/listinfo/pyqt
_______________________________________________
PyQt mailing list    [hidden email]
http://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: Cannot 'configure' PyQt4.9 before build on Linuxmint

Brian Kelley-3
That would have been nice, except (1) This affected multiple distress that
did not have the openSUSE build service (2) I need to build with multiple
pythons (2.3Š2.7) (3) I need to install into a specific prefix and PyQt is
not easily re-locatable and (4) I use the commercial distribution and this
affected ubuntu and SLED10.

Brian


>
>You could have spared a significant amount of your time by simply
>building sip
>and friends in openSUSEs build service. That typically results in
>properly
>installable packages, and a new target (distribution) is mostly a matter
>of a
>few clicks. There are plenty of packages/examples in BS, that could serve
>as
>the rpm spec template (including mine found here:
> https://build.opensuse.org/project/show?project=home%3Afrispete
> http://download.opensuse.org/repositories/home:/frispete:/
>).
>
>Pete
>
>> Brian
>>
>> On 4/19/12 2:09 PM, "murison" <[hidden email]> wrote:
>> >I, too, am stopped cold by this very same problem. Sip 4.13.2, Python
>> >2.7.3,
>> >Qt 4.8.1, PyQt 4.9.1 on Ubuntu 11.10.
>> >
>> >--
>> >View this message in context:
>>
>>>http://python.6.n6.nabble.com/Cannot-configure-PyQt4-9-before-build-on-L
>>>in
>> >uxmint-tp2309321p4899103.html
>> >Sent from the PyQt mailing list archive at Nabble.com.
>> >_______________________________________________
>> >PyQt mailing list    [hidden email]
>> >http://www.riverbankcomputing.com/mailman/listinfo/pyqt

_______________________________________________
PyQt mailing list    [hidden email]
http://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: Cannot 'configure' PyQt4.9 before build on Linuxmint

Brian Kelley-3
I should be clear what I mean by relocatable: sipconfig.py and
pyqtconfig.py have hard-coded paths so if you build new pyqt libraries
from C++ widgets you shouldn't move these files (although I expect you can
just change the paths internally but I've never been that brave, perhaps I
should investigate a move-pyqt-install tool)

Brian

On 4/25/12 8:28 AM, "Brian Kelley" <[hidden email]> wrote:

>That would have been nice, except (1) This affected multiple distress that
>did not have the openSUSE build service (2) I need to build with multiple
>pythons (2.3Š2.7) (3) I need to install into a specific prefix and PyQt is
>not easily re-locatable and (4) I use the commercial distribution and this
>affected ubuntu and SLED10.
>
>Brian

_______________________________________________
PyQt mailing list    [hidden email]
http://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: Cannot 'configure' PyQt4.9 before build on Linuxmint

Brian Kelley-3
In reply to this post by Brian Kelley-3
Sadly this doesn't work either, the "-e" flag in pyqt configure just tells
what modules to build, so I was turning the failing modules off.

Back to the drawing board (the shell script does expose the problem
however)

Brian

On 4/24/12 1:44 PM, "Brian Kelley" <[hidden email]> wrote:

>I got hit by this as well.  Apparently having the correct sip in your path
>may not be enough.  I have attached a script that properly builds sip+qt
>assuming you have downloaded the current tarballs.  It also has the
>command that fails (SLED10-64/Ubuntu10-64) so Phil can take a look at it.
>
>Essentially:
>
>I had to specifically tell PyQt's configure where the sip include file
>(include/sip.h) was.
>
>> sip -V
>4.13.2
>> which sip
>.../sip-4.13.2/bin/sip
>
>> python configure.py \
>  -q .../Trolltech/Qt-4.8.0/bin/qmake \
>   -e .../sip-4.13.2/include \
>   -v .../sip-4.13.2/share/sip
>
>
>Note that "-e" and "-v" are the same flags as how you configured sip which
>is how I figured this out in the first place (purely by serendipity, I
>copied the wrong configure flags in a shell by accident)
>
>I kind of think this might be a bug in the PyQt configure, but then I know
>all about configuration hell so I have some sympathy ( I had to patch Qt
>4.8 to properly build WebKit on SLED10-64 as well ).  I don't have
>sympathy for the amount of time it took me to figure this out though, so
>hopefully this will help future coders. :)
>
>Brian
>
>
>
>On 4/19/12 2:09 PM, "murison" <[hidden email]> wrote:
>
>>I, too, am stopped cold by this very same problem. Sip 4.13.2, Python
>>2.7.3,
>>Qt 4.8.1, PyQt 4.9.1 on Ubuntu 11.10.
>>
>>--
>>View this message in context:
>>http://python.6.n6.nabble.com/Cannot-configure-PyQt4-9-before-build-on-Li
>>n
>>uxmint-tp2309321p4899103.html
>>Sent from the PyQt mailing list archive at Nabble.com.
>>_______________________________________________
>>PyQt mailing list    [hidden email]
>>http://www.riverbankcomputing.com/mailman/listinfo/pyqt
>

_______________________________________________
PyQt mailing list    [hidden email]
http://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: Cannot 'configure' PyQt4.9 before build on Linuxmint

Hans-Peter Jansen-2
In reply to this post by Brian Kelley-3
Am Wednesday 25 April 2012 14:28:54 schrieb Brian Kelley:
> That would have been nice, except (1) This affected multiple distress that
> did not have the openSUSE build service (2) I need to build with multiple
> pythons (2.3Š2.7) (3) I need to install into a specific prefix and PyQt is
> not easily re-locatable and (4) I use the commercial distribution and this
> affected ubuntu and SLED10.

Hmm, (1, 4) did you notice the broad range of distros, that BS supports -
including various debian, ubuntu and SuSE commercial releases...

(2) Building against various python distros is a matter of including that
python version within that project.

(3) I usually do path tinkering in spec files with sed scripts without
modifying the source nor creating a patch.

Finally, setting up a private BS is a bit of a hassle and non rpm based
packaging adds some complexity, though.

You're free to do whatever you want of course - I just wanted to show some
interesting alternatives to the ordinary build from tarballs..

Pete

> Brian
>
> >You could have spared a significant amount of your time by simply
> >building sip
> >and friends in openSUSEs build service. That typically results in
> >properly
> >installable packages, and a new target (distribution) is mostly a matter
> >of a
> >few clicks. There are plenty of packages/examples in BS, that could serve
> >as
> >the rpm spec template (including mine found here:
> > https://build.opensuse.org/project/show?project=home%3Afrispete
> > http://download.opensuse.org/repositories/home:/frispete:/
> >).
> >
> >Pete
> >
> >> Brian
> >>
> >> On 4/19/12 2:09 PM, "murison" <[hidden email]> wrote:
> >> >I, too, am stopped cold by this very same problem. Sip 4.13.2, Python
> >> >2.7.3,
> >> >Qt 4.8.1, PyQt 4.9.1 on Ubuntu 11.10.
> >> >
> >> >--
> >> >View this message in context:
> >>>
> >>>http://python.6.n6.nabble.com/Cannot-configure-PyQt4-9-before-build-on-L
> >>>in
> >>>
> >> >uxmint-tp2309321p4899103.html
> >> >Sent from the PyQt mailing list archive at Nabble.com.
> >> >_______________________________________________
> >> >PyQt mailing list    [hidden email]
> >> >http://www.riverbankcomputing.com/mailman/listinfo/pyqt
>
> _______________________________________________
> PyQt mailing list    [hidden email]
> http://www.riverbankcomputing.com/mailman/listinfo/pyqt


_______________________________________________
PyQt mailing list    [hidden email]
http://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: Cannot 'configure' PyQt4.9 before build on Linuxmint

Nico Dufort
I just wanted to bring some closure to my old thread in case someone browses the archive:

Following Brian's suggestion of editing PyQt-*-4.9.1/sip/QtNetwork/qssl.sip as explained in the following thread solved the configuration problem I had since December.  I had given up then since nothing seemed to help and I had found a build online that had worked for my needs.

Info can be found under the following thread, and it is my understanding that at this time a new snapshot is fixing the issue: [PyQt] sip: __or__() unsupported function return type - provide %MethodCode and a C++ signature ( QT 4.8.1 + PyQt 4.9.1 ).


Cheers. nico


On Thu, Apr 26, 2012 at 12:41 PM, Hans-Peter Jansen <[hidden email]> wrote:
Am Wednesday 25 April 2012 14:28:54 schrieb Brian Kelley:
> That would have been nice, except (1) This affected multiple distress that
> did not have the openSUSE build service (2) I need to build with multiple
> pythons (2.3Š2.7) (3) I need to install into a specific prefix and PyQt is
> not easily re-locatable and (4) I use the commercial distribution and this
> affected ubuntu and SLED10.

Hmm, (1, 4) did you notice the broad range of distros, that BS supports -
including various debian, ubuntu and SuSE commercial releases...

(2) Building against various python distros is a matter of including that
python version within that project.

(3) I usually do path tinkering in spec files with sed scripts without
modifying the source nor creating a patch.

Finally, setting up a private BS is a bit of a hassle and non rpm based
packaging adds some complexity, though.

You're free to do whatever you want of course - I just wanted to show some
interesting alternatives to the ordinary build from tarballs..

Pete

> Brian
>
> >You could have spared a significant amount of your time by simply
> >building sip
> >and friends in openSUSEs build service. That typically results in
> >properly
> >installable packages, and a new target (distribution) is mostly a matter
> >of a
> >few clicks. There are plenty of packages/examples in BS, that could serve
> >as
> >the rpm spec template (including mine found here:
> >     https://build.opensuse.org/project/show?project=home%3Afrispete
> >     http://download.opensuse.org/repositories/home:/frispete:/
> >).
> >
> >Pete
> >
> >> Brian
> >>
> >> On 4/19/12 2:09 PM, "murison" <[hidden email]> wrote:
> >> >I, too, am stopped cold by this very same problem. Sip 4.13.2, Python
> >> >2.7.3,
> >> >Qt 4.8.1, PyQt 4.9.1 on Ubuntu 11.10.
> >> >
> >> >--
> >> >View this message in context:
> >>>
> >>>http://python.6.n6.nabble.com/Cannot-configure-PyQt4-9-before-build-on-L
> >>>in
> >>>
> >> >uxmint-tp2309321p4899103.html
> >> >Sent from the PyQt mailing list archive at Nabble.com.
> >> >_______________________________________________
> >> >PyQt mailing list    [hidden email]
> >> >http://www.riverbankcomputing.com/mailman/listinfo/pyqt
>
> _______________________________________________
> PyQt mailing list    [hidden email]
> http://www.riverbankcomputing.com/mailman/listinfo/pyqt


_______________________________________________
PyQt mailing list    [hidden email]
http://www.riverbankcomputing.com/mailman/listinfo/pyqt



--
"Attention, attention. Here and now, boys," the mynah repeated. "Here and now, boys."

_______________________________________________
PyQt mailing list    [hidden email]
http://www.riverbankcomputing.com/mailman/listinfo/pyqt