Dropping support for Python 2.3

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Dropping support for Python 2.3

Nick Joyce
Hi,

I am considering dropping support for Python 2.3 in the next release of PyAMF (0.6).

Python 2.3 was originally released in July 2003 and the last point release was in September 2008. Both Django and Twisted have dropped support for 2.3. I believe that SQLAlchemy has also dropped support for its 0.6.x line (at least that is what the debian repos tell me)?

Does anyone have any strong feelings about *not* doing this?

-Nick
_______________________________________________
PyAMF users mailing list - [hidden email]
http://lists.pyamf.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Dropping support for Python 2.3

Thijs Triemstra
I think that's a good idea, also since the unit tests now require the 'unittest2' package, which seems to run on Python 2.4+ only.

It looks like Twisted also is dropping support for Python 2.4, so what about dropping support for that in PyAMF as well? I haven't used PyAMF with Python 2.4 since 0.1..

Cheers,

Thijs

On Jun 20, 2010, at 6:04 AM, Nick Joyce wrote:

> Hi,
>
> I am considering dropping support for Python 2.3 in the next release of PyAMF (0.6).
>
> Python 2.3 was originally released in July 2003 and the last point release was in September 2008. Both Django and Twisted have dropped support for 2.3. I believe that SQLAlchemy has also dropped support for its 0.6.x line (at least that is what the debian repos tell me)?
>
> Does anyone have any strong feelings about *not* doing this?
>
> -Nick
> _______________________________________________
> PyAMF users mailing list - [hidden email]
> http://lists.pyamf.org/mailman/listinfo/users

_______________________________________________
PyAMF users mailing list - [hidden email]
http://lists.pyamf.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Dropping support for Python 2.3

Radhakrishna Bhat
I use 2.6. No probs for me.

-radhakrishna

On Sun, Jun 20, 2010 at 7:35 PM, Thijs Triemstra | Collab <[hidden email]> wrote:
I think that's a good idea, also since the unit tests now require the 'unittest2' package, which seems to run on Python 2.4+ only.

It looks like Twisted also is dropping support for Python 2.4, so what about dropping support for that in PyAMF as well? I haven't used PyAMF with Python 2.4 since 0.1..

Cheers,

Thijs

On Jun 20, 2010, at 6:04 AM, Nick Joyce wrote:

> Hi,
>
> I am considering dropping support for Python 2.3 in the next release of PyAMF (0.6).
>
> Python 2.3 was originally released in July 2003 and the last point release was in September 2008. Both Django and Twisted have dropped support for 2.3. I believe that SQLAlchemy has also dropped support for its 0.6.x line (at least that is what the debian repos tell me)?
>
> Does anyone have any strong feelings about *not* doing this?
>
> -Nick
> _______________________________________________
> PyAMF users mailing list - [hidden email]
> http://lists.pyamf.org/mailman/listinfo/users

_______________________________________________
PyAMF users mailing list - [hidden email]
http://lists.pyamf.org/mailman/listinfo/users


_______________________________________________
PyAMF users mailing list - [hidden email]
http://lists.pyamf.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Dropping support for Python 2.3

Nick Joyce
In reply to this post by Thijs Triemstra
On 21 Jun 2010, at 00:05, Thijs Triemstra | Collab wrote:

> I think that's a good idea, also since the unit tests now require the 'unittest2' package, which seems to run on Python 2.4+ only.
>
> It looks like Twisted also is dropping support for Python 2.4, so what about dropping support for that in PyAMF as well? I haven't used PyAMF with Python 2.4 since 0.1..
>
> Cheers,
>
> Thijs


According to the download stats [1], 2.4 still has a reasonable following so I suggest (at least for the medium term) we continue supporting it (perhaps until 1.0?) There are no real technical reason that I can see why not.

Cheers,

Nick

[1] - http://pypi.python.org/pypi/PyAMF
_______________________________________________
PyAMF users mailing list - [hidden email]
http://lists.pyamf.org/mailman/listinfo/users