Failure to run PyQt5 installed as binary wheel

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Failure to run PyQt5 installed as binary wheel

Pol Welter

Hello,

Today I updated PyQt on one of my machines, this seems to have broken my install. I can reproduce the issue on multiple machines with the minimum example below.

I am on Windows, running Python 3.7 (64-bit). I use a conda environment.

I can reproduce the problem when setting up an environment with the following steps:

> conda create -n pyqttest37
> activate pyqttest37
> conda install python=3.7.2
> pip install pyqt5
> python -c "import PyQt5.QtWidgets"
Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: DLL load failed: The specified procedure could not be found.

The weird thing is, it does not seem to depend on any specific version of PyQt5. For instance, the above installs 5.12. Before 5.11.3 was working just fine, but reverting to it now gives me the same error.
Also I tested Py3.6, with the same result.

What am I doing wrong? Is there some issue with the wheels?
I am confused because the above installing process worked fine for many years. Now, pip install -U pyqt5 breaks any install and I yet have to figure out how to revert. (Haven’t tried building from source yet; it’s not particularly fun on Windows.)

Best
Pol


_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt