Having trouble with pip install

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Having trouble with pip install

Vladik Rikhter
Hi (excuse the n00b like question, but I'm lost at this point):

I've been trying to install my requirements.txt file with pip through Cygwin.  I went through and ran the easy_install, worked without a problem.  I then tried to execute the following command:
"pip install -r requirements.txt"

Unfortunately the following error came up:
Downloading/unpacking git+http://github.com/tropo/tropo-webapi-python.git (from
-r requirements.txt (line 9))
  Cloning http://github.com/tropo/tropo-webapi-python.git to /tmp/pip-E3epk3-bui
ld
  Running setup.py egg_info for package from git+http://github.com/tropo/tropo-w
ebapi-python.git
      1 [main] python2.6 9848 C:\cygwin\bin\python2.6.exe: *** fatal error - una
ble to remap \\?\C:\cygwin\lib\python2.6\lib-dynload\time.dll to same address as
 parent: 0x360000 != 0x3F0000
Stack trace:
Frame     Function  Args
00289F08  6102796B  (00289F08, 00000000, 00000000, 00000000)
0028A1F8  6102796B  (6117EC60, 00008000, 00000000, 61180977)
0028B228  61004F1B  (611A7FAC, 61243884, 00360000, 003F0000)
End of stack trace
      1 [main] python2.6 11796 fork: child 9848 - died waiting for dll loading,
errno 11
    Error [Errno 11] Resource temporarily unavailable while executing command py
thon setup.py egg_info
Exception:
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/pip-1.0.2-py2.6.egg/pip/basecommand.py"
, line 126, in main
    self.run(options, args)
  File "/usr/lib/python2.6/site-packages/pip-1.0.2-py2.6.egg/pip/commands/instal
l.py", line 223, in run
    requirement_set.prepare_files(finder, force_root_egg_info=self.bundle, bundl
e=self.bundle)
  File "/usr/lib/python2.6/site-packages/pip-1.0.2-py2.6.egg/pip/req.py", line 9
86, in prepare_files
    req_to_install.run_egg_info()
  File "/usr/lib/python2.6/site-packages/pip-1.0.2-py2.6.egg/pip/req.py", line 2
22, in run_egg_info
    command_desc='python setup.py egg_info')
  File "/usr/lib/python2.6/site-packages/pip-1.0.2-py2.6.egg/pip/__init__.py", l
ine 220, in call_subprocess
    cwd=cwd, env=env)
  File "/usr/lib/python2.6/subprocess.py", line 633, in __init__
    errread, errwrite)
  File "/usr/lib/python2.6/subprocess.py", line 1049, in _execute_child
    self.pid = os.fork()
OSError: [Errno 11] Resource temporarily unavailable
Storing complete log in /home/Vladik/.pip/pip.log

Would love some help on how to fix this! Thank you, thank you!
--
(c) 404.966.9048

_______________________________________________
Distutils-SIG maillist  -  [hidden email]
http://mail.python.org/mailman/listinfo/distutils-sig