Help installing PyGObject

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Help installing PyGObject

Vincent D. Brown
Hello,

I was wondering if anyone could help me with some installation trouble.  
I downloaded PyGObject 3.0.2 and tried running configure.  It said that
I don't have glib version >= 2.24.0, so I found glib 2.24.2 and
installed it.  The configure still stops on the same error:

checking for GLIB - version >= 2.24.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log
for the
*** exact error that occured. This usually means GLIB is incorrectly
installed.
configure: error: maybe you want the pygobject-2-4 branch?

I'm on CentOS 5, if that helps.

Thanks,
Vincent
_______________________________________________
pygtk mailing list   [hidden email]
http://www.daa.com.au/mailman/listinfo/pygtk
Read the PyGTK FAQ: http://faq.pygtk.org/
Reply | Threaded
Open this post in threaded view
|

Re: Help installing PyGObject

Hrvoje Niksic-2
On 03/05/2013 09:20 PM, Vincent D. Brown wrote:
> I was wondering if anyone could help me with some installation trouble.
> I downloaded PyGObject 3.0.2 and tried running configure.  It said that
> I don't have glib version >= 2.24.0, so I found glib 2.24.2 and
> installed it.  The configure still stops on the same error:
>
> checking for GLIB - version >= 2.24.0... no

What is the output of "pkg-config --cflags glib-2.0"? It should point to
your newly installed glib 2.24.2, and not to the old glib present on the
system. If this is not the case, you either need to put the installed
directory on PKG_CONFIG_PATH, or see what went wrong with the installation.

_______________________________________________
pygtk mailing list   [hidden email]
http://www.daa.com.au/mailman/listinfo/pygtk
Read the PyGTK FAQ: http://faq.pygtk.org/