[IPython-User] How to upgrade or install Ipython for python 3.x support?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[IPython-User] How to upgrade or install Ipython for python 3.x support?

janpenguin
Hi,

I mostly use ipython as SymPy interface that serves as CAS (Computer
Algebra System) application in Devuan (Debian without systemd) Linux.

The ipython supports python 2.x I believe.

$ ipython --pylab
Python 2.7.10+ (default, Oct 10 2015, 09:11:24)
Type "copyright", "credits" or "license" for more information.

IPython 2.3.0 -- An enhanced Interactive Python.
?         -> Introduction and overview of IPython's features.
%quickref -> Quick reference.
help      -> Python's own help system.
object?   -> Details about 'object', use 'object??' for extra details.
Using matplotlib backend: TkAgg

I'm planning to replace all previous python codes I've written to Python
3.x. Is there Ipython version that supports Python 3.x?

Regards,
Hughe



_______________________________________________
IPython-User mailing list
[hidden email]
https://mail.scipy.org/mailman/listinfo/ipython-user
Reply | Threaded
Open this post in threaded view
|

Re: How to upgrade or install Ipython for python 3.x support?

MinRK
Yes, IPython has supported Python 3 since at least 0.12. You do not
need a different version of IPython to use Python 3, just install
IPython with Python 3:

    python3 -m pip install ipython

-MinRK

On Thu, Dec 24, 2015 at 12:01 PM,  <[hidden email]> wrote:

> Hi,
>
> I mostly use ipython as SymPy interface that serves as CAS (Computer Algebra
> System) application in Devuan (Debian without systemd) Linux.
>
> The ipython supports python 2.x I believe.
>
> $ ipython --pylab
> Python 2.7.10+ (default, Oct 10 2015, 09:11:24)
> Type "copyright", "credits" or "license" for more information.
>
> IPython 2.3.0 -- An enhanced Interactive Python.
> ?         -> Introduction and overview of IPython's features.
> %quickref -> Quick reference.
> help      -> Python's own help system.
> object?   -> Details about 'object', use 'object??' for extra details.
> Using matplotlib backend: TkAgg
>
> I'm planning to replace all previous python codes I've written to Python
> 3.x. Is there Ipython version that supports Python 3.x?
>
> Regards,
> Hughe
>
>
>
> _______________________________________________
> IPython-User mailing list
> [hidden email]
> https://mail.scipy.org/mailman/listinfo/ipython-user
_______________________________________________
IPython-User mailing list
[hidden email]
https://mail.scipy.org/mailman/listinfo/ipython-user