Quantcast

[IPython-User] Notebook doesn't produce output

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[IPython-User] Notebook doesn't produce output

Ullrich Koethe
Hi,

I'm very impressed with the new notebook functionality, but I cannot get
it to work on my computer (Windows 7, 64-bit, python 2.7, ipython 0.12,
Firefox 10.0). When I start the notebook via

$ ipython notebook

the notebook management page correctly shows up in Firefox, and I can
create new notebooks. Upon notebook creation, a kernel is correctly
started, as I confirmed by a console client started with "--existing",
which works normally. However, when I try to execute commands within the
notebook (Shift-Enter), the prompt changes into

   In[*]

and a new cell is created, but no output appears. In fact, the command
has no effect at all, as I confirmed in the other client.

How can I proceed to fix the problem?

Thanks!
Ulli
_______________________________________________
IPython-User mailing list
[hidden email]
http://mail.scipy.org/mailman/listinfo/ipython-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Notebook doesn't produce output

Fernando Perez
On Thu, Feb 9, 2012 at 8:50 AM, Ullrich Koethe
<[hidden email]> wrote:
>
> How can I proceed to fix the problem?

This is odd, as the other info you provide seems to indicate that the
zmq machinery is working fine.  A few things to help debug:

- could you also try with chrome, just to be sure it's not a browser thing?

- hit reload on the notebook page (not just the dashboard) to ensure
there's no cached  javascript around by chance.

- what version of tornado and pyzme are you using?  You can see both with:

In [3]: import tornado, zmq

In [4]: tornado.version
Out[4]: '2.1'

In [5]: zmq.__version__
Out[5]: '2.1.9'


Cheers,

f
_______________________________________________
IPython-User mailing list
[hidden email]
http://mail.scipy.org/mailman/listinfo/ipython-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Notebook doesn't produce output

MinRK
In reply to this post by Ullrich Koethe


On Thu, Feb 9, 2012 at 08:50, Ullrich Koethe <[hidden email]> wrote:
Hi,

I'm very impressed with the new notebook functionality, but I cannot get
it to work on my computer (Windows 7, 64-bit, python 2.7, ipython 0.12,
Firefox 10.0). When I start the notebook via

$ ipython notebook

the notebook management page correctly shows up in Firefox, and I can
create new notebooks. Upon notebook creation, a kernel is correctly
started, as I confirmed by a console client started with "--existing",
which works normally. However, when I try to execute commands within the
notebook (Shift-Enter), the prompt changes into

  In[*]

and a new cell is created, but no output appears. In fact, the command
has no effect at all, as I confirmed in the other client.

How can I proceed to fix the problem?

The first place to look is always the javascript console (Tools/Web Developer/Error Console in FF).  It is likely there was an error reported there.
 

Thanks!
Ulli
_______________________________________________
IPython-User mailing list
[hidden email]
http://mail.scipy.org/mailman/listinfo/ipython-user


_______________________________________________
IPython-User mailing list
[hidden email]
http://mail.scipy.org/mailman/listinfo/ipython-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Notebook doesn't produce output

Ullrich Koethe
Hi Fernando and Benjamin,

thanks for your suggestions.

 >>
 >> How can I proceed to fix the problem?
 >
 > This is odd, as the other info you provide seems to indicate that
 > the zmq machinery is working fine.  A few things to help debug:
 >
 > - could you also try with chrome, just to be sure it's not a browser
 > thing?
 >

I tried chrome 17.0.963.46 m, and it didn't work either. The javascript
console says:

Starting WS:
ws://127.0.0.1:8888/kernels/c9eac7c8-c15c-4cdb-8ed9-4d6df5e77e37
Kernel started:  c9eac7c8-c15c-4cdb-8ed9-4d6df5e77e37
event.layerX and event.layerY are broken and deprecated in WebKit. They
will be removed from the engine in the near future.

 > - hit reload on the notebook page (not just the dashboard) to ensure
 > there's no cached  javascript around by chance.
 >

The javascript console displays an error message, see below.

 > - what version of tornado and pyzme are you using?  You can see both
 > with:
 >

import tornado, zmq

tornado.version
Out[28]: '2.2'

zmq.__version__
Out[29]: '2.1.10'

 > The first place to look is always the javascript console (Tools/Web
 > Developer/Error Console in FF).  It is likely there was an error
 > reported there.

There are many CSS warnings when I open the dashboard or a new notebook,
but no errors. When I type or execute a command, nothing appears on the
console (neither error nor warning). However, when I reload the notebook
page I get:

Fehler: Die Verbindung zu
ws://127.0.0.1:8888/kernels/a9a26480-6400-4184-ae62-ad1b0e40a5f5/shell
wurde unterbrochen, während die Seite geladen wurde.
Quelldatei: http://127.0.0.1:8888/static/js/kernel.js
Zeile: 124

Fehler: Die Verbindung zu
ws://127.0.0.1:8888/kernels/a9a26480-6400-4184-ae62-ad1b0e40a5f5/iopub
wurde unterbrochen, während die Seite geladen wurde.
Quelldatei: http://127.0.0.1:8888/static/js/kernel.js
Zeile: 125

(english: connection lost while loading the page)

The same happens when I close the notebook page or press "Restart kernel".

After closing the notebook, I additionaly get:

Error: attempt to run compile-and-go script on a cleared scope
Quelldatei: http://127.0.0.1:8888/static/js/kernel.js
Zeile: 140

I also tried to run Firefox with add-ons disabled, but to no avail.

Best regards
Ulli


_______________________________________________
IPython-User mailing list
[hidden email]
http://mail.scipy.org/mailman/listinfo/ipython-user
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Notebook doesn't produce output

bevanj
Ullrich Koethe wrote
Hi Fernando and Benjamin,

thanks for your suggestions.

 >>
 >> How can I proceed to fix the problem?
 >
I am wondering if this issue has been addressed as I seem to be suffering from the same/similar problem.  When I run a cell I get In [*] but no output.  My system is Windows 7 64 bit.  Although my python is 32 bit.
I am using:
    ipython 0.13.dev
    tornado 2.2
    zmq 2.1.11
    simplejson 2.5.0
    Chrome 18.0.1025.142 m

I looked in Tools - JavaScript console but can't see any errors...
Any thoughts on where I should look are most appreciated, as I am looking forward to playing with the notebook.  I also appreciate the work that has gone into ipython a lot.

Bevan

Loading...