Quantcast

[IPython-User] %matplotlib qt hangs notebook

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[IPython-User] %matplotlib qt hangs notebook

Vasco Tenner-2
Dear,
sometimes when I run %matplotlib qt in the ipython notebook (v4), it is
indicated that the cell is executed and that the kernel is not busy.
However, the next cell cannot be executed: there appears a *, as should
be, but there is no output, the * remains, but the kernel does not look
busy.

This mainly happens when I run the second cell, while the %matplotlib qt
command is not finished yet.

Is this a known problem? How can I diagnose what is going on? I tried to
start jupyter with --debug flag, but it does not give any errors or
messages relating the notebook/kernel that is giving problems.

This problem occurs at both a windowsxp machine with the newest python3
version from anaconda, as on a ubuntu machine, with
* python '3.4.0 (default, Jun 19 2015, 14:20:21) \n[GCC 4.8.2]'
* matplotlib 1.3.1

Both with ipython4 from pypi

Kind regards,
Vasco

_______________________________________________
IPython-User mailing list
[hidden email]
https://mail.scipy.org/mailman/listinfo/ipython-user
Loading...