Installing on Windowblowz

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Installing on Windowblowz

Jesse Warden-2
Friend is trying to install on Windows.  Holy shit what a mess.

2 errors, maybe y'all can help:

1. "Unable to find vcvarsall.bat"  eh?

2. Second, easy install does't seem to work with 2.7; 404 on the egg or whatever

_______________________________________________
PyAMF users mailing list - [hidden email]
http://lists.pyamf.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Installing on Windowblowz

Nick Joyce
Ah the wonderful world of Python packaging - welcome to a world of pain :)

On 2 Oct 2010, at 11:53, Jesse Warden wrote:

> Friend is trying to install on Windows.  Holy shit what a mess.
>
> 2 errors, maybe y'all can help:
>
> 1. "Unable to find vcvarsall.bat"  eh?

To use the compiled c-extensions, Visual Studio (or at least the 'free' compiler and libs) must be installed. You can bypass this step and use the pure python equivalent (but obviously you lose the speedups) by doing:

c:\Python26\python.exe setup.py install --disable-ext

>
> 2. Second, easy install does't seem to work with 2.7; 404 on the egg or whatever

We don't have Python 2.7 eggs available since we don't support it currently. By all accounts it works but we will need build slaves to ensure it does on all platforms.

We also use build slaves to make all the necessary binaries and package up PyAMF into eggs. Windows 7 is a missing platform (along with a couple others).
_______________________________________________
PyAMF users mailing list - [hidden email]
http://lists.pyamf.org/mailman/listinfo/users