Minimum requirements?

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Minimum requirements?

Daniel.
Hi everybody!

I was looking for minimum requirements for an pyqt application. For doing this I'm taking minimum requirements for all it's dependencies, manly Python, Qt and pyqt. I guess that the major dependency for PyQt is Qt it self, so I would have no problems with Qt.

I can't find anything like _minimum requirements for running Qt apps_ on Qt documentation.The most of the documents about requirements are for developing and building Qt apps and not for running them.

If anybody has faced this question before and want to point out a direction for following other than getting the minimum requirements for each dependence I would appreciate. Since this is a common request in desktop software development, the community would benefit from a roadmap for such scenarios. Summing up, any help is appreciated! :-)

Regards,
--
“If you're going to try, go all the way. Otherwise, don't even start. ..."
  Charles Bukowski

_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: Minimum requirements?

Florian Bruhin
On Tue, Oct 09, 2018 at 10:32:20AM -0300, Daniel. wrote:
> I can't find anything like _minimum requirements for running Qt apps_ on Qt
> documentation.The most of the documents about requirements are for
> developing and building Qt apps and not for running them.

Do you mean something like this?
http://doc.qt.io/qt-5.11/supported-platforms.html

As for run-time library dependencies, that entirely depends on how Qt
was built.

Florian

--
https://www.qutebrowser.org | [hidden email] (Mail/XMPP)
   GPG: 916E B0C8 FD55 A072 | https://the-compiler.org/pubkey.asc
         I love long mails! | https://email.is-not-s.ms/

_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt

signature.asc (849 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Minimum requirements?

Kyle Altendorf
In reply to this post by Daniel.
On 2018-10-09 09:32, Daniel. wrote:

> Hi everybody!
>
> I was looking for minimum requirements for an pyqt application. For
> doing this I'm taking minimum requirements for all it's dependencies,
> manly Python, Qt and pyqt. I guess that the major dependency for PyQt
> is Qt it self, so I would have no problems with Qt.
>
> I can't find anything like _minimum requirements for running Qt apps_
> on Qt documentation.The most of the documents about requirements are
> for developing and building Qt apps and not for running them.
>
> If anybody has faced this question before and want to point out a
> direction for following other than getting the minimum requirements for
> each dependence I would appreciate. Since this is a common request in
> desktop software development, the community would benefit from a
> roadmap for such scenarios. Summing up, any help is appreciated! :-)

Requirements like 'how do I distribute my program' or like 'I should
tell my users to have at least a 1GHz CPU and 2GB of RAM'?  I'm thinking
you mean the latter but I don't think it's really a thing that can be
answered generally.  It depends entirely on what the program does.  Some
programs will require a Raspberry PI and other's a 42 core workstation.  
I guess for a bottom line, if you really need some numbers, maybe you
just take the OS suggested minimums.

Cheers,
-kyle
_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: Minimum requirements?

Daniel.
In reply to this post by Florian Bruhin
Hi Florian,

I saw this page, yeah but it states compilers etc. The information about runtime libraries are really helpful, thanks!!!

What I'm doing is to test it with the minimum requirement for Windows XP since I have a requirement of supporting Windows XP

Regards,

Em ter, 9 de out de 2018 às 11:03, Florian Bruhin <[hidden email]> escreveu:
On Tue, Oct 09, 2018 at 10:32:20AM -0300, Daniel. wrote:
> I can't find anything like _minimum requirements for running Qt apps_ on Qt
> documentation.The most of the documents about requirements are for
> developing and building Qt apps and not for running them.

Do you mean something like this?
http://doc.qt.io/qt-5.11/supported-platforms.html

As for run-time library dependencies, that entirely depends on how Qt
was built.

Florian

--
https://www.qutebrowser.org | [hidden email] (Mail/XMPP)
   GPG: 916E B0C8 FD55 A072 | https://the-compiler.org/pubkey.asc
         I love long mails! | https://email.is-not-s.ms/


--
“If you're going to try, go all the way. Otherwise, don't even start. ..."
  Charles Bukowski

_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: Minimum requirements?

Kyle Altendorf
On 2018-10-09 13:35, Daniel. wrote:

> What I'm doing is to test it with the minimum requirement for Windows
> XP since I have a requirement of supporting Windows XP

Note that that leaves you running Python 3.4.

https://docs.python.org/3/using/windows.html#supported-versions

Apparently 3.4 is still supported but the plan is that the final release
will be in March 2019.

https://www.python.org/dev/peps/pep-0429/#release-schedule

Also, the PyQt5 wheels anyways are 3.5+ as I recall.

Cheers,
-kyle
_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt