Problem pip installing sqlalchemy-migrate with latest distribute

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem pip installing sqlalchemy-migrate with latest distribute

Mark McLoughlin
Hey,

I've just reported this sqlalchemy-migrate issue:

  http://code.google.com/p/sqlalchemy-migrate/issues/detail?id=131

I thought it was worth pointing out here in case anyone thinks it's not
an sqlalchemy-migrate specific issue.

Cheers,
Mark.

_______________________________________________
Distutils-SIG maillist  -  [hidden email]
http://mail.python.org/mailman/listinfo/distutils-sig
Reply | Threaded
Open this post in threaded view
|

Re: Problem pip installing sqlalchemy-migrate with latest distribute

PJ Eby
On Tue, Oct 25, 2011 at 9:19 AM, Mark McLoughlin <[hidden email]> wrote:
Hey,

I've just reported this sqlalchemy-migrate issue:

 http://code.google.com/p/sqlalchemy-migrate/issues/detail?id=131

I thought it was worth pointing out here in case anyone thinks it's not
an sqlalchemy-migrate specific issue.

It's not.   https://bitbucket.org/tarek/distribute/issue/208 is an incorrect fix; the pkg_resources code was correct, and the documentation was wrong.  So distribute 0.6.23 actually introduces a bug, relative to setuptools.

As it happens, the behavior described in the doc was changed a long time ago because people weren't reading the docs and packages existed in the field using '-rc' tags, so I fixed the problem in pkg_resources, but missed that there was a reference in setuptools.txt to this behavior.


_______________________________________________
Distutils-SIG maillist  -  [hidden email]
http://mail.python.org/mailman/listinfo/distutils-sig