Problems compiling, installing and running programs that need PyGTK

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Problems compiling, installing and running programs that need PyGTK

Dedeco Balaco
Hello,

a few days ago, I decided to try the Gajim XMPP client. Due some
limitations and the willing to have its current version, I need to
compile it from source. Not a big problem, this is not something so new
to me.

But I have a problem with Gajim: it needs PyGTK 2.22+. I have downloaded
PyGTK 2.24.0 source, a few dependencies, compiled and installed it. But
Gajim keeps complaining the same!

For this problem I started a thread in LinuxQuestions.org. There, I
detailed what I have done, and some discussion helped me improve a bit.
But the PyGTK complaint still exists. You may read this thread in
http://www.linuxquestions.org/questions/linux-software-2/bash-simple-lines-known-values-for-variables-wrong-behaviour-what-is-wrong-4175607815/ 
, but it is long and possibly will not interest much people around here.

A few less days ago, in the Gajim development list, someone pointed me
something new. What was told me is also a question that was not answered
in LQ. It is about Python and GTK. The thread can be seen here:
https://lists.gajim.org/pipermail/gajim-devel/2017-June/001175.html

The discussion in Gajim dev list is not too long. I ask you to read the
first two messages of that thread (including the quoted previous
messages because the first reply I received was, by mistake, not sent to
the list). The main part of what I wrote is:

---
4. PyGTK reported, before building:
==
The following modules will be built:
atk
pango

The following modules will NOT be built:
pangocairo
gtk
gtk.glade
gtk.unixprint

Numpy support: no
==

4.1. What should I do to build those in the "NOT" section? Are they used
by Gajim?
---

This item, 4.1, has a question I want to ask here, the first there.

Further, I did what forenjunkie wrote in 2017-06-11 19:09, about the two
python environment commands. With those commands, should I expect that
python reported version 2.24.0, since I installed this version of PyGTK?
Or I would need to compile the gtk module in PyGTK? How? I installed
PyGTK in /usr/local, as you may see in those related threads I point here.

Hopefully you can help me.

Thank you in advance,

Balaco

_______________________________________________
pygtk mailing list   [hidden email]
http://mailman.daa.com.au/cgi-bin/mailman/listinfo/pygtk
Read the PyGTK FAQ: http://faq.pygtk.org/