PyQtDeploy: Supported development hosts for Android

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

PyQtDeploy: Supported development hosts for Android

safa1996alfulaij
Hi all,
I'm trying to follow the documentation of pyqtdeploy to build the demo on my Android device.
I'm now stuch where I get:

D:\0000-pyQt_Android\pyqtdeploy-2.4\demo>python build-demo.py --target=android-64 --source-dir="D:\0000-pyQt_Android\libraries" --installed-qt-dir="C:\QtOld\5.12.3"
pyqtdeploy-sysroot: win-64 is not a supported android-64 development host
Is it that I have to use my Linux distro to build for Android? Or am I doing something wrong?
Using Windows 10-64bit

Regards

Virus-free. www.avast.com

_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: PyQtDeploy: Supported development hosts for Android

safa1996alfulaij
Oh, and using x64 Native Tools Command Promot for VS 2017.

Virus-free. www.avast.com

‫في الخميس، 12 سبتمبر 2019 في 10:25 ص تمت كتابة ما يلي بواسطة ‪Safa Alfulaij‬‏ <‪[hidden email]‬‏>:‬
Hi all,
I'm trying to follow the documentation of pyqtdeploy to build the demo on my Android device.
I'm now stuch where I get:

D:\0000-pyQt_Android\pyqtdeploy-2.4\demo>python build-demo.py --target=android-64 --source-dir="D:\0000-pyQt_Android\libraries" --installed-qt-dir="C:\QtOld\5.12.3"
pyqtdeploy-sysroot: win-64 is not a supported android-64 development host
Is it that I have to use my Linux distro to build for Android? Or am I doing something wrong?
Using Windows 10-64bit

Regards

Virus-free. www.avast.com

_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: PyQtDeploy: Supported development hosts for Android

Phil Thompson-5
In reply to this post by safa1996alfulaij
On 12/09/2019 09:25, Safa Alfulaij wrote:

> Hi all,
> I'm trying to follow the documentation of pyqtdeploy to build the demo
> on
> my Android device.
> I'm now stuch where I get:
>
> D:\0000-pyQt_Android\pyqtdeploy-2.4\demo>python build-demo.py
> --target=android-64 --source-dir="D:\0000-pyQt_Android\libraries"
> --installed-qt-dir="C:\QtOld\5.12.3"
> pyqtdeploy-sysroot: win-64 is not a supported android-64 development
> host
> Is it that I have to use my Linux distro to build for Android? Or am I
> doing something wrong?
> Using Windows 10-64bit

You have to use Linux or macOS as the host. Using Windows as a host
shouldn’t require too many changes, so patches welcome...

Phil

_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: PyQtDeploy: Supported development hosts for Android

safa1996alfulaij
Thanks :)
Well, maybe once I gain the needed knowledge :)

Now I tried it on my ArchLinux. Using NDK r19c, SDK 22&26, Qt 5.12.2, PyQt5.12.1.
I'm getting
/home/safa/Android/Ndk/android-ndk-r19c/toolchains/llvm/prebuilt/linux-x86_64/bin/clang++ -c -D__ANDROID_API__=26 -target aarch64-none-linux-android -gcc-toolchain /home/safa/Android/Ndk/android-ndk-r19c/toolchains/aarch64-linux-android-4.9/prebuilt/linux-x86_64 -fno-limit-debug-info -DANDROID_HAS_WSTRING --sysroot=/home/safa/Android/Ndk/android-ndk-r19c/sysroot -isystem /home/safa/Android/Ndk/android-ndk-r19c/sysroot/usr/include/aarch64-linux-android -isystem /home/safa/Android/Ndk/android-ndk-r19c/sources/cxx-stl/llvm-libc++/include -isystem /home/safa/Android/Ndk/android-ndk-r19c/sources/android/support/include -isystem /home/safa/Android/Ndk/android-ndk-r19c/sources/cxx-stl/llvm-libc++abi/include -fstack-protector-strong -DANDROID -O2 -O2 -fPIC -fvisibility=hidden -fvisibility-inlines-hidden -fno-exceptions -Wall -W -D_REENTRANT -DSIP_PROTECTED_IS_PUBLIC -Dprotected=public -DPy_LIMITED_API=0x03040000 -DQT_NO_EXCEPTIONS -DQT_NO_DEBUG -DQT_CORE_LIB -I. -I. -I../../../include/python3.7 -I../qpy/QtCore -I/home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/include -I/home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/include/QtCore -I. -I/home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/mkspecs/android-clang -o qpycore_post_init.o qpycore_post_init.cpp
In file included from qpycore_post_init.cpp:23:
In file included from /home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/include/QtCore/QMutex:1:
In file included from /home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/include/QtCore/qmutex.h:43:
/home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/include/QtCore/qglobal.h:45:12: fatal error: 'type_traits' file not found
#  include <type_traits>
           ^~~~~~~~~~~~~
1 error generated.
make[1]: *** [Makefile:1027: qpycore_post_init.o] Error 1
make[1]: Leaving directory '/home/safa/0000-PyQt_Andoird/pyqtdeploy-2.4/demo/sysroot-android-64/build/PyQt5_gpl-5.12.1/QtCore'
make: *** [Makefile:53: sub-QtCore-make_first-ordered] Error 2
pyqtdeploy-sysroot: Execution failed: returned exit code 2
[safa@archlinux demo]$
I'm pretty sure that this is about gcc/clang/c++17, but I'm using the proper versions, I suppose.

Thanks.

‫في الخميس، 12 سبتمبر 2019 في 10:35 ص تمت كتابة ما يلي بواسطة ‪Phil Thompson‬‏ <‪[hidden email]‬‏>:‬
On 12/09/2019 09:25, Safa Alfulaij wrote:
> Hi all,
> I'm trying to follow the documentation of pyqtdeploy to build the demo
> on
> my Android device.
> I'm now stuch where I get:
>
> D:\0000-pyQt_Android\pyqtdeploy-2.4\demo>python build-demo.py
> --target=android-64 --source-dir="D:\0000-pyQt_Android\libraries"
> --installed-qt-dir="C:\QtOld\5.12.3"
> pyqtdeploy-sysroot: win-64 is not a supported android-64 development
> host
> Is it that I have to use my Linux distro to build for Android? Or am I
> doing something wrong?
> Using Windows 10-64bit

You have to use Linux or macOS as the host. Using Windows as a host
shouldn’t require too many changes, so patches welcome...

Phil


_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: PyQtDeploy: Supported development hosts for Android

Phil Thompson-5
On 12/09/2019 14:44, Safa Alfulaij wrote:

> Thanks :)
> Well, maybe once I gain the needed knowledge :)
>
> Now I tried it on my ArchLinux. Using NDK r19c, SDK 22&26, Qt 5.12.2,
> PyQt5.12.1.
> I'm getting
> /home/safa/Android/Ndk/android-ndk-r19c/toolchains/llvm/prebuilt/linux-x86_64/bin/clang++
> -c -D__ANDROID_API__=26 -target aarch64-none-linux-android
> -gcc-toolchain
> /home/safa/Android/Ndk/android-ndk-r19c/toolchains/aarch64-linux-android-4.9/prebuilt/linux-x86_64
> -fno-limit-debug-info -DANDROID_HAS_WSTRING
> --sysroot=/home/safa/Android/Ndk/android-ndk-r19c/sysroot -isystem
> /home/safa/Android/Ndk/android-ndk-r19c/sysroot/usr/include/aarch64-linux-android
> -isystem
> /home/safa/Android/Ndk/android-ndk-r19c/sources/cxx-stl/llvm-libc++/include
> -isystem
> /home/safa/Android/Ndk/android-ndk-r19c/sources/android/support/include
> -isystem
> /home/safa/Android/Ndk/android-ndk-r19c/sources/cxx-stl/llvm-libc++abi/include
> -fstack-protector-strong -DANDROID -O2 -O2 -fPIC -fvisibility=hidden
> -fvisibility-inlines-hidden -fno-exceptions -Wall -W -D_REENTRANT
> -DSIP_PROTECTED_IS_PUBLIC -Dprotected=public
> -DPy_LIMITED_API=0x03040000
> -DQT_NO_EXCEPTIONS -DQT_NO_DEBUG -DQT_CORE_LIB -I. -I.
> -I../../../include/python3.7 -I../qpy/QtCore
> -I/home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/include
> -I/home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/include/QtCore -I.
> -I/home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/mkspecs/android-clang -o
> qpycore_post_init.o qpycore_post_init.cpp
> In file included from qpycore_post_init.cpp:23:
> In file included from
> /home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/include/QtCore/QMutex:1:
> In file included from
> /home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/include/QtCore/qmutex.h:43:
> /home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/include/QtCore/qglobal.h:45:12:
> fatal error: 'type_traits' file not found
> #  include <type_traits>
>            ^~~~~~~~~~~~~
> 1 error generated.
> make[1]: *** [Makefile:1027: qpycore_post_init.o] Error 1
> make[1]: Leaving directory
> '/home/safa/0000-PyQt_Andoird/pyqtdeploy-2.4/demo/sysroot-android-64/build/PyQt5_gpl-5.12.1/QtCore'
> make: *** [Makefile:53: sub-QtCore-make_first-ordered] Error 2
> pyqtdeploy-sysroot: Execution failed: returned exit code 2
> [safa@archlinux demo]$
> I'm pretty sure that this is about gcc/clang/c++17, but I'm using the
> proper versions, I suppose.

Start by building the demo using the same versions shown in the demo
screenshots. Only those combinations of versions has been tested. Once
that works, change versions one thing at a time until you are using the
versions you want to use. If a version doesn't work then *you* have to
debug it.

Phil
_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: PyQtDeploy: Supported development hosts for Android

iMath
In reply to this post by safa1996alfulaij
Have you googled "fatal error: 'type_traits' file not found" to find solutions ? 





在 2019-09-12 21:44:01,"Safa Alfulaij" <[hidden email]> 写道:
Thanks :)
Well, maybe once I gain the needed knowledge :)

Now I tried it on my ArchLinux. Using NDK r19c, SDK 22&26, Qt 5.12.2, PyQt5.12.1.
I'm getting
/home/safa/Android/Ndk/android-ndk-r19c/toolchains/llvm/prebuilt/linux-x86_64/bin/clang++ -c -D__ANDROID_API__=26 -target aarch64-none-linux-android -gcc-toolchain /home/safa/Android/Ndk/android-ndk-r19c/toolchains/aarch64-linux-android-4.9/prebuilt/linux-x86_64 -fno-limit-debug-info -DANDROID_HAS_WSTRING --sysroot=/home/safa/Android/Ndk/android-ndk-r19c/sysroot -isystem /home/safa/Android/Ndk/android-ndk-r19c/sysroot/usr/include/aarch64-linux-android -isystem /home/safa/Android/Ndk/android-ndk-r19c/sources/cxx-stl/llvm-libc++/include -isystem /home/safa/Android/Ndk/android-ndk-r19c/sources/android/support/include -isystem /home/safa/Android/Ndk/android-ndk-r19c/sources/cxx-stl/llvm-libc++abi/include -fstack-protector-strong -DANDROID -O2 -O2 -fPIC -fvisibility=hidden -fvisibility-inlines-hidden -fno-exceptions -Wall -W -D_REENTRANT -DSIP_PROTECTED_IS_PUBLIC -Dprotected=public -DPy_LIMITED_API=0x03040000 -DQT_NO_EXCEPTIONS -DQT_NO_DEBUG -DQT_CORE_LIB -I. -I. -I../../../include/python3.7 -I../qpy/QtCore -I/home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/include -I/home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/include/QtCore -I. -I/home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/mkspecs/android-clang -o qpycore_post_init.o qpycore_post_init.cpp
In file included from qpycore_post_init.cpp:23:
In file included from /home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/include/QtCore/QMutex:1:
In file included from /home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/include/QtCore/qmutex.h:43:
/home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/include/QtCore/qglobal.h:45:12: fatal error: 'type_traits' file not found
#  include <type_traits>
           ^~~~~~~~~~~~~
1 error generated.
make[1]: *** [Makefile:1027: qpycore_post_init.o] Error 1
make[1]: Leaving directory '/home/safa/0000-PyQt_Andoird/pyqtdeploy-2.4/demo/sysroot-android-64/build/PyQt5_gpl-5.12.1/QtCore'
make: *** [Makefile:53: sub-QtCore-make_first-ordered] Error 2
pyqtdeploy-sysroot: Execution failed: returned exit code 2
[safa@archlinux demo]$
I'm pretty sure that this is about gcc/clang/c++17, but I'm using the proper versions, I suppose.

Thanks.

‫في الخميس، 12 سبتمبر 2019 في 10:35 ص تمت كتابة ما يلي بواسطة ‪Phil Thompson‬‏ <‪[hidden email]‬‏>:‬
On 12/09/2019 09:25, Safa Alfulaij wrote:
> Hi all,
> I'm trying to follow the documentation of pyqtdeploy to build the demo
> on
> my Android device.
> I'm now stuch where I get:
>
> D:\0000-pyQt_Android\pyqtdeploy-2.4\demo>python build-demo.py
> --target=android-64 --source-dir="D:\0000-pyQt_Android\libraries"
> --installed-qt-dir="C:\QtOld\5.12.3"
> pyqtdeploy-sysroot: win-64 is not a supported android-64 development
> host
> Is it that I have to use my Linux distro to build for Android? Or am I
> doing something wrong?
> Using Windows 10-64bit

You have to use Linux or macOS as the host. Using Windows as a host
shouldn’t require too many changes, so patches welcome...

Phil



 


_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: PyQtDeploy: Supported development hosts for Android

safa1996alfulaij
I tried googling
Most of comments are about building with c++11. I added a config setting in .pro files but it didn't work. I think it's thinking its gcc while its clang, somehow.

I'll keep looking and hopefully I get something working.

Thank!

On Sat, Sep 14, 2019, 4:38 AM Zhao Lee <[hidden email]> wrote:
Have you googled "fatal error: 'type_traits' file not found" to find solutions ? 





在 2019-09-12 21:44:01,"Safa Alfulaij" <[hidden email]> 写道:
Thanks :)
Well, maybe once I gain the needed knowledge :)

Now I tried it on my ArchLinux. Using NDK r19c, SDK 22&26, Qt 5.12.2, PyQt5.12.1.
I'm getting
/home/safa/Android/Ndk/android-ndk-r19c/toolchains/llvm/prebuilt/linux-x86_64/bin/clang++ -c -D__ANDROID_API__=26 -target aarch64-none-linux-android -gcc-toolchain /home/safa/Android/Ndk/android-ndk-r19c/toolchains/aarch64-linux-android-4.9/prebuilt/linux-x86_64 -fno-limit-debug-info -DANDROID_HAS_WSTRING --sysroot=/home/safa/Android/Ndk/android-ndk-r19c/sysroot -isystem /home/safa/Android/Ndk/android-ndk-r19c/sysroot/usr/include/aarch64-linux-android -isystem /home/safa/Android/Ndk/android-ndk-r19c/sources/cxx-stl/llvm-libc++/include -isystem /home/safa/Android/Ndk/android-ndk-r19c/sources/android/support/include -isystem /home/safa/Android/Ndk/android-ndk-r19c/sources/cxx-stl/llvm-libc++abi/include -fstack-protector-strong -DANDROID -O2 -O2 -fPIC -fvisibility=hidden -fvisibility-inlines-hidden -fno-exceptions -Wall -W -D_REENTRANT -DSIP_PROTECTED_IS_PUBLIC -Dprotected=public -DPy_LIMITED_API=0x03040000 -DQT_NO_EXCEPTIONS -DQT_NO_DEBUG -DQT_CORE_LIB -I. -I. -I../../../include/python3.7 -I../qpy/QtCore -I/home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/include -I/home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/include/QtCore -I. -I/home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/mkspecs/android-clang -o qpycore_post_init.o qpycore_post_init.cpp
In file included from qpycore_post_init.cpp:23:
In file included from /home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/include/QtCore/QMutex:1:
In file included from /home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/include/QtCore/qmutex.h:43:
/home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/include/QtCore/qglobal.h:45:12: fatal error: 'type_traits' file not found
#  include <type_traits>
           ^~~~~~~~~~~~~
1 error generated.
make[1]: *** [Makefile:1027: qpycore_post_init.o] Error 1
make[1]: Leaving directory '/home/safa/0000-PyQt_Andoird/pyqtdeploy-2.4/demo/sysroot-android-64/build/PyQt5_gpl-5.12.1/QtCore'
make: *** [Makefile:53: sub-QtCore-make_first-ordered] Error 2
pyqtdeploy-sysroot: Execution failed: returned exit code 2
[safa@archlinux demo]$
I'm pretty sure that this is about gcc/clang/c++17, but I'm using the proper versions, I suppose.

Thanks.

‫في الخميس، 12 سبتمبر 2019 في 10:35 ص تمت كتابة ما يلي بواسطة ‪Phil Thompson‬‏ <‪[hidden email]‬‏>:‬
On 12/09/2019 09:25, Safa Alfulaij wrote:
> Hi all,
> I'm trying to follow the documentation of pyqtdeploy to build the demo
> on
> my Android device.
> I'm now stuch where I get:
>
> D:\0000-pyQt_Android\pyqtdeploy-2.4\demo>python build-demo.py
> --target=android-64 --source-dir="D:\0000-pyQt_Android\libraries"
> --installed-qt-dir="C:\QtOld\5.12.3"
> pyqtdeploy-sysroot: win-64 is not a supported android-64 development
> host
> Is it that I have to use my Linux distro to build for Android? Or am I
> doing something wrong?
> Using Windows 10-64bit

You have to use Linux or macOS as the host. Using Windows as a host
shouldn’t require too many changes, so patches welcome...

Phil



 


_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: PyQtDeploy: Supported development hosts for Android

iMath
You could also search with the keyword Qt, that is to google  "Qt fatal error: 'type_traits' file not found", I found some threads said it was NDK that caused the problem, but I am not sure if it is true,  maybe you could give it a try! 
No matter whether you solved the problem in the end, drop me a line, I am really interested in whether it is viable to develop Android APP with PyQt.




At 2019-09-15 06:07:12, "Safa Alfulaij" <[hidden email]> wrote:
I tried googling
Most of comments are about building with c++11. I added a config setting in .pro files but it didn't work. I think it's thinking its gcc while its clang, somehow.

I'll keep looking and hopefully I get something working.

Thank!

On Sat, Sep 14, 2019, 4:38 AM Zhao Lee <[hidden email]> wrote:
Have you googled "fatal error: 'type_traits' file not found" to find solutions ? 





在 2019-09-12 21:44:01,"Safa Alfulaij" <[hidden email]> 写道:
Thanks :)
Well, maybe once I gain the needed knowledge :)

Now I tried it on my ArchLinux. Using NDK r19c, SDK 22&26, Qt 5.12.2, PyQt5.12.1.
I'm getting
/home/safa/Android/Ndk/android-ndk-r19c/toolchains/llvm/prebuilt/linux-x86_64/bin/clang++ -c -D__ANDROID_API__=26 -target aarch64-none-linux-android -gcc-toolchain /home/safa/Android/Ndk/android-ndk-r19c/toolchains/aarch64-linux-android-4.9/prebuilt/linux-x86_64 -fno-limit-debug-info -DANDROID_HAS_WSTRING --sysroot=/home/safa/Android/Ndk/android-ndk-r19c/sysroot -isystem /home/safa/Android/Ndk/android-ndk-r19c/sysroot/usr/include/aarch64-linux-android -isystem /home/safa/Android/Ndk/android-ndk-r19c/sources/cxx-stl/llvm-libc++/include -isystem /home/safa/Android/Ndk/android-ndk-r19c/sources/android/support/include -isystem /home/safa/Android/Ndk/android-ndk-r19c/sources/cxx-stl/llvm-libc++abi/include -fstack-protector-strong -DANDROID -O2 -O2 -fPIC -fvisibility=hidden -fvisibility-inlines-hidden -fno-exceptions -Wall -W -D_REENTRANT -DSIP_PROTECTED_IS_PUBLIC -Dprotected=public -DPy_LIMITED_API=0x03040000 -DQT_NO_EXCEPTIONS -DQT_NO_DEBUG -DQT_CORE_LIB -I. -I. -I../../../include/python3.7 -I../qpy/QtCore -I/home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/include -I/home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/include/QtCore -I. -I/home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/mkspecs/android-clang -o qpycore_post_init.o qpycore_post_init.cpp
In file included from qpycore_post_init.cpp:23:
In file included from /home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/include/QtCore/QMutex:1:
In file included from /home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/include/QtCore/qmutex.h:43:
/home/safa/Qt5.12.2/5.12.2/android_arm64_v8a/include/QtCore/qglobal.h:45:12: fatal error: 'type_traits' file not found
#  include <type_traits>
           ^~~~~~~~~~~~~
1 error generated.
make[1]: *** [Makefile:1027: qpycore_post_init.o] Error 1
make[1]: Leaving directory '/home/safa/0000-PyQt_Andoird/pyqtdeploy-2.4/demo/sysroot-android-64/build/PyQt5_gpl-5.12.1/QtCore'
make: *** [Makefile:53: sub-QtCore-make_first-ordered] Error 2
pyqtdeploy-sysroot: Execution failed: returned exit code 2
[safa@archlinux demo]$
I'm pretty sure that this is about gcc/clang/c++17, but I'm using the proper versions, I suppose.

Thanks.

‫في الخميس، 12 سبتمبر 2019 في 10:35 ص تمت كتابة ما يلي بواسطة ‪Phil Thompson‬‏ <‪[hidden email]‬‏>:‬
On 12/09/2019 09:25, Safa Alfulaij wrote:
> Hi all,
> I'm trying to follow the documentation of pyqtdeploy to build the demo
> on
> my Android device.
> I'm now stuch where I get:
>
> D:\0000-pyQt_Android\pyqtdeploy-2.4\demo>python build-demo.py
> --target=android-64 --source-dir="D:\0000-pyQt_Android\libraries"
> --installed-qt-dir="C:\QtOld\5.12.3"
> pyqtdeploy-sysroot: win-64 is not a supported android-64 development
> host
> Is it that I have to use my Linux distro to build for Android? Or am I
> doing something wrong?
> Using Windows 10-64bit

You have to use Linux or macOS as the host. Using Windows as a host
shouldn’t require too many changes, so patches welcome...

Phil



 



 


_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt