PyQtWebEngine build requirements

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

PyQtWebEngine build requirements

Davide Pesavento
Hi,

It seems that PyQtWebEngine 5.13.0 cannot be built with a version of
QtWebEngine older than 5.13.0 (see [1]). I was wondering if this
requirement is intentional given that, when the module was part of
PyQt5, it was compatible with a wide range of Qt versions.

Furthermore, does PyQtWebEngine version N require PyQt5 version >= N,
or there's no such requirement?

[1] https://bugs.gentoo.org/689602

Thanks,
Davide
_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: PyQtWebEngine build requirements

Phil Thompson-5
On 12/07/2019 19:23, Davide Pesavento wrote:
> Hi,
>
> It seems that PyQtWebEngine 5.13.0 cannot be built with a version of
> QtWebEngine older than 5.13.0 (see [1]). I was wondering if this
> requirement is intentional given that, when the module was part of
> PyQt5, it was compatible with a wide range of Qt versions.

It's a bug - fixed in tonight's snapshot.

> Furthermore, does PyQtWebEngine version N require PyQt5 version >= N,
> or there's no such requirement?

Bugs aside, you should always use the latest PyQt version no matter what
version of Qt you are using.

Phil
_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt