Pygame

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Pygame

Marc Stevens
Geachte python experts,
 
Na een tijdje zoeken ben ik er achter gekomen dat je voor pygame een x86 versie van python nodig hebt.
Ik heb toen python 34  gedownload want 3.5 schijnt op een of andere manier ook niet te werken.
Heb daarna ook pip aan het werken gekregen, maar krijg echter ook hiermee pygame niet aan het werken.
Ik heb pygame wel succesvol gedownload en geinstalleerd, maar ik kan me nog iets herinneren van mijn vorige computer dat er nog enige handelingen nodig zijn om pygame te activeren (iets van Pypi en ez_setup.py of zoiets).
Verder gaat er nog iets verkeerd. Als ik Python Gui open met slechts een klik, worden er verschillende vensters geopend.
De verklaring dat het allemaal niet zo lekker loopt is dat ik nu met windows 8 werk.
mijn vraag : hoe krijg ik pygame aan het werken zodat ik grafische programma’s kan laten draaien en hoe krijg ik de Gui fatsoenlijk geopend.
 
                                                                                   
 
                                                                                            B.V.D.
                                                                                               
                                                                                                    Groetjes Marc Stevens
 

_______________________________________________
Python-nl mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/python-nl
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pygame

Floris van Manen
pygame zit standaard op de raspberry pi debian distributie.
En het werkt ook prima op alle andere ARM bordjes.

.F


> On 9 Apr 2015, at 20:54, Marc Stevens <[hidden email]> wrote:
>
> Geachte python experts,
>  
> Na een tijdje zoeken ben ik er achter gekomen dat je voor pygame een x86 versie van python nodig hebt.
> Ik heb toen python 34  gedownload want 3.5 schijnt op een of andere manier ook niet te werken.
> Heb daarna ook pip aan het werken gekregen, maar krijg echter ook hiermee pygame niet aan het werken.
> Ik heb pygame wel succesvol gedownload en geinstalleerd, maar ik kan me nog iets herinneren van mijn vorige computer dat er nog enige handelingen nodig zijn om pygame te activeren (iets van Pypi en ez_setup.py of zoiets).
> Verder gaat er nog iets verkeerd. Als ik Python Gui open met slechts een klik, worden er verschillende vensters geopend.
> De verklaring dat het allemaal niet zo lekker loopt is dat ik nu met windows 8 werk.
> mijn vraag : hoe krijg ik pygame aan het werken zodat ik grafische programma’s kan laten draaien en hoe krijg ik de Gui fatsoenlijk geopend.
>  
>                                                                                    
>  
>                                                                                             B.V.D.
>                                                                                                
>                                                                                                     Groetjes Marc Stevens
>  
> _______________________________________________
> Python-nl mailing list
> [hidden email]
> https://mail.python.org/mailman/listinfo/python-nl

_______________________________________________
Python-nl mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/python-nl
JMH
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pygame

JMH
Zolang je een 32-bits versie van Python gebruikt en de Pygame precies matcht is het ok.

Het makkelijkst: Je kunt ook een bundel downloaden zoals Pythonxy, in de installer dan ook Pygame aanvinken. Die werkt zeker. (Windows en Linux).

Best regards/Met vriendelijke groeten,
    Jacco Hoekstra

Sent from my iPhone, hence the typos.

> On 9 apr. 2015, at 22:05, Floris van Manen <[hidden email]> wrote:
>
> pygame zit standaard op de raspberry pi debian distributie.
> En het werkt ook prima op alle andere ARM bordjes.
>
> .F
>
>
>> On 9 Apr 2015, at 20:54, Marc Stevens <[hidden email]> wrote:
>>
>> Geachte python experts,
>>
>> Na een tijdje zoeken ben ik er achter gekomen dat je voor pygame een x86 versie van python nodig hebt.
>> Ik heb toen python 34  gedownload want 3.5 schijnt op een of andere manier ook niet te werken.
>> Heb daarna ook pip aan het werken gekregen, maar krijg echter ook hiermee pygame niet aan het werken.
>> Ik heb pygame wel succesvol gedownload en geinstalleerd, maar ik kan me nog iets herinneren van mijn vorige computer dat er nog enige handelingen nodig zijn om pygame te activeren (iets van Pypi en ez_setup.py of zoiets).
>> Verder gaat er nog iets verkeerd. Als ik Python Gui open met slechts een klik, worden er verschillende vensters geopend.
>> De verklaring dat het allemaal niet zo lekker loopt is dat ik nu met windows 8 werk.
>> mijn vraag : hoe krijg ik pygame aan het werken zodat ik grafische programma’s kan laten draaien en hoe krijg ik de Gui fatsoenlijk geopend.
>>
>>
>>
>>                                                                                            B.V.D.
>>
>>                                                                                                    Groetjes Marc Stevens
>>
>> _______________________________________________
>> Python-nl mailing list
>> [hidden email]
>> https://mail.python.org/mailman/listinfo/python-nl
>
> _______________________________________________
> Python-nl mailing list
> [hidden email]
> https://mail.python.org/mailman/listinfo/python-nl
_______________________________________________
Python-nl mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/python-nl
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pygame

Geert Stappers
In reply to this post by Floris van Manen
On Thu, Apr 09, 2015 at 10:05:40PM +0200, Floris van Manen wrote:

> > On 9 Apr 2015, at 20:54, Marc Stevens <[hidden email]> wrote:
> >
> > Geachte python experts,
> >
> > Na een tijdje zoeken ben ik er achter gekomen dat je voor pygame
> > een x86 versie van python nodig hebt.
>
> pygame zit standaard op de raspberry pi debian distributie.
> En het werkt ook prima op alle andere ARM bordjes.
>

Mijn inschatting is ook dat
het onzin is, dat pygame alleen op x86 draait.


> > Ik heb toen python 34  gedownload want 3.5 schijnt op een of andere
> > manier ook niet te werken.  Heb daarna ook pip aan het werken
> > gekregen, maar krijg echter ook hiermee pygame niet aan het werken.
> > Ik heb pygame wel succesvol gedownload en geinstalleerd, maar ik
> > kan me nog iets herinneren van mijn vorige computer dat er nog
> > enige handelingen nodig zijn om pygame te activeren (iets van Pypi
> > en ez_setup.py of zoiets).  Verder gaat er nog iets verkeerd. Als
> > ik Python Gui open met slechts een klik, worden er verschillende
> > vensters geopend.  De verklaring dat het allemaal niet zo lekker
> > loopt is dat ik nu met windows 8 werk.  mijn vraag : hoe krijg ik
> > pygame aan het werken zodat ik grafische programma???s kan laten
> > draaien en hoe krijg ik de Gui fatsoenlijk geopend.

Van https://www.pygame.org/wiki/FrequentlyAskedQuestions
heb ik dit

import pygame
import os
os.environ['SDL_VIDEO_CENTERED'] = '1'
pygame.init()
try:
     screen = pygame.display.set_mode((200, 200))
     # This should show a blank 200 by 200 window centered on the screen
     pygame.display.flip()
     while True:
         event = pygame.event.wait()
         if event.type == pygame.QUIT:
             break
finally:
     pygame.quit()  # Keep this IDLE friendly


Op mijn Linux systeem komt er dan gewoon een "grafisch" scherm.

Doe er je voordeel mee ...


_______________________________________________
Python-nl mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/python-nl
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pygame

Adri Mathlener
In reply to this post by Marc Stevens
Marc,

werp anders een een blik in dit gratis  boek:

Making Games with Python & Pygame covers the Pygame library with the source code for 11 games. Making Games was written as a sequel for the same age range as Invent with Python. Once you have an understanding of the basics of Python programming, you can now expand your abilities using the Pygame library to make games with graphics, animation, and sound.

The book features the source code to 11 games. The games are clones of classics such as Nibbles, Tetris, Simon, Bejeweled, Othello, Connect Four, Flood It, and others.



2015-04-09 20:54 GMT+02:00 Marc Stevens <[hidden email]>:
Geachte python experts,
 
Na een tijdje zoeken ben ik er achter gekomen dat je voor pygame een x86 versie van python nodig hebt.
Ik heb toen python 34  gedownload want 3.5 schijnt op een of andere manier ook niet te werken.
Heb daarna ook pip aan het werken gekregen, maar krijg echter ook hiermee pygame niet aan het werken.
Ik heb pygame wel succesvol gedownload en geinstalleerd, maar ik kan me nog iets herinneren van mijn vorige computer dat er nog enige handelingen nodig zijn om pygame te activeren (iets van Pypi en ez_setup.py of zoiets).
Verder gaat er nog iets verkeerd. Als ik Python Gui open met slechts een klik, worden er verschillende vensters geopend.
De verklaring dat het allemaal niet zo lekker loopt is dat ik nu met windows 8 werk.
mijn vraag : hoe krijg ik pygame aan het werken zodat ik grafische programma’s kan laten draaien en hoe krijg ik de Gui fatsoenlijk geopend.
 
                                                                                   
 
                                                                                            B.V.D.
                                                                                               
                                                                                                    Groetjes Marc Stevens
 

_______________________________________________
Python-nl mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/python-nl




--

Met vriendelijke groet,
Adri Mathlener

| Adri Mathlener | IT Beheerder  [Video, Mobile Phones & Tablets, Apple Mac] | Kamer 5431.0163 | 
Rijksuniversiteit Groningen | Nettelbosje 1, Zernikeborg 9747 AJ Groningen | T: 050 - 363 9225 |

_______________________________________________
Python-nl mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/python-nl
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pygame

Marc Stevens
In reply to this post by JMH
Beste Jacco,

Python 32 bit versie zou inderdaad moeten matchen, maar dat doet hij dus
niet.
Bij de Installatie van pythonxy kan ik niets van pygame vinden om aan te
vinken.
Ik heb hem wel geinstalleerd maar kon ook in de documentatie niets terug
vinden over een module als pygame
Zie ik iets over het hoofd, bijvoorbeeld bij het installeren of wordt pygame
gewoon door pythonxy niet ondersteund?
Kun je dit effe voor me checken. Alsvast bedankt,

                                                            Marc Stevens


-----Oorspronkelijk bericht-----
From: Jacco Hoekstra
Sent: Thursday, April 9, 2015 10:34 PM
To: Dutch Python developers and users
Subject: Re: [python-nl] Pygame

Zolang je een 32-bits versie van Python gebruikt en de Pygame precies matcht
is het ok.

Het makkelijkst: Je kunt ook een bundel downloaden zoals Pythonxy, in de
installer dan ook Pygame aanvinken. Die werkt zeker. (Windows en Linux).

Best regards/Met vriendelijke groeten,
    Jacco Hoekstra

Sent from my iPhone, hence the typos.

> On 9 apr. 2015, at 22:05, Floris van Manen <[hidden email]> wrote:
>
> pygame zit standaard op de raspberry pi debian distributie.
> En het werkt ook prima op alle andere ARM bordjes.
>
> .F
>
>
>> On 9 Apr 2015, at 20:54, Marc Stevens <[hidden email]> wrote:
>>
>> Geachte python experts,
>>
>> Na een tijdje zoeken ben ik er achter gekomen dat je voor pygame een x86
>> versie van python nodig hebt.
>> Ik heb toen python 34  gedownload want 3.5 schijnt op een of andere
>> manier ook niet te werken.
>> Heb daarna ook pip aan het werken gekregen, maar krijg echter ook hiermee
>> pygame niet aan het werken.
>> Ik heb pygame wel succesvol gedownload en geinstalleerd, maar ik kan me
>> nog iets herinneren van mijn vorige computer dat er nog enige handelingen
>> nodig zijn om pygame te activeren (iets van Pypi en ez_setup.py of
>> zoiets).
>> Verder gaat er nog iets verkeerd. Als ik Python Gui open met slechts een
>> klik, worden er verschillende vensters geopend.
>> De verklaring dat het allemaal niet zo lekker loopt is dat ik nu met
>> windows 8 werk.
>> mijn vraag : hoe krijg ik pygame aan het werken zodat ik grafische
>> programma’s kan laten draaien en hoe krijg ik de Gui fatsoenlijk geopend.
>>
>>
>>
>>
>> B.V.D.
>>
>>
>> Groetjes Marc Stevens
>>
>> _______________________________________________
>> Python-nl mailing list
>> [hidden email]
>> https://mail.python.org/mailman/listinfo/python-nl
>
> _______________________________________________
> Python-nl mailing list
> [hidden email]
> https://mail.python.org/mailman/listinfo/python-nl
_______________________________________________
Python-nl mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/python-nl 

_______________________________________________
Python-nl mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/python-nl
JMH
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Pygame

JMH
Beste Marc,

Pythonxy bevat wel Pygame, hoor. Klik custom-install en even bladeren bij de additionele plug-ins.

Zie ook hier:

http://code.google.com/p/pythonxy/wiki/AdditionalPlugins

Succes!

Best regards/Met vriendelijke groeten,
    Jacco Hoekstra

Sent from my iPhone, hence the typos.

> On 10 apr. 2015, at 13:23, Marc Stevens <[hidden email]> wrote:
>
> Beste Jacco,
>
> Python 32 bit versie zou inderdaad moeten matchen, maar dat doet hij dus niet.
> Bij de Installatie van pythonxy kan ik niets van pygame vinden om aan te vinken.
> Ik heb hem wel geinstalleerd maar kon ook in de documentatie niets terug vinden over een module als pygame
> Zie ik iets over het hoofd, bijvoorbeeld bij het installeren of wordt pygame gewoon door pythonxy niet ondersteund?
> Kun je dit effe voor me checken. Alsvast bedankt,
>
>                                                           Marc Stevens
>
>
> -----Oorspronkelijk bericht----- From: Jacco Hoekstra
> Sent: Thursday, April 9, 2015 10:34 PM
> To: Dutch Python developers and users
> Subject: Re: [python-nl] Pygame
>
> Zolang je een 32-bits versie van Python gebruikt en de Pygame precies matcht is het ok.
>
> Het makkelijkst: Je kunt ook een bundel downloaden zoals Pythonxy, in de installer dan ook Pygame aanvinken. Die werkt zeker. (Windows en Linux).
>
> Best regards/Met vriendelijke groeten,
>   Jacco Hoekstra
>
> Sent from my iPhone, hence the typos.
>
>> On 9 apr. 2015, at 22:05, Floris van Manen <[hidden email]> wrote:
>>
>> pygame zit standaard op de raspberry pi debian distributie.
>> En het werkt ook prima op alle andere ARM bordjes.
>>
>> .F
>>
>>
>>> On 9 Apr 2015, at 20:54, Marc Stevens <[hidden email]> wrote:
>>>
>>> Geachte python experts,
>>>
>>> Na een tijdje zoeken ben ik er achter gekomen dat je voor pygame een x86 versie van python nodig hebt.
>>> Ik heb toen python 34  gedownload want 3.5 schijnt op een of andere manier ook niet te werken.
>>> Heb daarna ook pip aan het werken gekregen, maar krijg echter ook hiermee pygame niet aan het werken.
>>> Ik heb pygame wel succesvol gedownload en geinstalleerd, maar ik kan me nog iets herinneren van mijn vorige computer dat er nog enige handelingen nodig zijn om pygame te activeren (iets van Pypi en ez_setup.py of zoiets).
>>> Verder gaat er nog iets verkeerd. Als ik Python Gui open met slechts een klik, worden er verschillende vensters geopend.
>>> De verklaring dat het allemaal niet zo lekker loopt is dat ik nu met windows 8 werk.
>>> mijn vraag : hoe krijg ik pygame aan het werken zodat ik grafische programma’s kan laten draaien en hoe krijg ik de Gui fatsoenlijk geopend.
>>>
>>>
>>>
>>> B.V.D.
>>>
>>> Groetjes Marc Stevens
>>>
>>> _______________________________________________
>>> Python-nl mailing list
>>> [hidden email]
>>> https://mail.python.org/mailman/listinfo/python-nl
>>
>> _______________________________________________
>> Python-nl mailing list
>> [hidden email]
>> https://mail.python.org/mailman/listinfo/python-nl
> _______________________________________________
> Python-nl mailing list
> [hidden email]
> https://mail.python.org/mailman/listinfo/python-nl 
> _______________________________________________
> Python-nl mailing list
> [hidden email]
> https://mail.python.org/mailman/listinfo/python-nl
_______________________________________________
Python-nl mailing list
[hidden email]
https://mail.python.org/mailman/listinfo/python-nl
Loading...