Python Tools Beta Pluing - No Toolbox Items

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Python Tools Beta Pluing - No Toolbox Items

phatfish
Hi all,

I have installed the Python Tools for Visual Studio beta 1, and im having trouble getting any tools in the WPF designer.

This has worked OK, but with the tools packaged with the IronPython install.

I actually did a fresh install on another box recently and only ever installed the beta Tools. When i create a new WPF project and drop into designer mode all the toolbox icons are greyed out.

Does anyone else have this issue, or know how to fix?

Thanks,
Chris

_______________________________________________
Users mailing list
[hidden email]
http://lists.ironpython.com/listinfo.cgi/users-ironpython.com
Reply | Threaded
Open this post in threaded view
|

Re: Python Tools Beta Pluing - No Toolbox Items

Dino Viehland

I ran into that too and it’s fixed for the next release (along w/ IronPython Silverlight debugging which was also broken).  The fix is checked in so if you can build from source you can download the current sources and do that.  Otherwise the next release should be happening in the next few days so you can probably just wait.

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of Chris
Sent: Friday, April 08, 2011 7:27 AM
To: Discussion of IronPython
Subject: [IronPython] Python Tools Beta Pluing - No Toolbox Items

 

Hi all,

I have installed the Python Tools for Visual Studio beta 1, and im having trouble getting any tools in the WPF designer.

This has worked OK, but with the tools packaged with the IronPython install.

I actually did a fresh install on another box recently and only ever installed the beta Tools. When i create a new WPF project and drop into designer mode all the toolbox icons are greyed out.

Does anyone else have this issue, or know how to fix?

Thanks,
Chris


_______________________________________________
Users mailing list
[hidden email]
http://lists.ironpython.com/listinfo.cgi/users-ironpython.com
Reply | Threaded
Open this post in threaded view
|

Re: Python Tools Beta Pluing - No Toolbox Items

phatfish
Great thanks for the heads up. Ill wait on the new beta i think.

Chris

On 8 April 2011 17:14, Dino Viehland <[hidden email]> wrote:

I ran into that too and it’s fixed for the next release (along w/ IronPython Silverlight debugging which was also broken).  The fix is checked in so if you can build from source you can download the current sources and do that.  Otherwise the next release should be happening in the next few days so you can probably just wait.

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of Chris
Sent: Friday, April 08, 2011 7:27 AM
To: Discussion of IronPython
Subject: [IronPython] Python Tools Beta Pluing - No Toolbox Items

 

Hi all,

I have installed the Python Tools for Visual Studio beta 1, and im having trouble getting any tools in the WPF designer.

This has worked OK, but with the tools packaged with the IronPython install.

I actually did a fresh install on another box recently and only ever installed the beta Tools. When i create a new WPF project and drop into designer mode all the toolbox icons are greyed out.

Does anyone else have this issue, or know how to fix?

Thanks,
Chris


_______________________________________________
Users mailing list
[hidden email]
http://lists.ironpython.com/listinfo.cgi/users-ironpython.com



_______________________________________________
Users mailing list
[hidden email]
http://lists.ironpython.com/listinfo.cgi/users-ironpython.com
Reply | Threaded
Open this post in threaded view
|

Re: Python Tools Beta Pluing - No Toolbox Items

Dave Wald
In reply to this post by phatfish
Chris,
Lest you think I gave you a bum steer the other day, here's what happened:
By the time I switched over to the new tools, I already had all my layout done in the designer, and was just working in XAML and code.
I never realized the toolbox wasn't working!
But thanks for the heads up. I would've been somewhat consternated...  ;-)

Dave

On 4/8/2011 9:26 AM, Chris wrote:
Hi all,

I have installed the Python Tools for Visual Studio beta 1, and im having trouble getting any tools in the WPF designer.

This has worked OK, but with the tools packaged with the IronPython install.

I actually did a fresh install on another box recently and only ever installed the beta Tools. When i create a new WPF project and drop into designer mode all the toolbox icons are greyed out.

Does anyone else have this issue, or know how to fix?

Thanks,
Chris
_______________________________________________ Users mailing list [hidden email] http://lists.ironpython.com/listinfo.cgi/users-ironpython.com


_______________________________________________
Users mailing list
[hidden email]
http://lists.ironpython.com/listinfo.cgi/users-ironpython.com
Reply | Threaded
Open this post in threaded view
|

Re: Python Tools Beta Pluing - No Toolbox Items

Dino Viehland

Beta 2 is now out w/ the fix for this - http://pytools.codeplex.com/releases/view/63597  It also fixes Silverlight debugging which was broken in Beta 1.  It should now be back at parity w/ IronPython Tools for pure IronPython development not to mention all the other improvements over IronPython Tools that have been made.  So please give it a try and let us know if you run into any additional issues.

 

From: [hidden email] [mailto:[hidden email]] On Behalf Of Dave Wald
Sent: Friday, April 08, 2011 7:06 PM
To: Discussion of IronPython
Subject: Re: [IronPython] Python Tools Beta Pluing - No Toolbox Items

 

Chris,
Lest you think I gave you a bum steer the other day, here's what happened:
By the time I switched over to the new tools, I already had all my layout done in the designer, and was just working in XAML and code.
I never realized the toolbox wasn't working!
But thanks for the heads up. I would've been somewhat consternated...  ;-)

Dave

On 4/8/2011 9:26 AM, Chris wrote:

Hi all,

I have installed the Python Tools for Visual Studio beta 1, and im having trouble getting any tools in the WPF designer.

This has worked OK, but with the tools packaged with the IronPython install.

I actually did a fresh install on another box recently and only ever installed the beta Tools. When i create a new WPF project and drop into designer mode all the toolbox icons are greyed out.

Does anyone else have this issue, or know how to fix?

Thanks,
Chris

 
 
_______________________________________________
Users mailing list
[hidden email]
http://lists.ironpython.com/listinfo.cgi/users-ironpython.com

 


_______________________________________________
Users mailing list
[hidden email]
http://lists.ironpython.com/listinfo.cgi/users-ironpython.com
Reply | Threaded
Open this post in threaded view
|

Re: Python Tools Beta Pluing - No Toolbox Items

Dave Wald
Looks good. Thanks, Dino

On 4/11/2011 1:53 PM, Dino Viehland wrote:

Beta 2 is now out w/ the fix for this - http://pytools.codeplex.com/releases/view/63597  It also fixes Silverlight debugging which was broken in Beta 1.  It should now be back at parity w/ IronPython Tools for pure IronPython development not to mention all the other improvements over IronPython Tools that have been made.  So please give it a try and let us know if you run into any additional issues.

 

From: [hidden email] [[hidden email]] On Behalf Of Dave Wald
Sent: Friday, April 08, 2011 7:06 PM
To: Discussion of IronPython
Subject: Re: [IronPython] Python Tools Beta Pluing - No Toolbox Items

 

Chris,
Lest you think I gave you a bum steer the other day, here's what happened:
By the time I switched over to the new tools, I already had all my layout done in the designer, and was just working in XAML and code.
I never realized the toolbox wasn't working!
But thanks for the heads up. I would've been somewhat consternated...  ;-)

Dave

On 4/8/2011 9:26 AM, Chris wrote:

Hi all,

I have installed the Python Tools for Visual Studio beta 1, and im having trouble getting any tools in the WPF designer.

This has worked OK, but with the tools packaged with the IronPython install.

I actually did a fresh install on another box recently and only ever installed the beta Tools. When i create a new WPF project and drop into designer mode all the toolbox icons are greyed out.

Does anyone else have this issue, or know how to fix?

Thanks,
Chris

 
 
_______________________________________________
Users mailing list
[hidden email]
http://lists.ironpython.com/listinfo.cgi/users-ironpython.com

 

_______________________________________________ Users mailing list [hidden email] http://lists.ironpython.com/listinfo.cgi/users-ironpython.com


_______________________________________________
Users mailing list
[hidden email]
http://lists.ironpython.com/listinfo.cgi/users-ironpython.com