Struggling newbie

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Struggling newbie

Jeff Silverman
I am running python3.4 with Django in virtualenv.  When I execute python manage.py runserver I continue to get "sqlite3.NotSupportedError: URIs not supported",  I have looked all around for posts that will point me to the solution but have not located any to date. Can anyone provide me with clues as to what I have messed up in the environment?

--
You received this message because you are subscribed to the Google Groups "Django developers (Contributions to Django itself)" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/django-developers.
To view this discussion on the web visit https://groups.google.com/d/msgid/django-developers/fb917387-fe59-4e62-867e-bdaac7bd82ce%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Struggling newbie

"Александр Христюхин (roboslone)"
Could you provide you settings file?
I think it may be an error in settings.

On 24 Aug 2016, at 23:12, [hidden email] wrote:

I am running python3.4 with Django in virtualenv.  When I execute python manage.py runserver I continue to get "sqlite3.NotSupportedError: URIs not supported",  I have looked all around for posts that will point me to the solution but have not located any to date. Can anyone provide me with clues as to what I have messed up in the environment?

--
You received this message because you are subscribed to the Google Groups "Django developers (Contributions to Django itself)" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/django-developers.
To view this discussion on the web visit https://groups.google.com/d/msgid/django-developers/fb917387-fe59-4e62-867e-bdaac7bd82ce%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "Django developers (Contributions to Django itself)" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/django-developers.
To view this discussion on the web visit https://groups.google.com/d/msgid/django-developers/72EF151D-A89A-481D-BB7E-C28AA0A46B5D%40gmail.com.
For more options, visit https://groups.google.com/d/optout.
Reply | Threaded
Open this post in threaded view
|

Re: Struggling newbie

Berker Peksağ
In reply to this post by Jeff Silverman
On Wed, Aug 24, 2016 at 11:12 PM,  <[hidden email]> wrote:
> I am running python3.4 with Django in virtualenv.  When I execute python
> manage.py runserver I continue to get "sqlite3.NotSupportedError: URIs not
> supported",  I have looked all around for posts that will point me to the
> solution but have not located any to date. Can anyone provide me with clues
> as to what I have messed up in the environment?

You need to install SQLite 3.7.7 or newer to be able to pass uri=True
to sqlite3.connect(). However, this list is for discussing the
development of Django itself, please ask usage questions on
django-users.

--Berker

--
You received this message because you are subscribed to the Google Groups "Django developers  (Contributions to Django itself)" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To post to this group, send email to [hidden email].
Visit this group at https://groups.google.com/group/django-developers.
To view this discussion on the web visit https://groups.google.com/d/msgid/django-developers/CAF4280Lk1xVxjZoCjRXrF1gf3GpkknwfA4JWg0RjphnDf9uExw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.