TypeError Qt Designer plugin import

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

TypeError Qt Designer plugin import

Adam Unger
Hi,

I'm having a problem loading custom PyQt5 plugins with Qt Designer. The example plugins available on GitHub were working and I used them to create my own plugin which was working as well. Then yesterday Designer stopped loading any of them. When I start Designer from the CLI I get:

TypeError: unwrapinstance() argument 1 must be sip.simplewrapper, not PyAnalogClockPlugin
TypeError: unwrapinstance() argument 1 must be sip.simplewrapper, not BubblesPlugin
TypeError: unwrapinstance() argument 1 must be sip.simplewrapper, not CounterLabelPlugin
TypeError: unwrapinstance() argument 1 must be sip.simplewrapper, not PyDateEditPlugin
TypeError: unwrapinstance() argument 1 must be sip.simplewrapper, not PyDateTimeEditPlugin
TypeError: unwrapinstance() argument 1 must be sip.simplewrapper, not HelloGLWidgetPlugin
TypeError: unwrapinstance() argument 1 must be sip.simplewrapper, not MultiPageWidgetPlugin
TypeError: unwrapinstance() argument 1 must be sip.simplewrapper, not PolygonWidgetPlugin
TypeError: unwrapinstance() argument 1 must be sip.simplewrapper, not PyDemoPlugin
TypeError: unwrapinstance() argument 1 must be sip.simplewrapper, not PythonConsolePlugin

I don't know where to start and Google-ing the issue didn't help either. I'm using Python 3.6.6, Qt 5.11.1, PyQt5 5.11.2, and Linux 4.17.5-1-ARCH.

What is causing this error? How do I fix it?


Thanks,


Adam Unger

[hidden email]



_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: TypeError Qt Designer plugin import

Phil Thompson-5
On 11 Jul 2018, at 7:08 am, Adam Unger <[hidden email]> wrote:

>
> Hi,
> I'm having a problem loading custom PyQt5 plugins with Qt Designer. The example plugins available on GitHub were working and I used them to create my own plugin which was working as well. Then yesterday Designer stopped loading any of them. When I start Designer from the CLI I get:
>
> TypeError: unwrapinstance() argument 1 must be sip.simplewrapper, not PyAnalogClockPlugin
> TypeError: unwrapinstance() argument 1 must be sip.simplewrapper, not BubblesPlugin
> TypeError: unwrapinstance() argument 1 must be sip.simplewrapper, not CounterLabelPlugin
> TypeError: unwrapinstance() argument 1 must be sip.simplewrapper, not PyDateEditPlugin
> TypeError: unwrapinstance() argument 1 must be sip.simplewrapper, not PyDateTimeEditPlugin
> TypeError: unwrapinstance() argument 1 must be sip.simplewrapper, not HelloGLWidgetPlugin
> TypeError: unwrapinstance() argument 1 must be sip.simplewrapper, not MultiPageWidgetPlugin
> TypeError: unwrapinstance() argument 1 must be sip.simplewrapper, not PolygonWidgetPlugin
> TypeError: unwrapinstance() argument 1 must be sip.simplewrapper, not PyDemoPlugin
> TypeError: unwrapinstance() argument 1 must be sip.simplewrapper, not PythonConsolePlugin
> I don't know where to start and Google-ing the issue didn't help either. I'm using Python 3.6.6, Qt 5.11.1, PyQt5 5.11.2, and Linux 4.17.5-1-ARCH.
>
> What is causing this error? How do I fix it?

It's a regression in PyQt v5.11.2 that also affects the qmlscene plugin. It has been fixed in the current snapshot.

Phil
_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt