Unable to run qtdemo.py : ValueError: PyCapsule

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Unable to run qtdemo.py : ValueError: PyCapsule

KanoriBull
Hi,
I have installed sip-4.19.13 and PyQt5_gpl-5.11.3 (by specifiying
./configure.py --sip <path>) on a Raspberry PI 3 from sources (no packages
found with apt or pip).

 However, I can't manage to run qtdemo.py in the examples folder :
>>>from PyQt5 import QtCore
    Traceback (most recent call last):
    File "<stdin>", line 1, in <module>
    ValueError: PyCapsule_GetPointer called with incorrect name

How can I fixed it ? I've googled it but not found any solutions...

Thanks,
Kanori



--
Sent from: http://python.6.x6.nabble.com/PyQt-f1792048.html
_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: Unable to run qtdemo.py : ValueError: PyCapsule

Phil Thompson-5
On 5 Dec 2018, at 11:55 am, KanoriBull <[hidden email]> wrote:

>
> Hi,
> I have installed sip-4.19.13 and PyQt5_gpl-5.11.3 (by specifiying
> ./configure.py --sip <path>) on a Raspberry PI 3 from sources (no packages
> found with apt or pip).
>
> However, I can't manage to run qtdemo.py in the examples folder :
>>>> from PyQt5 import QtCore
>    Traceback (most recent call last):
>    File "<stdin>", line 1, in <module>
>    ValueError: PyCapsule_GetPointer called with incorrect name
>
> How can I fixed it ? I've googled it but not found any solutions...

You haven't said how you have built sip.  At a guess...

https://pyqt.readthedocs.io/en/latest/installation.html#downloading-sip

Phil
_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt