Which version of python on OSX Lion 10.7.2

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Which version of python on OSX Lion 10.7.2

Erik van Blokland-2
Hi all,

I'm writing some code intended to help installing some python modules on OSX. There are some complications outside my control (that I hope I won't have to go into) that make it a bit of a puzzle.

The installer is targeted at Python 2.7.1 on OSX Lion 10.7.2, and this has an accessible site-packages folder at
        /Library/Python/2.7/site-packages

While trying my installer on different machines (MacBook, MacBook Pro, iMac) running Lion (OSX 10.7.2, build 11C74), most of the python versions I see are:
> Python 2.7.1 (r271:86832, Jun 16 2011, 16:59:05)
> [GCC 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2335.15.00)] on darwin

I came across a new MacBook Pro, OSX 10.7.2, also build 11C74. This one had another one:
> Python 2.7.2 (v2.7.2:8527427914a2, Jun 11 2011, 14:13:39)
> [GCC 4.0.1 (Apple Inc. build 5493)] on darwin

This machine is brand new and hasn't had any post-unpacking installations. This 2.7.2 also looks at
        /Library/Python/2.7/site-packages
..which is helpful, but this version doesn't have any of the OSX modules, no objc or AppKit.

Any other users with a similar experience? Is the 2.7.2 somehow a freak version, or are there really multiple versions floating around?

Thanks!
Erik van Blokland
_______________________________________________
Pythonmac-SIG maillist  -  [hidden email]
http://mail.python.org/mailman/listinfo/pythonmac-sig
unsubscribe: http://mail.python.org/mailman/options/Pythonmac-SIG
Reply | Threaded
Open this post in threaded view
|

Re: Which version of python on OSX Lion 10.7.2

Ned Deily
In article <[hidden email]>,
 Erik van Blokland <[hidden email]> wrote:

> Hi all,
>
> I'm writing some code intended to help installing some python modules on OSX.
> There are some complications outside my control (that I hope I won't have to
> go into) that make it a bit of a puzzle.
>
> The installer is targeted at Python 2.7.1 on OSX Lion 10.7.2, and this has an
> accessible site-packages folder at
> /Library/Python/2.7/site-packages
>
> While trying my installer on different machines (MacBook, MacBook Pro, iMac)
> running Lion (OSX 10.7.2, build 11C74), most of the python versions I see
> are:
> > Python 2.7.1 (r271:86832, Jun 16 2011, 16:59:05)
> > [GCC 4.2.1 (Based on Apple Inc. build 5658) (LLVM build 2335.15.00)] on
> > darwin
>
> I came across a new MacBook Pro, OSX 10.7.2, also build 11C74. This one had
> another one:
> > Python 2.7.2 (v2.7.2:8527427914a2, Jun 11 2011, 14:13:39)
> > [GCC 4.0.1 (Apple Inc. build 5493)] on darwin
>
> This machine is brand new and hasn't had any post-unpacking installations.
> This 2.7.2 also looks at
> /Library/Python/2.7/site-packages
> ..which is helpful, but this version doesn't have any of the OSX modules, no
> objc or AppKit.
>
> Any other users with a similar experience? Is the 2.7.2 somehow a freak
> version, or are there really multiple versions floating around?

The objc and AppKit modules are provided by Apple and so are only
available in the system Pythons.  They should always be available
regardless of whether a user installs other Pythons, which they often do
since Apple never updates system Pythons (other than the occasional
security fix).  If you are installing something that depends on the
system Python, you should explicitly invoke Python via
/usr/bin/python2.7 and, if you need to use easy_install,
/usr/bin/easy_install-2.7

--
 Ned Deily,
 [hidden email]

_______________________________________________
Pythonmac-SIG maillist  -  [hidden email]
http://mail.python.org/mailman/listinfo/pythonmac-sig
unsubscribe: http://mail.python.org/mailman/options/Pythonmac-SIG