about buildout & some python packages?

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

about buildout & some python packages?

3sso
This post was updated on .
form this <a href="http://grok.zope.org/community/grok-web-forums?janrain_nonce=2011-07-13T19%3A57%3A25ZYJacEM&openid.assoc_handle={HMAC-SHA1}{4e1df8a5}{t%2FG5Jg%3D%3D}&openid.claimed_id=http%3A%2F%2Ftakz1977.myopenid.com%2F&openid.identity=http%3A%2F%2Ftakz1977.myopenid.com%2F&openid.mode=id_res&openid.ns=http%3A%2F%2Fspecs.openid.net%2Fauth%2F2.0&openid.op_endpoint=http%3A%2F%2Fwww.myopenid.com%2Fserver&openid.response_nonce=2011-07-13T19%3A57%3A36Z8mI8QO&openid.return_to=http%3A%2F%2Fgrok.zope.org%2Fcommunity%2Fgrok-web-forums%3Fjanrain_nonce%3D2011-07-13T19%253A57%253A25ZYJacEM&openid.sig=U925UWEzB0nKK1Uv83DkKKpmX14%3D&openid.signed=assoc_handle%2Cclaimed_id%2Cidentity%2Cmode%2Cns%2Cop_endpoint%2Cresponse_nonce%2Creturn_to%2Csigned">answer

my system is Ubuntu 11.04 server 64 bit (with Python 2.7+)

the module I need "netsnmp" locate on /usr/lib/python2.7/dist-packages
it install from sudo apt-get install libsnmp-python

Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following extra packages will be installed:
  libperl5.10 libsensors4 libsnmp-base libsnmp15
Suggested packages:
  lm-sensors snmp-mibs-downloader
The following NEW packages will be installed:
  libperl5.10 libsensors4 libsnmp-base libsnmp-python libsnmp15
0 upgraded, 5 newly installed, 0 to remove and 3 not upgraded.
Need to get 1,627 kB of archives.
After this operation, 4,608 kB of additional disk space will be used.
Do you want to continue [Y/n]?

proplem with grok, grok can't import module from /usr/lib/python2.7/dist-packages but can import from /usr/local/lib/python2.7/dist-packages Jan-Wijbrand Kolman-3 who say (detail from link above) I try to read it and try to modify buildout.cfg but still not work (some option not use)

so.very simple question How? to setup buildout for use that module

ps. I try that with django it can import and I can use that module in my simple script run on python interpreter