error whle installing grok

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

error whle installing grok

shivani
Hi,

I was installing grok1.3 on linux platform but I am getting an internal error of zc.buildout.Since I am new to grok framework help is needed.

Initially I installed python2.6,after that I installed setuptools for python2.6(easy_install).But when I entered grokproject myfirstgrokproject I got following error. I am posting my error below.

First-Line of error: An internal error occurred due to a bug in either zc.buildout or in a
recipe being used

Last lines:
 File "/root/.buildout/eggs/setuptools-0.6c11-py2.6.egg/setuptools/package_index.py", line 621, in _attempt_download
    headers = self._download_to(url, filename)
  File "/root/.buildout/eggs/setuptools-0.6c11-py2.6.egg/setuptools/package_index.py", line 553, in _download_to
    size = int(headers["Content-Length"])
ValueError: invalid literal for int() with base 10: '382727, 382727'

Thank you,

With Regards,
Shivani Waradkar



_______________________________________________
Grok-dev mailing list
[hidden email]
https://mail.zope.org/mailman/listinfo/grok-dev
Reply | Threaded
Open this post in threaded view
|

Re: error whle installing grok

Jeffrey Peterson-2
This is an error in mechanize when it's installed with setuptools and/or distribute.  Manually install mechanize into your python and link or copy the egg to your eggs-dir for grok and either re-run grokproject or go into the project dirs and run ./bin/buildout to work around the issue until mechanize gets straightened out.

Jeff.

On Mar 30, 2011, at 6:02 AM, Shivani Waradkar wrote:

> Hi,
>
> I was installing grok1.3 on linux platform but I am getting an internal error of zc.buildout.Since I am new to grok framework help is needed.
>
> Initially I installed python2.6,after that I installed setuptools for python2.6(easy_install).But when I entered grokproject myfirstgrokproject I got following error. I am posting my error below.
>
> First-Line of error: An internal error occurred due to a bug in either zc.buildout or in a
> recipe being used
>
> Last lines:
>  File "/root/.buildout/eggs/setuptools-0.6c11-py2.6.egg/setuptools/package_index.py", line 621, in _attempt_download
>     headers = self._download_to(url, filename)
>   File "/root/.buildout/eggs/setuptools-0.6c11-py2.6.egg/setuptools/package_index.py", line 553, in _download_to
>     size = int(headers["Content-Length"])
> ValueError: invalid literal for int() with base 10: '382727, 382727'
>
> Thank you,
>
> With Regards,
> Shivani Waradkar
>
>
> _______________________________________________
> Grok-dev mailing list
> [hidden email]
> https://mail.zope.org/mailman/listinfo/grok-dev

_______________________________________________
Grok-dev mailing list
[hidden email]
https://mail.zope.org/mailman/listinfo/grok-dev
Reply | Threaded
Open this post in threaded view
|

Re: error whle installing grok

Christian Klinger
In reply to this post by shivani
Hi,

Not sure if it's the smartest way to fix but worked for me.

[buildout]
allow-hosts=
    *.python.org


Christian

> Hi,
>
> I was installing grok1.3 on linux platform but I am getting an internal
> error of zc.buildout.Since I am new to grok framework help is needed.
>
> Initially I installed python2.6,after that I installed setuptools for
> python2.6(easy_install).But when I entered grokproject
> myfirstgrokproject I got following error. I am posting my error below.
>
> First-Line of error: An internal error occurred due to a bug in either
> zc.buildout or in a
> recipe being used
>
> Last lines:
>   File
> "/root/.buildout/eggs/setuptools-0.6c11-py2.6.egg/setuptools/package_index.py",
> line 621, in _attempt_download
>      headers = self._download_to(url, filename)
>    File
> "/root/.buildout/eggs/setuptools-0.6c11-py2.6.egg/setuptools/package_index.py",
> line 553, in _download_to
>      size = int(headers["Content-Length"])
> ValueError: invalid literal for int() with base 10: '382727, 382727'
>
> Thank you,
>
> With Regards,
> Shivani Waradkar
>
>
>
>
> _______________________________________________
> Grok-dev mailing list
> [hidden email]
> https://mail.zope.org/mailman/listinfo/grok-dev


_______________________________________________
Grok-dev mailing list
[hidden email]
https://mail.zope.org/mailman/listinfo/grok-dev
Reply | Threaded
Open this post in threaded view
|

Re: error whle installing grok

Alexandre Garel-2
In reply to this post by Jeffrey Peterson-2
Le 30/03/2011 15:29, Jeffrey Peterson a écrit :
> This is an error in mechanize when it's installed with setuptools and/or distribute.  Manually install mechanize into your python and link or copy the egg to your eggs-dir for grok and either re-run grokproject or go into the project dirs and run ./bin/buildout to work around the issue until mechanize gets straightened out.
>
> Jeff.

I filled a bug to mechanize :
https://github.com/jjlee/mechanize/issues/#issue/39
but a fix is to be released on setuptool side :
http://bugs.python.org/setuptools/issue123

Note that

    pip install mechanize

works.


--
Alexandre Garel
06 65 04 50 81

_______________________________________________
Grok-dev mailing list
[hidden email]
https://mail.zope.org/mailman/listinfo/grok-dev
Reply | Threaded
Open this post in threaded view
|

Re: error whle installing grok

Martijn Faassen-2
In reply to this post by shivani
Hi there,

This issue now appears to have been fixed on the sourceforge.net end.

Thanks Christian Klinger for the tip to restrict downloads to
python.org, I didn't know about that approach yet. I'd been using a
download cache instead to work around this.

Regards,

Martijn


_______________________________________________
Grok-dev mailing list
[hidden email]
https://mail.zope.org/mailman/listinfo/grok-dev