installing pygtk

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

installing pygtk

Michael Bowers
 
My local python installation is 2.6, and pygtk works fine, but I need some of the features of 2.7, so I installed that locally.  Now I need the pygtk bindings but I have not been successful at installing them.
 
I downloaded pygtk-2.24.0.tar.gz.  Configured and got the following error:
 
configure: error: Package requirements (pygobject-2.0 >= 2.21.3) were not met:
No package 'pygobject-2.0' found
 
So I downloaded pygobject-2.28.4.tar.gz.  Configured and got the following error:
 
checking for GLIB - version >= 2.24.0... yes (version 2.24.1) checking for ffi... checking for FFI... no checking for GIO... yes checking for GIOUNIX... yes checking for GI... no
configure: error: Package requirements (glib-2.0 >= 2.24.0
        gobject-introspection-1.0 >= 0.10.2
    ) were not met:
No package 'gobject-introspection-1.0' found
 
Then I downloaded gobject-introspection-1.31.22.tar.xz.  Configured and got the following error:
 
checking for flex... no
checking for lex... no
configure: error: flex not found but required
 
That's where I stopped trying to install dependencies.  Is there a simpler way to do this?  Do I need all these things or can I turn some of them off or point to already installed libraries?
 
Any help would be appreciated.
 
Thanks,
 
Mike B.
 

_______________________________________________
pygtk mailing list   [hidden email]
http://www.daa.com.au/mailman/listinfo/pygtk
Read the PyGTK FAQ: http://faq.pygtk.org/
Reply | Threaded
Open this post in threaded view
|

Re: installing pygtk

Timo List
Op 27-03-13 19:47, Michael Bowers schreef:

> My local python installation is 2.6, and pygtk works fine, but I need
> some of the features of 2.7, so I installed that locally.  Now I need
> the pygtk bindings but I have not been successful at installing them.
> I downloaded pygtk-2.24.0.tar.gz.Configured and got the following error:
> configure: error: Package requirements (pygobject-2.0 >= 2.21.3) were
> not met:
> No package 'pygobject-2.0' found
> So I downloaded pygobject-2.28.4.tar.gz.Configured and got the
> following error:
> checking for GLIB - version >= 2.24.0... yes (version 2.24.1) checking
> for ffi... checking for FFI... no checking for GIO... yes checking for
> GIOUNIX... yes checking for GI... no
> configure: error: Package requirements (glib-2.0 >= 2.24.0
> gobject-introspection-1.0 >= 0.10.2
> ) were not met:
> No package 'gobject-introspection-1.0' found
> Then I downloaded gobject-introspection-1.31.22.tar.xz.Configured and
> got the following error:
> checking for flex... no
> checking for lex... no
> configure: error: flex not found but required
> That's where I stopped trying to install dependencies.  Is there a
> simpler way to do this?  Do I need all these things or can I turn some
> of them off or point to already installed libraries?

I assume you are running some Linux distribution based on some names above.

Just install the required packages through your package manager.
Remember that when you're trying to build something, you need the
development files of those packages (most likely ending in -dev).

On Ubuntu you can run the following command which will pull in all build
dependencies:
sudo apt-get build-dep python-gtk2

Timo

> Any help would be appreciated.
> Thanks,
> Mike B.
>
>
> _______________________________________________
> pygtk mailing list   [hidden email]
> http://www.daa.com.au/mailman/listinfo/pygtk
> Read the PyGTK FAQ: http://faq.pygtk.org/

_______________________________________________
pygtk mailing list   [hidden email]
http://www.daa.com.au/mailman/listinfo/pygtk
Read the PyGTK FAQ: http://faq.pygtk.org/