megrok.layout default templates for form views

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

megrok.layout default templates for form views

Jan-Jaap Driessen
Hi,

I am working with megrok.layout and am wondering why the
megrok.layout.components.Form class has the following template:

'''
grokcore.view.template('default_form_template')
'''

Where the AddForm, EditForm and DisplayForm have templates where the
html/head has been stripped out of:

'''
template = default_form_template
'''

Is this a typo or someone forgot to copy the template directive along?
I am getting duplicate html/head in my pages using the Form component.


Cheers,

Jan-Jaap
_______________________________________________
Grok-dev mailing list
[hidden email]
https://mail.zope.org/mailman/listinfo/grok-dev
Reply | Threaded
Open this post in threaded view
|

Re: megrok.layout default templates for form views

Jan-Jaap Driessen
On 5 July 2011 19:53, Jan-Jaap Driessen <[hidden email]> wrote:

> Hi,
>
> I am working with megrok.layout and am wondering why the
> megrok.layout.components.Form class has the following template:
>
> '''
> grokcore.view.template('default_form_template')
> '''
>
> Where the AddForm, EditForm and DisplayForm have templates where the
> html/head has been stripped out of:
>
> '''
> template = default_form_template
> '''
>
> Is this a typo or someone forgot to copy the template directive along?
> I am getting duplicate html/head in my pages using the Form component.

Exposed and fixed this bug in r122119:

http://svn.zope.org/megrok.layout/trunk/src/megrok/layout/components.py?rev=122119&view=rev

--
Jan-Jaap
_______________________________________________
Grok-dev mailing list
[hidden email]
https://mail.zope.org/mailman/listinfo/grok-dev
Reply | Threaded
Open this post in threaded view
|

Re: fanstatic, dolmen, PIL module missing

Aroldo Souza-Leite
Hi list,

the Dolmen test is missing a PIL module in the Python-2.7 virtual env.  
I think I already had this problem with an early Python version.

dolmenproject was installed in a virtual environment that didn't have
grokproject.

Ubuntu Lucid Lynx.

Thanks.

Regards,

  Aroldo

-------

(grok-env)aroldo@aroldo-laptop:~/tmp/python/grok-env$ echo $VIRTUAL_ENV
/home/aroldo/tmp/python/grok-env
(grok-env)aroldo@aroldo-laptop:~/tmp/python/grok-env/ which dolmenproject
/home/aroldo/tmp/python/grok-env/bin/dolmenproject
.....
(grok-env)aroldo@aroldo-laptop:~/tmp/python/grok-env/MyDolmen$ bin/test
.....
ZopeXMLConfigurationError: File
"/home/aroldo/.buildout-eggs/zope.fanstatic-0.9.1-py2.7.egg/zope/fanstatic/configure.zcml",
line 9.2-9.27
     ImportError: No module named PIL
....
Tests with errors:
    Layer: <zope.fanstatic.testing.ZopeFanstaticBrowserLayer object at
0x951e62c>
Total: 1 tests, 0 failures, 1 errors in 0.681 seconds.


_______________________________________________
Grok-dev mailing list
[hidden email]
https://mail.zope.org/mailman/listinfo/grok-dev
Reply | Threaded
Open this post in threaded view
|

Re: fanstatic, dolmen, PIL module missing

Alexandre Garel-2
Le 06/07/2011 11:23, Aroldo Souza-Leite a écrit :

> Hi list,
>
> the Dolmen test is missing a PIL module in the Python-2.7 virtual env.
> I think I already had this problem with an early Python version.
>
> dolmenproject was installed in a virtual environment that didn't have
> grokproject.
>
> Ubuntu Lucid Lynx.
>
> Thanks.
>
> Regards,
>
>    Aroldo
>
> -------
>
> (grok-env)aroldo@aroldo-laptop:~/tmp/python/grok-env$ echo $VIRTUAL_ENV
> /home/aroldo/tmp/python/grok-env
> (grok-env)aroldo@aroldo-laptop:~/tmp/python/grok-env/ which dolmenproject
> /home/aroldo/tmp/python/grok-env/bin/dolmenproject
> .....
> (grok-env)aroldo@aroldo-laptop:~/tmp/python/grok-env/MyDolmen$ bin/test
> .....
> ZopeXMLConfigurationError: File
> "/home/aroldo/.buildout-eggs/zope.fanstatic-0.9.1-py2.7.egg/zope/fanstatic/configure.zcml",
> line 9.2-9.27
>       ImportError: No module named PIL
> ....
> Tests with errors:
>      Layer:<zope.fanstatic.testing.ZopeFanstaticBrowserLayer object at
> 0x951e62c>
> Total: 1 tests, 0 failures, 1 errors in 0.681 seconds.
It seems buildout can't get PIL package.

"pip install PIL" in your virtualenv would fix it.

Regards,
Alex
_______________________________________________
Grok-dev mailing list
[hidden email]
https://mail.zope.org/mailman/listinfo/grok-dev