pip install Django==3.0

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

pip install Django==3.0

אורי
Django users,

When I use pip to install a package, does it depend on the version of Python I'm using?

pip install Django==3.0 fails with Python 3.5:

But it succeeds with Python 3.6 and 3.7. I noticed that Django 3.0 doesn't support Python 3.5. But why does pip fail?
 

--
You received this message because you are subscribed to the Google Groups "Django users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/django-users/CABD5YeG8ezgQpM7uHmVGsKMrQnw5OArZTf%3DHYTkar7s4QdHt2Q%40mail.gmail.com.
Reply | Threaded
Open this post in threaded view
|

Re: pip install Django==3.0

John McClain
try without specifying version
try without using pip

what ide are you using

‪On Mon, 2 Dec 2019 at 16:05, ‫אורי‬‎ <[hidden email]> wrote:‬
Django users,

When I use pip to install a package, does it depend on the version of Python I'm using?

pip install Django==3.0 fails with Python 3.5:

But it succeeds with Python 3.6 and 3.7. I noticed that Django 3.0 doesn't support Python 3.5. But why does pip fail?
 

--
You received this message because you are subscribed to the Google Groups "Django users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/django-users/CABD5YeG8ezgQpM7uHmVGsKMrQnw5OArZTf%3DHYTkar7s4QdHt2Q%40mail.gmail.com.


--
John McClain

Cell: 085-1977-823
Skype: jmcclain0129

--
You received this message because you are subscribed to the Google Groups "Django users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/django-users/CAN-hv_r2RHT4OwX%2B%2BZhABH3KJnn-R0ZCK%2BN6qgOKW6UnBuEpuw%40mail.gmail.com.
Reply | Threaded
Open this post in threaded view
|

Re: pip install Django==3.0

Ramiro Morales-2
In reply to this post by אורי


‪On Mon, Dec 2, 2019 at 1:06 PM ‫אורי‬‎ <[hidden email]> wrote:‬
Django users,

When I use pip to install a package, does it depend on the version of Python I'm using?

pip install Django==3.0 fails with Python 3.5:

But it succeeds with Python 3.6 and 3.7. I noticed that Django 3.0 doesn't support Python 3.5. But why does pip fail?

Django 3.0 doesn't support Python 3.5.

It's the first item in the release notes document: https://docs.djangoproject.com/en/3.0/releases/3.0/#python-compatibility

See also:


 

--
You received this message because you are subscribed to the Google Groups "Django users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/django-users/CABD5YeG8ezgQpM7uHmVGsKMrQnw5OArZTf%3DHYTkar7s4QdHt2Q%40mail.gmail.com.


--
Ramiro Morales
@ramiromorales

--
You received this message because you are subscribed to the Google Groups "Django users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/django-users/CAO7PdF-hfB3Cmao_ZLO3eD942aZFADfPNug---jANn_pXR6Q_g%40mail.gmail.com.
Reply | Threaded
Open this post in threaded view
|

Re: pip install Django==3.0

JP Smith
In reply to this post by אורי
Django 3.0 does not support Python 3.5 .


‪On Mon, Dec 2, 2019 at 11:06 AM ‫אורי‬‎ <[hidden email]> wrote:‬
Django users,

When I use pip to install a package, does it depend on the version of Python I'm using?

pip install Django==3.0 fails with Python 3.5:

But it succeeds with Python 3.6 and 3.7. I noticed that Django 3.0 doesn't support Python 3.5. But why does pip fail?
 

--
You received this message because you are subscribed to the Google Groups "Django users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/django-users/CABD5YeG8ezgQpM7uHmVGsKMrQnw5OArZTf%3DHYTkar7s4QdHt2Q%40mail.gmail.com.

--
You received this message because you are subscribed to the Google Groups "Django users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/django-users/CAD6X1ZV3wC96vDN_a4VmXYE5OZ%3DF9XLt_VLzsA4nECGP-gMMNw%40mail.gmail.com.
Reply | Threaded
Open this post in threaded view
|

Re: pip install Django==3.0

JP Smith
In reply to this post by אורי
Django 3.0 does not support Python 3.5:

--
You received this message because you are subscribed to the Google Groups "Django users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/django-users/a1b85f65-c37e-4480-b5a3-a58db634a03c%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: pip install Django==3.0

Simon Charette
In reply to this post by אורי
Dear Uri,

> When I use pip to install a package, does it depend on the version of Python I'm using?

Yes, it does.

> I noticed that Django 3.0 doesn't support Python 3.5. But why does pip fail?

Pip will respect the supported version metadata of the package. There's no package available for the Django
and Python version constraints you provided.

Instead of getting a non-nonsensical SyntaxError crash when trying to run Django on Python 3.5 pip prevents
you from shooting yourself in the foot in the first place.

Simon

Le lundi 2 décembre 2019 11:06:18 UTC-5, Uri a écrit :
Django users,

When I use pip to install a package, does it depend on the version of Python I'm using?

pip install Django==3.0 fails with Python 3.5:
<a href="https://travis-ci.org/speedy-net/speedy-net/builds/619671495" target="_blank" rel="nofollow" onmousedown="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Ftravis-ci.org%2Fspeedy-net%2Fspeedy-net%2Fbuilds%2F619671495\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHUIgmHEwRC1iyZMTT0zAvEs34ZlQ&#39;;return true;" onclick="this.href=&#39;https://www.google.com/url?q\x3dhttps%3A%2F%2Ftravis-ci.org%2Fspeedy-net%2Fspeedy-net%2Fbuilds%2F619671495\x26sa\x3dD\x26sntz\x3d1\x26usg\x3dAFQjCNHUIgmHEwRC1iyZMTT0zAvEs34ZlQ&#39;;return true;">https://travis-ci.org/speedy-net/speedy-net/builds/619671495 

But it succeeds with Python 3.6 and 3.7. I noticed that Django 3.0 doesn't support Python 3.5. But why does pip fail?
 
אורי
<a href="javascript:" target="_blank" gdf-obfuscated-mailto="nTEqI3vJCAAJ" rel="nofollow" onmousedown="this.href=&#39;javascript:&#39;;return true;" onclick="this.href=&#39;javascript:&#39;;return true;">u...@...

--
You received this message because you are subscribed to the Google Groups "Django users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/django-users/f38c74ce-dd5b-428b-b785-003e19bf147b%40googlegroups.com.
Reply | Threaded
Open this post in threaded view
|

Re: pip install Django==3.0

Abu Yusuf
In reply to this post by אורי
django-3.png
They clearly mentioned here.

photo
Abu Yusuf
Jr. Software Engineer at  Binate Solutions Ltd.
Dhaka, Bangladesh
<a href="tel:01828689381" style="text-decoration:none;font-family:sans-serif;font-size:12px;color:#4e4b4c" target="_blank"> 01828689381 
[hidden email]
https://yusuff.dev 
Linkedin https://www.linkedin.com/in/yusuf-dev/
live:9151cfda40e05eef


‪On Mon, Dec 2, 2019 at 10:05 PM ‫אורי‬‎ <[hidden email]> wrote:‬
Django users,

When I use pip to install a package, does it depend on the version of Python I'm using?

pip install Django==3.0 fails with Python 3.5:

But it succeeds with Python 3.6 and 3.7. I noticed that Django 3.0 doesn't support Python 3.5. But why does pip fail?
 

--
You received this message because you are subscribed to the Google Groups "Django users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/django-users/CABD5YeG8ezgQpM7uHmVGsKMrQnw5OArZTf%3DHYTkar7s4QdHt2Q%40mail.gmail.com.

--
You received this message because you are subscribed to the Google Groups "Django users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/django-users/CACNsr2-1dWg09_AhmbhYew_DCp%3DnaXxPHzfAEyw35YBqzj%2B0Fw%40mail.gmail.com.
Reply | Threaded
Open this post in threaded view
|

Re: pip install Django==3.0

אורי
In reply to this post by Simon Charette

On Mon, Dec 2, 2019 at 9:24 PM Simon Charette <[hidden email]> wrote:
Dear Uri,

> When I use pip to install a package, does it depend on the version of Python I'm using?

Yes, it does.

> I noticed that Django 3.0 doesn't support Python 3.5. But why does pip fail?

Pip will respect the supported version metadata of the package. There's no package available for the Django
and Python version constraints you provided.

Instead of getting a non-nonsensical SyntaxError crash when trying to run Django on Python 3.5 pip prevents
you from shooting yourself in the foot in the first place.

Simon

Thank you. I didn't know that pip is that "smart" to check the version of Python I'm using. Good to know.


--
You received this message because you are subscribed to the Google Groups "Django users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to [hidden email].
To view this discussion on the web visit https://groups.google.com/d/msgid/django-users/CABD5YeH%3Di023-gNzKMpQdARfUR%2Bf82CiVqgKJkHVzh7GqbUsog%40mail.gmail.com.