Quantcast

problem with numpy and kapteyn package

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

problem with numpy and kapteyn package

woldri
Hello everyone,

So let me explain my problem,

I had installed

scipy-0.10.0
pyfits
numpy-1.6.1
kapteyn-2.1%20(2)


and  when I run my program (written in python)
i obtained something very weird like

[Valueerror: "c_numpy.pxd", line 76, in _proj (src/_proj.c:3234)] ... in
connection with the module "wcs" in "kapteyn"...

Thinking the problem came from numpy 1.6.1 and reviewing a forum (from a
distance, and diagonally i should admit) i thought it was preferable not to
uninstall / remove  numpy 1.6.1 before installing another numpy version
which seemed to work better to solve the kind of problem i talked about ...
i therefore installed numpy 1.3.0 brutally... (by the way I do not know how
uninstall numpy 1.6.1 or remove it or downgrade to numpy 1.3 or what , and
incidentally I may well not have searched enough and the web but i did not
found how to even use numpy 1.3 when you have previously installed numpy
1.6.1 )

and now i get a very bad problem far worse than the previous (that problem,
i can quote it extensively because i have it right now on my screen):

Traceback (most recent call last):
 File "example33.py", line 5, in <module>
   import pyfits
 File
"/usr/local/lib/python2.6/dist-packages/pyfits-2.4.0-py2.6.egg/pyfits/__init__.py",
line 17, in <module>
   from core import *
 File
"/usr/local/lib/python2.6/dist-packages/pyfits-2.4.0-py2.6.egg/pyfits/core.py",
line 36, in <module>
   import numpy as np
 File "/home/boubou/.local/lib/python2.6/site-packages/numpy/__init__.py",
line 128, in <module>
   from version import git_revision as __git_revision__
ImportError: cannot import name git_revision

If anyone would be so kind as to find a way out of this problem , it would
be very very very helpful !

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

problem with numpy and kapteyn package

Tom Roche

woldri Sat, 4 Feb 2012 15:47:12 -0800 (PST)
> So let me explain my problem,

>From your explanation, your problem appears to have nothing to do with
python-mode (a part of emacs), which is the topic of this list.
Rather, you seem to have a python problem, which is better asked on a
more general python help list, e.g.,

http://mail.python.org/mailman/listinfo/tutor

or one of the Enthought (the numpy/scipy vendor) lists

http://www.scipy.org/Mailing_Lists

> i thought it was preferable not to uninstall / remove numpy 1.6.1
> before installing another numpy version which seemed to work better
> to solve the kind of problem i talked about ... i therefore
> installed numpy 1.3.0 brutally... (by the way I do not know how
> uninstall numpy 1.6.1 or remove it or downgrade to numpy 1.3 or what
> , and incidentally I may well not have searched enough and the web
> but i did not found how to even use numpy 1.3 when you have
> previously installed numpy 1.6.1 )

Note that (IIUC) the state-of-the-art way to support multiple
independent python configurations (which involves less brutality :-)
is virtualenv, about which you can get help here

http://groups.google.com/group/python-virtualenv

HTH, Tom Roche <[hidden email]>
_______________________________________________
Python-mode mailing list
[hidden email]
http://mail.python.org/mailman/listinfo/python-mode
Loading...