pyqt5 on armv6/7/8 via PyPi

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

pyqt5 on armv6/7/8 via PyPi

sebastien durand
Hello.

I am currently using pyqt for an astronomy project. In this project we want to display 16-bit images via Qimage. Is now possible with version 5.13 of Qt.

On a classic computer (amd64), no problem we can install pyqt5.13 via pypi. By cons this project is intended to equip Arm card (raspberry type). On this kind of map the only accessible version is the 5.10 via the package "python3-pyqt".

So I would like to know if there is way to install pyqt5.13 via PyPi on Arm cards?

Thanks for your help.

_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: pyqt5 on armv6/7/8 via PyPi

Phil Thompson-5
On 10/08/2019 10:57, sebastien durand wrote:

> Hello.
>
> I am currently using pyqt for an astronomy project. In this project we
> want to display 16-bit images via Qimage. Is now possible with version
> 5.13 of Qt.
>
> On a classic computer (amd64), no problem we can install pyqt5.13 via
> pypi. By cons this project is intended to equip Arm card (raspberry
> type). On this kind of map the only accessible version is the 5.10 via
> the package "python3-pyqt".
>
> So I would like to know if there is way to install pyqt5.13 via PyPi
> on Arm cards?

Not yet. sip5 will support building from sdists with pip.

Phil
_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: pyqt5 on armv6/7/8 via PyPi

sebastien durand
Is there any other way to have pyqt5.13 on armv6 / 7/8?

De : Phil Thompson <[hidden email]>
Envoyé : samedi 10 août 2019 12:09
À : sebastien durand <[hidden email]>
Cc : [hidden email] <[hidden email]>
Objet : Re: [PyQt] pyqt5 on armv6/7/8 via PyPi
 
On 10/08/2019 10:57, sebastien durand wrote:
> Hello.
>
> I am currently using pyqt for an astronomy project. In this project we
> want to display 16-bit images via Qimage. Is now possible with version
> 5.13 of Qt.
>
> On a classic computer (amd64), no problem we can install pyqt5.13 via
> pypi. By cons this project is intended to equip Arm card (raspberry
> type). On this kind of map the only accessible version is the 5.10 via
> the package "python3-pyqt".
>
> So I would like to know if there is way to install pyqt5.13 via PyPi
> on Arm cards?

Not yet. sip5 will support building from sdists with pip.

Phil

_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: pyqt5 on armv6/7/8 via PyPi

Phil Thompson-5
On 10/08/2019 12:27, sebastien durand wrote:
> Is there any other way to have pyqt5.13 on armv6 / 7/8?

Compile it yourself.

Phil

> ________________________________
> De : Phil Thompson <[hidden email]>
> Envoyé : samedi 10 août 2019 12:09
> À : sebastien durand <[hidden email]>
> Cc : [hidden email] <[hidden email]>
> Objet : Re: [PyQt] pyqt5 on armv6/7/8 via PyPi
>
> On 10/08/2019 10:57, sebastien durand wrote:
>> Hello.
>>
>> I am currently using pyqt for an astronomy project. In this project we
>> want to display 16-bit images via Qimage. Is now possible with version
>> 5.13 of Qt.
>>
>> On a classic computer (amd64), no problem we can install pyqt5.13 via
>> pypi. By cons this project is intended to equip Arm card (raspberry
>> type). On this kind of map the only accessible version is the 5.10 via
>> the package "python3-pyqt".
>>
>> So I would like to know if there is way to install pyqt5.13 via PyPi
>> on Arm cards?
>
> Not yet. sip5 will support building from sdists with pip.
>
> Phil

_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: pyqt5 on armv6/7/8 via PyPi

David Boddie
In reply to this post by sebastien durand
On Sat Aug 10 12:27:16 BST 2019, sebastien durand wrote:

> Is there any other way to have pyqt5.13 on armv6 / 7/8?

Use a Linux distribution with packages for the architecture you are using.

Debian has arm64, armel and armhf in the current stable distribution:

https://packages.debian.org/buster/python3-pyqt5

David
_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: pyqt5 on armv6/7/8 via PyPi

Kyle Altendorf
In reply to this post by sebastien durand


On August 10, 2019 5:57:31 AM EDT, sebastien durand <[hidden email]> wrote:
>So I would like to know if there is way to install pyqt5.13 via PyPi on
>Arm cards?

https://www.piwheels.org/project/PyQt5/

It looks like piwheels may have a copy.  I would check on my own pi but I'm not at home with it.  You might have to follow their instructions to setup their index, or it may already be setup.  But, don't follow their advice to run the system pip with sudo.  That's a recipe for breaking stuff.  Mostly don't run the system pip at all, even with --user.  Work in a virtualenv or venv.  https://bit.ly/py-env

Cheers,
-kyle

_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt