pyqtdeploy-sysroot: Unable to find an installation of Python v2.7

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

pyqtdeploy-sysroot: Unable to find an installation of Python v2.7

Mike-5
Dear Friends

My python version is 3.7.1, when I use the pyqtdeploy with command 'python build-demo.py'(demo from pyqtdeploy) I got the error message below:
    "pyqtdeploy-sysroot: Unable to find an installation of Python v2.7"
Please help me on how to fix it, thank you very much


Best Regars
Mike

_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: pyqtdeploy-sysroot: Unable to find an installation of Python v2.7

Phil Thompson-5
On 13/09/2019 14:29, Mike wrote:
> Dear Friends
>
>
> My python version is 3.7.1, when I use the pyqtdeploy with command
> 'python build-demo.py'(demo from pyqtdeploy) I got the error message
> below:
>     "pyqtdeploy-sysroot: Unable to find an installation of Python v2.7"
> Please help me on how to fix it, thank you very much

Install Python v2.7 which is needed to build Qt from source on Windows.

I *strongly* recommend you use a different tool, eg PyInstaller, which
you will find easier to use.

Phil
_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt
Reply | Threaded
Open this post in threaded view
|

Re: pyqtdeploy-sysroot: Unable to find an installation of Python v2.7

Mike-5
Dear Phil

I used Pyinstaller before, it's really easy to use as you said, thank you anyway with no more question on this issue.

Best regards
Mike

------------------ Original ------------------
From: "Phil Thompson"<[hidden email]>;
Date: Fri, Sep 13, 2019 10:48 PM
To: "Mike"<[hidden email]>;
Cc: "pyqt"<[hidden email]>;
Subject: Re: [PyQt] pyqtdeploy-sysroot: Unable to find an installation of Python v2.7

On 13/09/2019 14:29, Mike wrote:
> Dear Friends
>
>
> My python version is 3.7.1, when I use the pyqtdeploy with command
> 'python build-demo.py'(demo from pyqtdeploy) I got the error message
> below:
>     "pyqtdeploy-sysroot: Unable to find an installation of Python v2.7"
> Please help me on how to fix it, thank you very much

Install Python v2.7 which is needed to build Qt from source on Windows.

I *strongly* recommend you use a different tool, eg PyInstaller, which
you will find easier to use.

Phil

_______________________________________________
PyQt mailing list    [hidden email]
https://www.riverbankcomputing.com/mailman/listinfo/pyqt