setup.cfg question???

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

setup.cfg question???

Rob Healey
Greetings:

In writing the setup.cfg file, how should the attribute for
'requires-Python' should look???

>From what I can understand, it should look like:

requires-Python : '>= 2.6'

could you please show me the correct way to have this written???

--
Sincerely yours,
Rob G. Healey
_______________________________________________
Distutils-SIG maillist  -  [hidden email]
http://mail.python.org/mailman/listinfo/distutils-sig
Reply | Threaded
Open this post in threaded view
|

Re: setup.cfg question???

Éric Araujo-2
Good afternoon,

> In writing the setup.cfg file, how should the attribute for
> 'requires-Python' should look???
> From what I can understand, it should look like:
>
> requires-Python : '>= 2.6'

This is correct, except for the quote marks.  The documentation does not
presently include an example for this field; you need to combine the
information from http://docs.python.org/dev/packaging/setupcfg#syntax 
(which tells you that "requires-python =" and requires-python:" are
valid, with capitalization and whitespace ignored),
http://docs.python.org/dev/packaging/setupcfg#metadata (which says that
the value for this field is defined in PEP 345) and
http://www.python.org/dev/peps/pep-0345/#requires-python (for the
version predicate format).

Regards
_______________________________________________
Distutils-SIG maillist  -  [hidden email]
http://mail.python.org/mailman/listinfo/distutils-sig