sqlite3 + IP 2.7

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

sqlite3 + IP 2.7

Guillermo López
Hello all,

I've managed to get the sqlite3 module (https://bitbucket.org/jdhardy/ironpython.sqlite/src) working under IronPython 2.6, but it doesn't seem to work with 2.7. I couldn't find any info about compatibility with 2.7, so I'd like to know whether this is a known issue or maybe the installation instructions for 2.7 are different?

The specific error I'm getting is that IronPython can't import the _sqlite3 module.

Regards,
Guillermo

_______________________________________________
Users mailing list
[hidden email]
http://lists.ironpython.com/listinfo.cgi/users-ironpython.com
Reply | Threaded
Open this post in threaded view
|

Re: sqlite3 + IP 2.7

Jeff Hardy-4
Hi Guillermo,
I haven't tried that module against 2.7 in a while, but it should
mostly work. You'll have to build from source and adjust the
references to point to 2.7B2 - the downloadable packages are 2.6 only.

I'll update the downloads to 2.7 shortly after it's released.

- Jeff

On Mon, Feb 14, 2011 at 3:46 PM, Guillermo López
<[hidden email]> wrote:

> Hello all,
> I've managed to get the sqlite3 module
> (https://bitbucket.org/jdhardy/ironpython.sqlite/src) working under
> IronPython 2.6, but it doesn't seem to work with 2.7. I couldn't find any
> info about compatibility with 2.7, so I'd like to know whether this is a
> known issue or maybe the installation instructions for 2.7 are different?
> The specific error I'm getting is that IronPython can't import the _sqlite3
> module.
> Regards,
> Guillermo
> _______________________________________________
> Users mailing list
> [hidden email]
> http://lists.ironpython.com/listinfo.cgi/users-ironpython.com
>
>
_______________________________________________
Users mailing list
[hidden email]
http://lists.ironpython.com/listinfo.cgi/users-ironpython.com